Asterisk valt weg

Onderwerp: Asterisk valt weg

  1. Asterisk valt weg

    merry said:

    Asterisk valt weg

    Hallo,

    Heb eens rondgezocht op internet, maar kan niet uit het volgende probleem komen.

    Op mijn werk kan ik mijn standaard voip-account niet gebruiken, poort zit dicht.
    Thuis heb ik voip op mijn modem (fritzbox).
    Deze werkt goed (met voipbuster)

    Met mijn voipserver kan ik ook bellen en gebeld worden, maar gesprekken blijven maar 20 seconden, daarna is de lijn dood.

    5060 is open in de firewall.
    80 is ook open en gaat naar 5060 op de server. Via deze route kan ik bellen vanaf mijn werk.

    Ook in het locale netwerk wil het gesprek echter niet langer dan 20 seconden werken.

    Mijn setup (getallen zijn IP (192.168...):
    Server 2.10 (Qnap ts209 Pro)
    Modem 1.1 -> 1.34 router 2.1< Pc 3.10
    2.20 Router 3.1 <
    Printer 3.11



    Asterisk versie 1.4

    Modem en router 2.1 hebben alle poorten open.
    Ook als ik met de pc inlog op het 2.x netwerk krijg ik dit probleem. Dan is het probleem dus niet een gevolg van router-instellingen.

    Ik heb de 3cx softwaretelefoon gebruikt, en draai nu Express Talk, maar bij beiden wil het niet lukken.

    Iemand een idee?
    Heb geen bevredigend antwoord kunnen vinden op dit forum of een andere plaats op internet. Maar misschien niet met de juiste woorden gezocht, hoor het graag.
  2. Asterisk valt weg

    sdetroch said:
    Ik heb indertijd ook zoiets gehad (wel met Snom Voip tf's) en het probleem van het uitvallen was opgelost na de clients te wijzigen van dynamisch naar statisch toewijzen van de (communicatie)poorten (of omgekeerd, weet ik zo niet meer). Dat was een instelling die in de telefoons kon worden gedaan, weet niet of je zoiets hebt bij een softphone?
  3. Asterisk valt weg

    merry said:
    Bedankt,

    Zal het als test hier thuis proberen.
    Probleem is dat ik het ook onderweg wil gebruiken, en dan heb ik altijd een ander IP.
    (Overigens hebben mijn systemen in de router allemaal een vast adres. Wordt wel toegekend via DHCP, maar het adres is altijd hetzelfde (alleen staat dat bij mij natuurlijk nergens in Asterisk vermeld bedenk ik nu, bij Cliënt een MAC-adres invoeren is dat genoeg?))
  4. mgielissen's Avatar

    mgielissen said:
    Dit probleem heb ik vroeger ook gehad icm een speedtouch modem. Een workaround was om intern poort 5080 ipv 5060 te gebruiken voor de sip clients. De externe client connect dus ook over poort 5080.

    Dit probleem had ik later niet meer met een Zyxel modem.
  5. Asterisk valt weg

    AB-Systems said:
    Wat mij ook bekend er van is dat er vele type modems zijn dat wanneer je na circa 15 / 20 seconde geen verbinding meer hebt dat je modem het niet (goed) ondersteund.. Nieuw modem zal wonderen doen.
  6. Asterisk valt weg

    Terrorhawk said:
    Ik gok dat je een NAT probleem hebt.
    als je in je shell eens asterisk -rvvvvvvvvv doet kom je in je asterisk

    dan moet je debug even aanzetten voor je extensie

    Sip set debug 110 (debug voor extensie 110)

    als je nu gaat bellen zal je denk ik in al die rommel die je ziet ergens wat staan van NAT retry #1 t/m 5 ofzo

    Als dit het geval is moet je even je NAT poorten openzetten en je nat settings in asterisk ff goed zetten (juiste poorten en ip's gebruiken!)

    poort 5060 word eigenlijk alleen gebruikt voor het aanmelden (wat dus lukt) en je gesprek zelf gaat meestal over een NAT poort (wat ook moet omdat je dus niet direct op inet bent aangesloten)
  7. Asterisk valt weg

    merry said:
    Hallo,

    Dank voor jullie tips.
    De Nat zou best een probleem kunnen zijn.
    Welke poorten zouden er dan open moeten staan?
    Heb upnp al expres open gezet, maar dat is kennelijk niet genoeg, kan Asterisk misschien niets mee.

    Ik ga snuffelen, bedankt iig.

    Vast MAC-adres heeft niet geholpen

    Ik heb nu een Zyxel, en het probleem bestaat dus nog.
    Wat vervelender is, mijn dect telefoons gebruiken de Fritzbox 7270, en die heeft 5060 in gebruik voor voip, kan ik helaas niet aanpassen.
    Daarom zal Asterisk op 5060 moeten blijven.
    Dit is ook één van de redenen van mijn ingewikkelde netwerkconstructie met 1 modem en 2 routers (3.1 is fritz). Ik kan de voippoort namelijk niet open zetten voor de server omdat fritz deze intern gebruikt
  8. Asterisk valt weg

    axeos said:
    Citaat Oorspronkelijk geplaatst door merry Bekijk Berichten
    De Nat zou best een probleem kunnen zijn.
    Welke poorten zouden er dan open moeten staan?
    NAT zal inderdaad het probleem zijn. Na ~20 seconden gaat de RTP stroom via andere poorten lopen waarna de firewall het verkeer op de nieuwe poort niet meer verbind aan het gesprek, vandaar het symptoom.

    Als test zou naast poort 5060 ook de volgende UDP poort range kunnen openzetten: 10000 - 20000. Bij een Axeos PBX is dat de oplossing, dus wellicht werkt het ook voor jou.
  9. Asterisk valt weg

    merry said:
    hmmm

    als ik zo'n grote range open zet kan ik het onderhand wel als exposed host openen.
    Maar ga eens kijken wat ik open heb op mijn server in deze range.
    Bedankt voor de tip iig. Hier kan ik verder mee zoeken.
    Geweldige hulp hier, had ik eerder moeten doen dan weken rondzoeken
  10. Asterisk valt weg

    Blacky said:
    Ik dacht ook aan een NAT probleem maar er stond...
    Modem en router 2.1 hebben alle poorten open.
    Nu lees ik:
    als ik zo'n grote range open zet kan ik het onderhand wel als exposed host openen.
    Huh? alle poorten stonden toch open stond er in het eerste bericht?
  11. Asterisk valt weg

    rvoermans said:
    Wanneer het gesprek zo'n 20 seconden wel goed loopt, kunnen er twee oorzaken zijn (denk ik):

    1. Jij of je provider stuurt een reINVITE waardoor er nieuwe poorten voor het spraakkanaal worden gebruikt. Dit wordt niet geaccepteerd door je client/asterisk of de provider

    2. (Meest waarschijnlijke oorzaak): Jij of je provider stuurt in het sip-bericht een Expires: of Min-Expires header mee. Dit wordt door de andere kant niet ondersteund. Nadat de Expires:-timer is verlopen, wordt het gesprek verbroken. Je kunt dit oplossen door een UA te vinden die de Expires-header ondersteunt of de andere kant geen gebruik te laten maken van de Expires-header.
  12. Asterisk valt weg

    merry said:
    Poorten lijkt het toch niet te zijn, ook omdat ik lokaal het probleem ook heb (ook binnen dezelfde subgroep.)

    @rvoermans: Wat bedoel je met provider?
    Internetprovider?
    Ik ben namelijk zelf zowel mijn voip-provider als voip-client
    En lokaal heb ik niets met mijn internetprovider te maken.

    Maar zal eens kijken of ik een expires uit kan zetten
  13. Asterisk valt weg

    merry said:
    @Blacky, is mijn fout

    Ik heb net mijn structuur omgegooid, en haalde wat door elkaar.
    Modem heeft NAT aan staan.
    Router heeft NAT uit.
    Router 2 (Fritz) heeft ook NAT uit.

    Router 2 was eerst modem en daar staat nu alles open. Dat haalde ik even door elkaar.
  14. Asterisk valt weg

    Terrorhawk said:
    als je nu eens een intern gesprek voert met sip debug aan dat zou enorm helpen.
  15. Asterisk valt weg

    merry said:
    @TerrorHawk

    hmmm, misschien handig om ALLE suggesties te proberen idd.

    Na wat knutselen ziet mijn log er op dit moment zo uit:
    Code: [Bekijk]
    [Apr 27 18:31:08] WARNING[1666] chan_mgcp.c: Unable to get our IP address, MGCP disabled
    [Apr 27 18:31:08] WARNING[10237] pbx_dundi.c: Unable to look up host 'Server'
    [Apr 27 18:31:08] WARNING[1650] frame.c: Cannot allow unknown format 'undefined'
    [Apr 27 18:31:08] WARNING[1650] chan_sip.c: To disallow external domains, you need to configure local SIP domains.
    [Apr 27 18:31:13] NOTICE[1650] chan_sip.c: Can't add wildcard IP address to domain list, please add IP address to domain manually.
    [Apr 27 18:31:18] WARNING[1650] chan_sip.c: Remote host can't match request NOTIFY to call '14e351c60dfa36681cd0525360b6ea73@146.50.195.206'. Giving up.
    [Apr 27 18:31:19] WARNING[10263] app_system.c: Unable to execute 'uptime > /var/lib/asterisk/static-http/config/sysinfo_output.html'
    [Apr 27 18:31:20] WARNING[10268] ast_expr2.fl: ast_yyerror():  syntax error: syntax error, unexpected '=', expecting $end; Input:
    [Apr 27 18:31:20] WARNING[10268] ast_expr2.fl: If you have questions, please refer to doc/channelvariables.txt in the asterisk source.
    [Apr 27 18:31:25] WARNING[10268] rtp.c: RTCP Read too short
    [Apr 27 18:31:29] WARNING[10268] rtp.c: RTCP Read too short
    [Apr 27 18:31:34] WARNING[10268] rtp.c: RTCP Read too short
    [Apr 27 18:31:38] NOTICE[1650] chan_sip.c: Registration from '<sip:6001@192.168.2.10>' failed for '192.168.2.20' - Not a local domain
    [Apr 27 18:31:38] NOTICE[1650] chan_sip.c: Registration from '<sip:6001@192.168.2.10>' failed for '192.168.2.20' - Not a local domain
    [Apr 27 18:31:38] NOTICE[1650] chan_sip.c: Registration from '<sip:6001@192.168.2.10>' failed for '192.168.2.20' - Not a local domain
    [Apr 27 18:31:38] NOTICE[1650] chan_sip.c: Registration from '<sip:6001@192.168.2.10>' failed for '192.168.2.20' - Not a local domain
    [Apr 27 18:31:38] NOTICE[1650] chan_sip.c: Registration from '<sip:6001@192.168.2.10>' failed for '192.168.2.20' - Not a local domain
    [Apr 27 18:31:39] WARNING[10268] rtp.c: RTCP Read too short
    [Apr 27 18:31:42] WARNING[1650] chan_sip.c: Maximum retries exceeded on transmission 1272384337-4276-W7@192.168.2.50 for seqno 486 (Critical Response) -- See doc/sip-retransmit.txt.
    [Apr 27 18:31:42] WARNING[1650] chan_sip.c: Hanging up call 1272384337-4276-W7@192.168.2.50 - no reply to our critical packet (see doc/sip-retransmit.txt).
    Ga nog even zoeken, maar mocht iemand nu meteen al weten wat het is....