Mijn MySQL wil niet meer starten doet heel vaag.
Meer info heb ik hier gepost
http://forum.directadmin.com/showthr...671#post239671
Is er iemand die met spoed kan helpen? eventueel tegen een vergoeding?
Mijn MySQL wil niet meer starten doet heel vaag.
Meer info heb ik hier gepost
http://forum.directadmin.com/showthr...671#post239671
Is er iemand die met spoed kan helpen? eventueel tegen een vergoeding?

Heb je al geprobeerd of het lukt om een repair te draaien via ssh?
Als dit de foutmelding is zou ik eens kijken of het bestandspad in my.cnf goed staat.130608 21:35:02 mysqld_safe mysqld from pid file /var/lib/mysql/server.pid ended
130608 21:35:08 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
130608 21:35:08 [Note] Plugin 'FEDERATED' is disabled.
130608 21:35:08 InnoDB: The InnoDB memory heap is disabled
130608 21:35:08 InnoDB: Mutexes and rw_locks use GCC atomic builtins
130608 21:35:08 InnoDB: Compressed tables use zlib 1.2.3
130608 21:35:08 InnoDB: Using Linux native AIO
130608 21:35:08 InnoDB: Initializing buffer pool, size = 1.0G
130608 21:35:08 InnoDB: Completed initialization of buffer pool
130608 21:35:08 InnoDB: Error: data file /var/lib/mysql/ibdata2 uses page size 8192,
130608 21:35:08 InnoDB: but the only supported page size in this release is=16384
130608 21:35:08 InnoDB: Could not open or create data files.
130608 21:35:08 InnoDB: If you tried to add new data files, and it failed here,
130608 21:35:08 InnoDB: you should now edit innodb_data_file_path in my.cnf back
130608 21:35:08 InnoDB: to what it was, and remove the new ibdata files InnoDB created
130608 21:35:08 InnoDB: in this failed attempt. InnoDB only wrote those files full of
130608 21:35:08 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
130608 21:35:08 InnoDB: remove old data files which contain your precious data!
130608 21:35:08 [ERROR] Plugin 'InnoDB' init function returned error.
130608 21:35:08 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
130608 21:35:08 [ERROR] Unknown/unsupported storage engine: InnoDB
130608 21:35:08 [ERROR] Aborting
Laatst gewijzigd door cfmweb; 08/06/13 om 23:33.
Of een innodb recovery tool in geval van Innodb problemen?
(of een backup)
SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
Dit is gewoon een bug in MySQL zoals gezegd. Heb ik zelf ook wel eens gehad. Je kunt als het goed is MySQL gewoon opnieuw starten, misschien
dat er ergens nog een lockfile staat?
Ik weet hier niet genoeg van af.. kan iemand me even toevoegen op skype (evolutionhost) webcam is helaas kapot.. dus wordt chatten! help appreciated
Gewoon herstarten is er niet bij, de log file wordt steeds vager
Ik weet niet veel van mysql maar aan je log te zien gaat hij fout op deze melding:
Error: data file /var/lib/mysql/ibdata2 uses page size 8192,
but the only supported page size in this release is=16384
Via Google kom ik dan op deze bug uit:
http://bugs.mysql.com/bug.php?id=64160
De bug gaat over versie 5.5.20 en zou verholpen zijn in 5.5.22.
Welke versie gebruik je?
Via Directadmin had je toch al in 5.5.32 kunnen zitten? Copy maken van je database bestanden ,het e.a. in innodb recovery modus zetten en dan een update doen, dit forceert een dump wat vaak de oplossing is.
Maar kan je je je hoster je niet helpen?
Op zoek naar hostingpartijen die zich willen laten overnemen (met desgewenst aanblijven)

Hallo EvolutionHost,
Is je probleem al opgelost?
Mag toch wel hopen binnen 3 weken een spoedje verholpen is ;-)

Ik heb dit probleem ook.
Starting MySQL. ERROR! The server quit without updating PID file (/var/lib/mysql/server.mijndomein.nl.pid).
ERROR! MySQL is not running, but lock file (/var/lock/subsys/mysql) exists
Vervolgens mij een probleem met InnoDB, maar ik ben hier niet in thuis.
Zou iemand mij kunnen helpen (uiteraard tegen betaling)? Stuur me even een PM.