Nee, is een kaal CentOS bakje met Apache 2.4.3.
Likes: 0
Nee, is een kaal CentOS bakje met Apache 2.4.3.
Is het toevallig een container op basis van OpenVZ / Virtuozzo?
Nee, daar had ik al meer over gelezen. Is wel een VM op basis van vSphere 5.
Inmiddels HTTP verkeer opgelost (uitschakelen van MMAP en SendFile in Apache).
SSL nog niet verholpen.
'Opgelost' lijkt me een groot woord. sendfile problemen op een centos bak komen maar zelden voor en dan nog in specifieke gevallen alleen:
•Some platforms may have broken sendfile support that the build system did not detect, especially if the binaries were built on another box and moved to such a machine with broken sendfile support.
•On Linux the use of sendfile triggers TCP-checksum offloading bugs on certain networking cards when using IPv6.
•On Linux on Itanium, sendfile may be unable to handle files over 2GB in size.
•With a network-mounted DocumentRoot (e.g., NFS or SMB), the kernel may be unable to serve the network file through its own cache.
Heb je gelijk in, ik had ook nog niet uitgezocht wat deze twee opties doen.
Wellicht dat het toch komt door de netwerk kaart, maar andere virtuele machines (wel op CentOS 6) draaien perfect, met dezelfde configuratie en SendFile/MMAP enabled.
Zowel OpenSSL als Apache zijn gebuild op het systeem zelf.
Misschien toch de enige optie om over te gaan op CentOS 6?
Als het nu niet werkt, dan is de kans klein dat het op centos 6 wel 'plotseling' zou werken.
Heb je geen drukke site dan zul je waarschijnlijk niet veel merken van de performance hit als je sendfile disabled. Heb je wel een drukke site dan wil je dit (incl. mmap) eigenlijk wel hebben![]()
Ik heb een aantal DirectAdmin servers op CentOS 6 draaien die geen problemen hebben. Zelfde netwerkkaart, Apache en virtualisatie platform.
Ik snap ook niets van de error. Ben ook geen problemen tegengekomen met compilen van OpenSSL en Apache.
PS: 'Gelukkig' geen druk webverkeer.
Laatst gewijzigd door Nielsvk; 09/12/12 om 21:44. Reden: typo
Opgelost. Ik ben vergeten een aantal modules te laden.
ps: Met MMAP en SendFile enabled. :-)
Voor het nageslacht; Welke modules waren dat specifiek?![]()
Excuus, niet over nagedacht. Na Apache opnieuw te hebben geconfigureerd met onderstaande opties (1e instantie met enkel enable_ssl, een aantal caching modules waren hierdoor niet geactiveerd):
Code:./configure --enable-so --enable-dav --enable-dav-fs --enable-dav-lock --enable-deflate --enable-unique-id --enable-mods-static=most --enable-reqtimeout --with-mpm=prefork --enable-logio --enable-ssl --enable-rewrite --enable-proxy --enable-expires --with-ssl=/usr/bin --enable-headers