Beste webhostingtalkers,
Ik heb het probleem dat mijn mysql niet start en op websites de melding krijg: Database connection error (2): Could not connect to MySQL.
Dit is de log
120901 01:35:39 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data
120901 1:35:39 [Warning] The syntax '--log' is deprecated and will be removed in a future release. Please use '--general-log'/'--general-log-file' instead.
120901 1:35:39 [ERROR] Can't find messagefile '/usr/share/mysql/english/errmsg.sys'
120901 1:35:39 [Note] Plugin 'FEDERATED' is disabled.
120901 1:35:39 InnoDB: The InnoDB memory heap is disabled
120901 1:35:39 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120901 1:35:39 InnoDB: Compressed tables use zlib 1.2.3
120901 1:35:39 InnoDB: Using Linux native AIO
120901 1:35:39 InnoDB: Initializing buffer pool, size = 128.0M
120901 1:35:39 InnoDB: Completed initialization of buffer pool
120901 1:35:39 InnoDB: highest supported file format is Barracuda.
120901 1:35:39 InnoDB: Waiting for the background threads to start
120901 1:35:40 InnoDB: 1.1.5 started; log sequence number 22313250
120901 1:35:40 [ERROR] Aborting
120901 1:35:40 InnoDB: Starting shutdown...
120901 1:35:40 - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.
key_buffer_size=16777216
read_buffer_size=131072
max_used_connections=0
max_threads=151
thread_count=0
connection_count=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 346679 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.
Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = (nil) thread_stack 0x30000
/usr/local/mysql/bin/mysqld(my_print_stacktrace+0x39)[0x794a09]
/usr/local/mysql/bin/mysqld(handle_segfault+0x380)[0x4fcc60]
/lib/libpthread.so.0(+0xeff0)[0x7f3e87d59ff0]
/usr/local/mysql/bin/mysqld(my_stat+0x8a)[0x790ada]
/usr/local/mysql/bin/mysqld[0x778bd4]
/usr/local/mysql/bin/mysqld[0x77948e]
/lib/libpthread.so.0(pthread_once+0x53)[0x7f3e87d577a3]
/usr/local/mysql/bin/mysqld(get_charset+0x5e)[0x7794fe]
/usr/local/mysql/bin/mysqld[0x7a86a4]
/usr/local/mysql/bin/mysqld[0x8a532a]
/usr/local/mysql/bin/mysqld[0x8a5801]
/usr/local/mysql/bin/mysqld[0x891ee3]
/usr/local/mysql/bin/mysqld[0x80d1bf]
/usr/local/mysql/bin/mysqld[0x7c8e77]
/usr/local/mysql/bin/mysqld[0x8addc8]
/usr/local/mysql/bin/mysqld[0x8ae439]
/usr/local/mysql/bin/mysqld[0x8aec75]
/usr/local/mysql/bin/mysqld[0x8a49bd]
/usr/local/mysql/bin/mysqld[0x7e7baa]
/usr/local/mysql/bin/mysqld[0x7dce08]
/lib/libpthread.so.0(+0x68ca)[0x7f3e87d518ca]
/lib/libc.so.6(clone+0x6d)[0x7f3e871f392d]
The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
120901 01:35:40 mysqld_safe mysqld from pid file /usr/local/mysql/data/3j12.pid ended
120901 01:36:02 mysqld_safe Starting mysqld daemon with databases from /usr/local/mysql/data
120901 1:36:02 [Warning] The syntax '--log' is deprecated and will be removed in a future release. Please use '--general-log'/'--general-log-file' instead.
120901 1:36:02 [ERROR] Can't find messagefile '/usr/share/mysql/english/errmsg.sys'
120901 1:36:02 [Note] Plugin 'FEDERATED' is disabled.
120901 1:36:02 InnoDB: The InnoDB memory heap is disabled
120901 1:36:02 InnoDB: Mutexes and rw_locks use GCC atomic builtins
120901 1:36:02 InnoDB: Compressed tables use zlib 1.2.3
120901 1:36:02 InnoDB: Using Linux native AIO
120901 1:36:02 InnoDB: Initializing buffer pool, size = 128.0M
120901 1:36:02 InnoDB: Completed initialization of buffer pool
120901 1:36:02 InnoDB: highest supported file format is Barracuda.
120901 1:36:02 InnoDB: Waiting for the background threads to start
120901 1:36:03 InnoDB: 1.1.5 started; log sequence number 22313250
120901 1:36:03 [ERROR] Aborting
120901 1:36:03 InnoDB: Starting shutdown...
120901 1:36:04 InnoDB: Shutdown completed; log sequence number 22313250
120901 1:36:04 [Note]
120901 01:36:04 mysqld_safe mysqld from pid file /usr/local/mysql/data/3j12.pid ended
Wanner is dit gebeurt ik heb het volgende gedaan:
nano /usr/local/directadmin/custombuild/configure/ap2/configure.php5
--with-xmlrpc toegevoegt
Daarna: ./build php inside the custombuild DIR.
En vanaf toen kwam ik er achter dat mysql niet meer wou draaien kan iemand mij hier bij helpen ?

Likes:


Quote