SMTP probleem binnen Qmail (connection refused)

Onderwerp: SMTP probleem binnen Qmail (connection refused)

  1. SMTP probleem binnen Qmail (connection refused)

    ExpressNet said:

    SMTP probleem binnen Qmail (connection refused)

    [Edit]
    Het probleem is ineens opgelost. :s Heel vaag, weet nu nog de oorzaak niet.
    [/Edit]

    Hallo,

    Ik heb een probleem met mijn mailserver. Ik maak gebruik van Linux + Qmail + Clamav + Spamassassin + vpopmail.

    Mijn probleem is dat iedere mail die binnenkomt via SMTP geweigerd word (connection refused). Ik zie in de logs dat verzender en begunstigde goed zijn. Maar ik zie verder geen reden waarom de verbinding verbroken word. In outlook krijg ik de melding 451; mail server temporarily rejected message (#4.3.0).

    Vanmorgen werkte alles nog prima tot ik een server-timeout kreeg, waarna ik de server een reboot heb gegeven, vervolgens krijg ik deze problemen :s

    Logje heb ik hieronder gezet om het wat duidelijker te maken.

    Enige spoed is geboden, daar het om een productie-server gaat

    Alvast bedankt voor enige hulp.


    Marcel

    (logje: /var/log/qmail/smtp/current)
    @40000000491adbf11719fa84 tcpserver: pid 9087 from <remote-ip>
    @40000000491adbf1171a0254 tcpserver: ok 9087 <server-ip>:25 :<remote-ip>::3165
    @40000000491adbf13285e044 CHKUSER accepted sender: from <support@domein.nl:> remote <laptopmarcel:unknown:<remote-ip>> rcpt <> : sender accepted
    @40000000491adbf13889695c CHKUSER relaying rcpt: from <support@domein.nl:> remote <laptopmarcel:unknown:<remote-ip>> rcpt <info@aan-domein.nl> : client allowed to relay
    @40000000491adbf5139fa8a4 connect(): Connection refused
    @40000000491adbf73a98b1bc tcpserver: end 9087 status 0
    @40000000491adbf73a98c15c tcpserver: status: 0/1000
    (ip-adressen/domeinen zijn gemaskeerd)
    Laatst gewijzigd door ExpressNet; 12/11/08 om 14:10. Reden: Opgelost
     
  2. SMTP probleem binnen Qmail (connection refused)

    ExpressNet said:

    Probleem is terug, sort of....

    Hallo allemaal,

    Het heeft een uurtje of twee gewerkt weer, maar zit nu weer met een mailserver die niet doet wat hij moet doen.

    Als ik nu in de smtp-log kijk zie ik bij elke mail 'connect(): No such file or directory' staan. Tevens blijkt clamd zo'n beetje 90% van m'n cpu op te eisen.

    Heeft iemand enig idee of hier een verband tussen is of dat dat twee verschillende dingen zijn.

    Ik word een beetje gek van dit soort dingen, probleem komt steeds vaker terug. Kon het meestal verhelpen met een reboot, maar dit keer dus niet.

    Alvast bedankt voor de hulp.

    Marcel
    Laatst gewijzigd door ExpressNet; 12/11/08 om 17:24. Reden: tikfoutje