Goedeavond,
Op mijn server werk ik met dynamische subdomeinen, dit werkt via rewrite rules.
Dit gaat goed enkel zodra ik in een subdomein een .htaccess aanmaken met de volgende rewrite rule erin krijg ik 500 error
de vhost heb ik als volgt:Code:RewriteEngine on RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php
volgens de error log krijg ik de volgende error:Code:<VirtualHost *:80> ServerAdmin postmaster[at]domein.ext DocumentRoot /home/domein.ext ServerName domein.ext ServerAlias *.domein.ext RewriteEngine on RewriteCond %{HTTP_HOST} ^domein.ext RewriteRule ^(.*)$ /www/$1 [L] RewriteCond %{HTTP_HOST} ^www[puntje]* RewriteRule ^(.*)$ /www/$1 [L] RewriteCond %{HTTP_HOST} ^(.*)\.domein\.ext RewriteRule ^(.*)$ /%1/$1 [L] ErrorLog /home/domein.ext/logs/error_log CustomLog /home/domein.ext/logs/access_log common <Directory /> AllowOverride All </Directory> </VirtualHost>
Zelfs als ik de LimitInternalRecursion op 50 zet werkt het niet en krijg ik dezelfde error.Code:[Fri Jan 11 20:18:43 2008] [error] [client 0.0.0.0] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
Weet iemand hoe dit optelossen is?
Bedankt.
het is inmiddels opgelost
moestCode:RewriteEngine on RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php
zijnCode:RewriteEngine on RewriteRule !\.(js|ico|gif|jpg|png|css|php)$ /index.php

Likes:


Quote