Likes Likes:  0
Resultaten 1 tot 1 van de 1
  1. #1
    Apache rewrite probleem
    geregistreerd gebruiker
    10 Berichten
    Ingeschreven
    18/01/05

    Locatie
    Veldhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 17209254
    Ondernemingsnummer: nvt

    Thread Starter

    Apache rewrite probleem

    Goedeavond,

    Op mijn server werk ik met dynamische subdomeinen, dit werkt via rewrite rules.
    Dit gaat goed enkel zodra ik in een subdomein een .htaccess aanmaken met de volgende rewrite rule erin krijg ik 500 error
    Code:
    RewriteEngine on
    RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php
    de vhost heb ik als volgt:
    Code:
    <VirtualHost *:80>
        ServerAdmin postmaster[at]domein.ext
        DocumentRoot /home/domein.ext
        ServerName domein.ext
        ServerAlias *.domein.ext
    
        RewriteEngine  on
        RewriteCond    %{HTTP_HOST}  ^domein.ext
        RewriteRule    ^(.*)$        /www/$1 [L]
        RewriteCond    %{HTTP_HOST}  ^www[puntje]*
        RewriteRule    ^(.*)$        /www/$1 [L]
    
        RewriteCond    %{HTTP_HOST}  ^(.*)\.domein\.ext
        RewriteRule    ^(.*)$        /%1/$1 [L]
    
        ErrorLog /home/domein.ext/logs/error_log
        CustomLog /home/domein.ext/logs/access_log common
    
            <Directory />
            AllowOverride All
            </Directory>
    
    </VirtualHost>
    volgens de error log krijg ik de volgende error:
    Code:
    [Fri Jan 11 20:18:43 2008] [error] [client 0.0.0.0] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
    Zelfs als ik de LimitInternalRecursion op 50 zet werkt het niet en krijg ik dezelfde error.

    Weet iemand hoe dit optelossen is?

    Bedankt.

    het is inmiddels opgelost
    Code:
    RewriteEngine on
    RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php
    moest
    Code:
    RewriteEngine on
    RewriteRule !\.(js|ico|gif|jpg|png|css|php)$ /index.php
    zijn
    Laatst gewijzigd door survivor; 11/01/08 om 20:37. Reden: Automerged Dubbelpost

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics