Plesk 10.1 is gereleased:
Parallels Plesk Panel 10.1.0
[+] PBAs compatibility. Parallels Busyness Automation Standard (PBAs) software will have a full integration with Plesk 10 starting from Plesk 10.1.0 and PBAs 4.0-7.
[+] openSuSE 11.3 support.
[+] Staging websites. Simplify publishing a website in production from a staging copy with the help of 3 tools: put a website on hold while maintaining, make a copy of a production site for further changes, and publish the changed site back into production.
[+] Migration from cPanel. Migrate from cPanel and see you websites structure fitting perfectly the new Plesk 10 subscription/webspace model altogether with mail.
[+] Customization & Branding: Ability to change Branding for Admin & Reseller. A custom branded look-and-feel theme can be developed and deployed on Plesk 10 by Admin or Reseller for their customers.
[+] Applications Filters: Admin can now manage which applications are offered to a particular subscription or hosting plan. Prohibiting all applications is possible as well.
[+] One-click installer. Single script for downloading and installing Plesk on any supported Unix OS in unattended mode without a need to choose appropriate distribution or go through installation wizard. A proper distribution will be selected automatically and typical Plesk configuration will be deployed (additional components can be installed later as usual).
[+] Unzipping in File Manager. Upload ZIP archive and unzip it via File Manager for simpler website deployment.
[+] Promotions of additional mail applications. Plesk Admin sees info about additional mail solutions available for their server.
[+] Custom items in hosting plans . Extend Plesk 10 hosting plans with your additional services.
[+] External webmail services support. A third-party webmail application can be installed on the server and then made available to the customers as a webmail choice in their subscriptions.
[+] Secure scheduler manager support. Scheduler Manager was improved to provide a higher security when chrooted environment is available.
[+] Hideable mail functions in Control Panel. Hide native Plesk Mail controls from your customers if you provide an alternative mail service or none at all.
[+] Supplied components upgrade: Horde 3.3.10, Tomcat-Apache plugin mod_jk v.1.2.31.
[*] SiteBuilder, Customer and Business Manager, and Mobile Sites are completely hidden from Customer's Control Panel if the features are not provided with the Panel license.
[*] Now Plesk supports loopback interface on PVC.
[*] Now the Panel does not remove dump of the Panel database (psa) after a successful upgrade. The dump filename format is changed to mysql.preupgrade.<from version>-<to version>.<YYYYMMDD>-<hhmmss>.dump.gz.
[*] List of countries available when filling forms in the Panel is updated according to ISO 3166/MA.
[*] Now QMail accepts multiline AUTH PLAIN requests.
[*] It is possible now to control visibility and URLs of links to Parallels Store that appear on the License Management page and allow purchasing the Panel and add-on licenses.
[*] It is possible to migrate data from a Parallels Panel server where SSH is configured on a custom port.
[*] Interface Management > Language Management page is updated and now fully corrsponds to the actual functionality: the legacy buttons for adding and removing locales are deleted. Modifications to the Panel languages are now available only from command-line and programming interfaces.
[*] Users who have the root shell access to a Panel server can customize HTTPS on a subdomain level by adding a vhost_ssl.conf Apache configuration file into the conf directory of a particular subdomain.
If you need customizing Apache confgiration, we recommend that you learn the new Panel 10 feature which allows an extremely flexible customization on the server level. Address to the Apache Configuration Guide for the info.
[-] Issue resolved: Changing location of virtual host directories by running the transvhosts.pl utility failed with error "ERROR 1054 (42S22) at line 1: Unknown column 'sys_user_type' in 'where clause'".
[-] Issue resolved for upgrades to Panel 10: Subscriptions remained in status Problem Subscription after they were processed with the Transition to Panel 10 Assistant using the scheme "Subscription Inherits from the Domain".
[-] Issue resolved: Backup manager always connected to personal FTP repositories in passive mode ignoring the user settings.
[-] Issue resolved for Postfix: Now Plesk strictly configures Postfix for using IPv4.
[-] Issue resolved: SpamAssassin update script "sa-update" failed to run because of a syntax error in the script.
[-] Issue resolved: The Panel automatically disabled Horde after upgrade from Plesk 9.x.
[-] Issue resolved: SpamAssassin script "sa-update" run by cron sent the false error message 'run-parts: /etc/cron.daily/60sa-update exited with return code 1' when no new mail was in mailboxes.
[-] Issue resolved: The "Statistics" tab in the Control Panel displayed incorrect disk space usage for mail services because it also included the size of domain-specific content (configuration, logs, and such).
[-] Issue resolved: Database content was not migrated from FreeBSD servers running Plesk 9.x.
[-] Issue resolved: Watchdog did not send e-mail reports due to the following cron job error: "PHP Fatal error: Class 'OptionalServices_ServicesConfiguration' not found in /usr/local/psa/admin/plib/common_func.php3 on line 2948".
[-] Issue resolved for upgrades to Panel 10: A language pack that was active on previous Plesk version got disabled after upgrade if its sequence number in the alphabetically ordered list of languages was beyond the number of languages available with the license.
[-] Issue resolved: Upgrade from 9.x to the Panel 10 failed with the with 'Internal Error' message if a client account had the same name as a domain administrator account.
[-] Issue resolved for qmail: The mail sent to default@ mailbox was not rejected even if such mail account did not exist and mail to non-existent users was set up to be rejected.
[-] Issue resolved: The Trash directory size was not calculated against the Mailbox size.
[-] Issue resolved: After soft limits on traffic and disk space usage were set to the unlimited (0), the Panel sent notification about reaching soft limits.
[-] Issue resolved: The Panel displayed wrong backup size in Backup Manager > Personal FTP Repository if a remote vsFTPd server was used as a personal FTP repository.
[-] Issue resolved: A DNS "A" record that granted support for the WWW prefix did not appear in the Panel 10 after the upgrade from 9.5.x.
[-] A critical security vulnerability in APS applications management was resolved.
[-] Issue resolved: Upgrade to Panel 10 failed with error "Internal error: 2715" if directory structure of the virtual host template had been modified.
[-] Issue resolved: When the Panel was generating a summary report, the error "Failed to connect to SiteBuilder" occurred if SiteBuilder was not installed.
[-] Issue resolved: It was impossible to change an IP address type from shared to exclusive when only a single customer used it.
[-] Issue resolved: A site root directory was not removed during the site removal from subscription.
[-] Issue resolved: All 3rd-party modules rendered HTML markup improperly when they were called from Control Panel.
[-] Issue resolved: It was impossible to install an APS application to the root directory of a subscription.
[-] Issue resolved: SFTP server in the CHROOT environment was not enabled by default.
[-] Issue resolved: The Panel did not back up mail content for suspended domains.
[-] Issue resolved: During a full server backup, all sites content was backed up twice.
[-] Issue resolved: It was impossible to rename a domain that had subdomains.
Zitten weer interessant aantal features en bugfixes in.

Likes:


Quote
