Ik ben bezig met PHP (5.3.0) te installeren op een windows server 2003 (standard edition). Hiervoor heb ik een aparte website aangemaakt. Statische pagina's , zoals .html, kan ik gewoon aanroepen. Maar zodra ik een .php aanroep krijg ik een HTTP Error 403 - Forbidden: Access is denied. foutmelding. Ik gebruik de php-cgi.exe, en deze staat op allowed. Ook bij application extensions verwijs ik .php naar php-cgi.exe.
De rechten:
IUSR_machinenaam en IIS_WPG hebben lees/schrijf/excecute rechten op:
E:\bla\PHP (PHP directory)
E:\bla\intranet (www directory)
C:\Windows\php.ini
C:\Windows\System32\php.ini
en een filemon log:
Volgens mij zitten er dus geen problemen in de ntfs-rechten.Code:140 10:47:40 w3wp.exe:3032 OPEN E:\bla\Intranet\index.php SUCCESS Options: Open Access: Read 141 10:47:40 w3wp.exe:3032 QUERY INFORMATION E:\bla\Intranet\index.php BUFFER OVERFLOW FileFsVolumeInformation 142 10:47:40 w3wp.exe:3032 QUERY INFORMATION E:\bla\Intranet\index.php BUFFER OVERFLOW FileAllInformation 143 10:47:40 w3wp.exe:3032 CLOSE E:\bla\Intranet\index.php SUCCESS 144 10:47:40 w3wp.exe:3032 QUERY INFORMATION E:\bla\PHP\php-cgi.exe SUCCESS Attributes: A 145 10:47:40 w3wp.exe:3032 QUERY INFORMATION E:\bla\PHP\php-cgi.exe SUCCESS Attributes: A 146 10:47:40 w3wp.exe:3032 OPEN E:\bla\PHP\php-cgi.exe SUCCESS Options: Open Access: 001000A1 147 10:47:40 w3wp.exe:3032 QUERY INFORMATION E:\bla\PHP\php-cgi.exe SUCCESS Length: 39936 148 10:47:40 svchost.exe:920 OPEN E:\bla\PHP\ SUCCESS Options: Open Directory Access: 00100001 149 10:47:40 svchost.exe:920 DIRECTORY E:\bla\PHP\ SUCCESS FileBothDirectoryInformation: php-cgi.exe 150 10:47:40 svchost.exe:920 CLOSE E:\bla\PHP\ SUCCESS 151 10:47:40 svchost.exe:920 QUERY INFORMATION E:\bla\PHP\php-cgi.exe SUCCESS Attributes: A 152 10:47:40 svchost.exe:920 OPEN E:\ SUCCESS Options: Open Directory Access: 00100001 153 10:47:40 svchost.exe:920 DIRECTORY E:\ SUCCESS FileBothDirectoryInformation: bla 154 10:47:40 svchost.exe:920 CLOSE E:\ SUCCESS 155 10:47:40 svchost.exe:920 OPEN E:\bla\ SUCCESS Options: Open Directory Access: 00100001 156 10:47:40 svchost.exe:920 DIRECTORY E:\bla\ SUCCESS FileBothDirectoryInformation: PHP 157 10:47:40 svchost.exe:920 CLOSE E:\bla\ SUCCESS 158 10:47:40 svchost.exe:920 OPEN E:\bla\PHP\ SUCCESS Options: Open Directory Access: 00100001 159 10:47:40 svchost.exe:920 DIRECTORY E:\bla\PHP\ SUCCESS FileBothDirectoryInformation: php-cgi.exe 160 10:47:40 svchost.exe:920 CLOSE E:\bla\PHP\ SUCCESS 161 10:47:40 php-cgi.exe:3032 READ E:\bla\PHP\php-cgi.exe SUCCESS Offset: 24064 Length: 11264 162 10:47:40 php-cgi.exe:3032 READ E:\bla\PHP\php-cgi.exe SUCCESS Offset: 35840 Length: 4096 163 10:47:40 w3wp.exe:3032 OPEN E:\bla\PHP\php-cgi.exe.Config NOT FOUND Options: Open Access: 001200A9 164 10:47:40 w3wp.exe:3032 QUERY INFORMATION E:\bla\Intranet SUCCESS Attributes: D 165 10:47:40 csrss.exe:364 QUERY INFORMATION E:\bla\PHP\en-US NOT FOUND Attributes: Error 166 10:47:40 csrss.exe:364 QUERY INFORMATION E:\bla\PHP\en NOT FOUND Attributes: Error 167 10:47:40 csrss.exe:364 QUERY INFORMATION E:\bla\PHP\ SUCCESS Attributes: D 168 10:47:40 csrss.exe:364 QUERY INFORMATION E:\bla\PHP\ SUCCESS Attributes: D 169 10:47:40 w3wp.exe:3032 CLOSE E:\bla\PHP\php-cgi.exe SUCCESS
Als ik op de server zelf naar localhost:86\index.php ga, dan krijg ik ook een 403. IP-adres access staat op: default: granted access
Ik kom er niet uit, weet iemand wat er fout kan zijn?

Likes:


Quote