Likes Likes:  0
Resultaten 1 tot 15 van de 18
Pagina 1 van de 2 1 2 LaatsteLaatste
Geen

Onderwerp: CGI probleem

  1. #1
    CGI probleem
    webace
    44 Berichten
    Ingeschreven
    07/04/05

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    CGI probleem

    Beste Webmaster,

    Wanneer ik CGI bestanden upload en probeer te bekijken geeft hij steeds deze:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@server01.nl and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    --------------------------------------------------------------------------

    Apache/1.3.34 Server at


    Heeft iemand ook zo'n gelijkaardig probleem gehad?
    Zou het graag opgelost gezien.

  2. #2
    CGI probleem
    Cloud en Datacenters
    1.442 Berichten
    Ingeschreven
    11/06/05

    Locatie
    Zoetermeer

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    10 Berichten zijn liked


    Bedrijf: Technotop Internet BV
    URL: www.technotop.nl
    Registrar SIDN: nee
    ISPConnect: JA
    KvK nummer: 55349323
    Ondernemingsnummer: nvt

    Zelfde problemen hier gehad, kijk de logs na van apache (suexec). Dit lijkt op een rechten probleem.
    Technotop Internet BV - Sinds 2005 gespecialiseerd in cloud en datacentra.

  3. #3
    CGI probleem
    geregistreerd gebruiker
    956 Berichten
    Ingeschreven
    06/04/03

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 30179952
    Ondernemingsnummer: nvt

    Check het volgende:

    - Chmod 755?
    - Geupload in ASCII?

  4. #4
    CGI probleem
    webace
    44 Berichten
    Ingeschreven
    07/04/05

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door mihosnet
    Check het volgende:

    - Chmod 755?
    - Geupload in ASCII?
    bedankt voor de replay
    maar blijft het zelfde

    nog steeds die error

  5. #5
    CGI probleem
    geregistreerd gebruiker
    1.547 Berichten
    Ingeschreven
    12/05/03

    Locatie
    NL-Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: ITChick
    Ondernemingsnummer: nvt

    Staat de directory met Options ExecCGI ?

  6. #6
    CGI probleem
    geregistreerd gebruiker
    5.163 Berichten
    Ingeschreven
    04/06/05

    Locatie
    Zeeland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Ook een leuke:
    staat de cgi-bin wel geconfigureerd. Ooit bij freehosting weken bezig geweest had een of ander knuppel wat vergeten

  7. #7
    CGI probleem
    Banned
    2.081 Berichten
    Ingeschreven
    11/07/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 24350017
    Ondernemingsnummer: nvt

    meestal komt dit doordat de bestanden in binary of auto zijn geupload.
    9,5 van de 10 gevallen!

    Weet je zeker dat de pl en/of cgi bestanden in ASCII mode zijn geupload?

    doe anders ff een rebuild van apache (costumapache)

  8. #8
    CGI probleem
    webace
    44 Berichten
    Ingeschreven
    07/04/05

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    nog steeds het zelfde probleem
    allemaal al gedaan

  9. #9
    CGI probleem
    Cloud en Datacenters
    1.442 Berichten
    Ingeschreven
    11/06/05

    Locatie
    Zoetermeer

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    10 Berichten zijn liked


    Bedrijf: Technotop Internet BV
    URL: www.technotop.nl
    Registrar SIDN: nee
    ISPConnect: JA
    KvK nummer: 55349323
    Ondernemingsnummer: nvt

    probeer hem eerst via de terminal te runnen.

    ./blabla.cgi

    kijk wat de uitkomst is. Krijg je daar geen error en werkt alles soepel, dan moet je de rechten goed plaatsen. Krijg je wel errors dan moet je die even posten.
    Technotop Internet BV - Sinds 2005 gespecialiseerd in cloud en datacentra.

  10. #10
    CGI probleem
    Managed Hosting
    3.704 Berichten
    Ingeschreven
    26/04/04

    Locatie
    Oldenzaal

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    8 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 08157036
    Ondernemingsnummer: nvt

    in de cgi-bin map gaan staan:
    #chown -R [user] *
    #chgrp [user group] *

    zo wist ik het probleem op te lossen

  11. #11
    CGI probleem
    webace
    44 Berichten
    Ingeschreven
    07/04/05

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    het lukt spijtig genoeg nog steeds niet.

    Weet iemand raad?

  12. #12
    CGI probleem
    Programmeur / Hoster
    3.952 Berichten
    Ingeschreven
    20/06/06

    Locatie
    Wijlre

    Post Thanks / Like
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    647 Berichten zijn liked


    Naam: John Timmer
    Bedrijf: SystemDeveloper.NL
    Functie: Eigenaar
    URL: www.systemdeveloper.nl
    KvK nummer: 14083066
    View johntimmer's profile on LinkedIn

    Log in met ssh (oid) en voer het script interactief uit met

    $ perl blabla.cgi

    en kijk wat er fout gaat

    Of controleer de eerste regel van je script of daar het juiste pad naar perl staat. En kijk even of je alle perlmodulen hebt die het scriptje nodig heeft. (juiste versie en zo).

    Maak een script van 1 regel en controleer of dat wel uitgevoerd wordt. (Dan staan je rechten en apacht-conf tenminste correct). En kijk eens in de logfiles als je kunt.
    SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks

  13. #13
    CGI probleem
    Hosting & Servers
    415 Berichten
    Ingeschreven
    29/09/04

    Locatie
    Haaksbergen / Enschede

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    14 Berichten zijn liked


    Naam: Roland
    Bedrijf: IceHosting
    Functie: CEO
    URL: www.icehosting.nl
    Registrar SIDN: Ja
    KvK nummer: 08128208

    Staat de map op juiste user en chmod? Heb zelf meegemaakt dat dit ook problemen kon geven.
    IceHosting, www.icehosting.nl, +31 (0)53 700 9750, Hosting & Dedicated servers

  14. #14
    CGI probleem
    uh?
    715 Berichten
    Ingeschreven
    26/04/05

    Locatie
    Den Haag

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 27295404
    Ondernemingsnummer: nvt

    correcte eerste regel die Perl aanroept?

  15. #15
    CGI probleem
    geregistreerd gebruiker
    49 Berichten
    Ingeschreven
    05/07/06

    Locatie
    Meppel

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 04072374
    Ondernemingsnummer: nvt

    die laatste regel betekend dat je custom error documenten niet te vinden zijn

    dat eerste deel kan komen door:

    Een fout in je script;
    - Dit kan vanalles zijn, misschien de moeite om een snippet te plaatsen?
    - Begint het script met de executable? #!/usr/bin/perl
    - Heb je deze regel in het begin staan? print "Content-type: text/html\r\n\r\n";

    Bestand staat op een plek waar je geen cgi execute mag doen
    - Plaats desnoods een .htaccess bestandje met Options ExecCgi

    Niet in ascii geupload
    - Upload het bestand opnieuw en controleer of het ftp programma op ascii staat voordat het bestand gekopieerd wordt (ook niet auto, sommige ftp proggies hebben daar niet standaard cgi bestanden tussen staan...)

    Rechten niet correct
    - chmod 755 x.cgi

Pagina 1 van de 2 1 2 LaatsteLaatste

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics