Mooi dat het opgelost is. Ook even uitzetten in de custombuild, anders heb je het bij de volgende update weer aan staan.
Likes: 0
Mooi dat het opgelost is. Ook even uitzetten in de custombuild, anders heb je het bij de volgende update weer aan staan.
Nou opgelost is het feitelijk niet, Brinkie heeft op deze manier de patch ongedaan gemaakt, hij heeft de gepatchte files ook gewoon verkeerd staan want....
Bij mij ook, en bij mij staat dus in die httpd-directories-old.conf wel degelijk de vervanging naar SymlinksifOwnerMatch vermeld zoals ik vetgedrukt aangaf in mijn quote.In mijn geval symlinkt httpd-directories.conf -> httpd-directories-old.conf.
Dat betekent dus dat op een of andere wijze de patch niet volledig is uitgevoerd, anders had dat bij Brinkie ook in de post gestaan.
Apart verhaal.
Enige wat de patch doet is FollowSymLinks ombouwen naar SymLinksIfOwnerMatch in de apache broncode voor het compilen.
Wat secure_htaccess op yes zetten doet is -new gebruiken, uitgeschakeld wordt -old gesymlnikt.
Als je -old gebruikt en die fouten oplevert klopt er ergens iets niet, zonder patch of met patch; FollowSymLinks behoort dan gewoon te werken? Of ik mis iets.
Klopt, ik denk dat hij de Symlink heeft verwijderd en daarom niet meer naar -new of -old wijst.
En daarom beide ook niet meer werkte bij hem.
Er zal iets anders fout moeten zijn gegaan want in bericht nr. #15 van hem schrijft ie nog dat de symlink er is en naar old verwijst (net zoals bij ons overigens).
Maar ergens moet iets fout zijn gegaan want bij anderen werkt het wel allemaal goed zo te lezen.
Heren - dat er iets fout is, is duidelijk. Maar wat er fout is/gaat is mij volstrekt onduidelijk ik heb gewoon conform de aanwijzingen van DA gewerkt (via de aanwijzingen in de knowledgebase). Ben nog in overleg met de custombuild contributor, want die begrijpt ook niet hoe het kan.
Misschien zit er toch nog een verschilletje tussen de aanwijzingen in de knowledgebase en de aanwijzingen die DA Administrator origineel in de betreffende thread op het forum heeft gegeven.
Ik hoop dat jullie er uit komen want als er inderdaad ergens een verschil of een foutje zit, wat dit probleem zou kunnen veroorzaken is het wel belangrijk dat het opgelost wordt.
Dus mochten jullie er t.z.t. uit komen, hoor ik het graag alhier. Succes alvast!
Dus samenvattend, wat moet ik nu doen om +FollowSymLinks snel werkend te krijgen voor 1 user?
Ik zat in hetzelfde schuitje. Nieuwe server geïnstalleerd, users verplaatst, nameservers gewijzigd, en gezeik!
Heb overal de +FollowSymLinks er gelijk uit geknipt met bash, maar 1 klant heeft nu klachten over zijn Drupal installatie..
Nevermind, fixed![]()
Misschien ook leuk om even aan te geven hoe je het gefixed hebt voor als hier iemand weer eens tegenaan loopt.![]()
Wij hebben hier de nieuwe versie draaien met mod_ruid2.
Werkt perfect.
Echter gaan installaties als drupal en wordpress miepen.
Wat we daar hebben gedaan is +followsymlinks vervangen voor: +SymLinksIfOwnerMatch.
En toen waren hier alle problemen verholpen.
Zo hebben wij dat ook gedaan. Ben benieuwd of Keizer dezelfde oplossing had.
Ben ook wel benieuwd hoe Keizer dat dan gedaan heeft want in ons geval werkte +followsymlinks vervangen voor +SymLinksIfOwnerMatch dus niet. Ik blijf in bepaalde gevallen problemen houden en kan dit alleen oplossen door de eerder aangegeven "oplossing" ..
Nou mijn fix is volgens mij geen fix zoals jullie hem willen zien, vandaar dat ik hem niet gepost heb
./build secure-htaccess no
in combinatie met
Options +SymLinksIfOwnerMatch