Likes Likes:  0
Resultaten 1 tot 6 van de 6
Geen
  1. #1
    Cacti - internal server error na inloggen
    geregistreerd gebruiker
    2.562 Berichten
    Ingeschreven
    30/07/06

    Locatie
    Roden/Drenthe

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    37 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: N/B

    Thread Starter

    Cacti - internal server error na inloggen

    Zoals de titel al zegt, een probleem met cacti als volgt:

    - Inlogpagina werkt prima, inloggen ook, bij een fout wachtwoord krijg je daar een melding van
    - Na het inloggen komt er een error pagina (internal server error).

    Opzich zou dat best kunnen echter:

    - Er is niks te vinden in logs, cacti log wordt niet meer aangemaakt
    - Het heeft eerder gewoon gewerkt (maanden lang), er is niets aangepast op de server noch in de cacti config.
    - Zodra de mapnaam aangepast wordt (bijv van domein.com/cacti naar domein.com/cacti2) werkt het weer prima voor enkele minuten/uren. Echter lijken de grafieken dood te blijven.

    Enige tijd geleden dit probleem ook gehad, destijds niet kunnen vinden waar de oorzaak zat, op internet is hier (voor zo ver ik toen en nu gezocht heb) niets over te vinden.

    Cacti opnieuw installeren is opzich geen groot probleem daar instellingen zo overgenomen kunnen worden, echter moet er toch een oorzaak zijn lijkt me.

    Iemand hier enige ervaring me/enig idee wat de oplossing kan zijn?

  2. #2
    Cacti - internal server error na inloggen
    För Sverige i tiden
    2.859 Berichten
    Ingeschreven
    21/02/06

    Locatie
    Egmond Aan Zee / Stockholm Zweden

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    10 Berichten zijn liked


    KvK nummer: 37128170

    .htaccess file is een mogelijke oorzaak. Of een oproep naar een niet bestaand module.

  3. #3
    Cacti - internal server error na inloggen
    geregistreerd gebruiker
    518 Berichten
    Ingeschreven
    16/09/05

    Locatie
    Terneuzen

    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    12 Berichten zijn liked


    Naam: Frank Buijze
    Bedrijf: FraJa WeB
    Functie: Eigenaar
    URL: www.frajaweb.nl
    Registrar SIDN: ja
    ISPConnect: Lid
    KvK nummer: 58893962
    Ondernemingsnummer: nvt

    Beste,

    Hierbij enkele tips om verder te speuren.

    1. Kijk eens in de Apache error logs. Deze geven vaak meer informatie bij een internal server error.
    2. Na het inloggen wordt er een loop veroorzaakt. Dit kan veroorzaakt worden door een verkeerde symlink, of een fouter rewrite rule in .htaccess. Of een foute alias, proxy of rewrite in de apache configuratie.
    3. Een fout in de .htaccess kan resulteren in een internal server error. Aangezien dat deze bestanden verborgen zijn, zijn ze wat moeilijk terug te vinden. Het kan zijn dat het bij redirect bij cacti fout gaat en bij een cacti het probleem zich niet meer voor doet.

    Dit laatste heb ik namelijk al een keer ondervonden.

  4. #4
    Cacti - internal server error na inloggen
    geregistreerd gebruiker
    2.562 Berichten
    Ingeschreven
    30/07/06

    Locatie
    Roden/Drenthe

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    37 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: N/B

    Thread Starter
    Citaat Oorspronkelijk geplaatst door frajaweb Bekijk Berichten
    Beste,

    Hierbij enkele tips om verder te speuren.

    1. Kijk eens in de Apache error logs. Deze geven vaak meer informatie bij een internal server error.
    2. Na het inloggen wordt er een loop veroorzaakt. Dit kan veroorzaakt worden door een verkeerde symlink, of een fouter rewrite rule in .htaccess. Of een foute alias, proxy of rewrite in de apache configuratie.
    3. Een fout in de .htaccess kan resulteren in een internal server error. Aangezien dat deze bestanden verborgen zijn, zijn ze wat moeilijk terug te vinden. Het kan zijn dat het bij redirect bij cacti fout gaat en bij een cacti het probleem zich niet meer voor doet.

    Dit laatste heb ik namelijk al een keer ondervonden.
    1. Zie openingposts, niks in logs te vinden hierover

    Daarnaast lijk .htaccess erg onwaarschijnlijk, zoals ik zei heeft het prima gewerkt, daarnaast werkt het ook gewoon als ik de naam van de map aanpas (van bijv. cacti naar cacti2), enige tijd later komt ook daar de internal server error, echter als ik hem dan weer terugzet naar cacti, werkt het eerst weer.

    Daarnaast maakt het hele domein geen gebruik van htaccess bestanden.

  5. #5
    Cacti - internal server error na inloggen
    Meneer de Directeur
    12.253 Berichten
    Ingeschreven
    11/05/04

    Locatie
    Valkenswaard / Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 17186890

    Heb je niet iets van ModSecurity runnen?

  6. #6
    Cacti - internal server error na inloggen
    Geregistreerd Gebruiker
    4.755 Berichten
    Ingeschreven
    23/04/05

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    353 Berichten zijn liked


    Naam: Toin Bloo
    Bedrijf: Dommel Hosting
    URL: www.dommelhosting.nl
    ISPConnect: Lid
    KvK nummer: 17177247

    is "enige tijd" wellicht gerelateerd aan een aantal seconden of aan een aantal requests?

    en misschien dat cacti abusievelijk de filerechten van een directory of file anders chmod als er een aantal samples zijn genomen

    misschien dat er wel een disk of partitie vol is?

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics