Likes: 0
Zoals Randy al zei, bruteforce wordt niet zoveel gedaan, gewoon een trojan die alles doorspeeld langs de klant hun zijde. Moet je gelijk ook je key login beperken per IP etc. Het is allemaal niet zo makkelijk en klantvriendelijk.
Een goede antivirus langs de klant hun zijde doet ook al wonderen, is zelfs makkelijker uit te leggen. Maar of dat het gaat tegen houden is ook iets anders...
je kan voor ftp (oa proftpd) ook prima mod_clamav draaien waarmee je dit soort scriptjes netjes tegen kan houden.
mikeh's angst voor brute-force is makkelijk te blokkeren met behulp van CSF/LFD of fail2ban
Er komt ook nog zoiets als "beslissingsrecht" bij kijken, als eigenaar dat onhandig vindt dat je klanten dingen moet gaan leren, dan gaat het niet door. Ik ben slechts reseller met onderhoudsfunktie.
Iemand hier nog ideeën over.
Dat is dus wat in die apache sessie files komt in de /tmp elke 10 minuten ofzo... Ik zie thans geen vreemde dingen meer in de logs.Code:Alpha|i:-1;Bravo|s:16:"IVEGOTNOPASSWORD";
Of wordt dat veroorzaakt door dit soort dingen?
Daarnaast wil ik graag het gebruik van perl script door klanten uitschakelen, daarmee zou dat ook voorkomen moeten kunnen worden, toch. Daarvoor had ik perl gechmod, met als gevolg dat CSF niet meer wenst te werken, dus dat gaat al niet door helaas.[Mon Jun 29 15:10:03 2009] [error] [client 88.80.199.117] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23):
/w00tw00t.at.ISC.SANS.DFind![]()
Ik denk dat als ik dat doe, er nog meer dingen meer niet gaan werken, toch?
Het perl script was nu gebruikt was, werd gestart onder de gebruiker zijn accountnaam. Is er geen optie dat je alleen kunt voorkomen dat de gebruiker het niet meer kan starten?
Want ik neem aan dat mod_perl nog meer doet dan alleen gebruikers gelegenheid geven om perl scripts te starten?
Zou het uitvinken van de cgi optie in de pakketten niet ook al dat resultaat teweeg brengen?