Een gekende fout, maar via google vind ik geen oplossing?
Het bestand in kwestie staat er inderdaad niet meer...
Likes: 0
Een gekende fout, maar via google vind ik geen oplossing?
Het bestand in kwestie staat er inderdaad niet meer...
Kijken in je config file waar je socket normaal staat. Als hij daar niet staat, controleren als je mysql wel gestart is, en goed loopt. Gewoon eerst een command line proberen...
Deze al geprobeerd ?
http://linux.ittoolbox.com/groups/te...-socket-968937
http://www.google.nl/search?hl=nl&q=...G=Zoeken&meta=Oorspronkelijk geplaatst door soulplayer
Technotop Internet BV - Sinds 2005 gespecialiseerd in cloud en datacentra.
Oorspronkelijk geplaatst door wonko
Mijn mysql wil niet starten doordat hij dat bestand niet vindt.
en no offence, maar het lukt met niet met die schitterende tutorials... Ik vind dat bestand nergens meer op mijn server....
Laatst gewijzigd door soulplayer; 21/07/06 om 14:36.
Dat bestand zul je alleen vinden als mysql gestart is. Dus jou analyse dat mysql niet wil starten omdat die file er niet is, is niet juist.Oorspronkelijk geplaatst door soulplayer
Zul je toch ergens anders moeten zoeken naar de oorzaak van het niet willen starten van mysql.
kan ik gewoon mysql uninstallen en opnieuw installen zonder dat de databases verloren gaan?
Zo ja hoe?
En op de google pagina's zie ik enkel mensen die het probleem ook hebben, geen echte oplossing...
Laatst gewijzigd door soulplayer; 21/07/06 om 16:40. Reden: Automerged Doublepost
Heb je ooit wel eens de logfiles nagekeken naar de errormeldingen die er zijn?
Kijk eens of de /var/run/mysqld/ directory nog bestaat en de juiste rechten heeft. Start mysqld vanuit een shell en kijk naar de meldingen in de log.
Of maak desnoods een mysql config file aan en zet daarin waar het socket aangemaakt moet worden.
Lijkt me toch sneller gedaan dan opnieuw installeren en je db's weer aan de praat krijgen met de juiste gebruikersrechten.
SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
dit geeft hij als error:
Hoe laat ik hem dan die file opnieuw genereren?Jul 21 17:00:01 S1E2R3V4R5 /etc/init.d/mysql[20352]: 1 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' resulted in
Jul 21 17:00:01 S1E2R3V4R5 /etc/init.d/mysql[20352]: ^G/usr/bin/mysqladmin: connect to server at 'localhost' failed
Jul 21 17:00:01 S1E2R3V4R5 /etc/init.d/mysql[20352]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
Jul 21 17:00:01 S1E2R3V4R5 /etc/init.d/mysql[20352]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
Jul 21 17:00:01 S1E2R3V4R5 /etc/init.d/mysql[20352]:
Jul 21 17:00:01 S1E2R3V4R5 /etc/init.d/mysql[20357]: /etc/mysql/debian-log-rotate.conf is obsolete, see /usr/share/doc/mysql-server-5.0/NEWS.Debian.gz
Laatst gewijzigd door soulplayer; 21/07/06 om 17:07.
Waarschijnlijk heeft mysql niet voldoende rechten op die dir.
Je kunt de /var/run/mysql/ chown'-en naar de mysql-user en kijken of je mysql dan wel kunt starten. Of je chmod de dir even naar 777![]()
SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
Ik heb de beide geprobeerd, en neen hij blijft dezelfde error geven...
en wat staat er in de config file voor path aangegeven?
default is namelijk /tmp
Zoek je my.cnf (standaard in /etc/my.cnf).
Als je de my.cnf niet ziet, controleer dan of je mysqld misschien met de parameter:
--defaults-file=/misschien-een-ander-pad/my.cnf
hebt gestart. Zo niet, maak je my.cnf gewoon in /etc/ aan.
Pleur er het volgende in:
[mysqld]
socket=/var/run/mysqld/mysql.sock
err-log=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
Stop de mysqld. Start de mysqld.
Check /var/log/mysqld.log en controleer de errors.
Als dit niet werkt en je wil een rekening van 15 minuten, dan gooi je maar een ssh login over de schutting
Suc6![]()
SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks