"1 processes alive"
Wellicht is er nog een proces actief waardoor mysql niet start?
Geloof dat je met killall mysql alle prosessen sluit?
Likes: 0
"1 processes alive"
Wellicht is er nog een proces actief waardoor mysql niet start?
Geloof dat je met killall mysql alle prosessen sluit?
Uhmm.. ja, met killall -9 [procnaam] kom ik een heel eind
Maar netter is om het via de normale manier te doen. ( .../mysql stop dus)
SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
Mijn mysql wil volgens mij gewoon niet meer opstarten:
Na /etc/init.d/mysql start:S1E2R3V4R5:~# /etc/init.d/mysql
Usage: /etc/init.d/mysql start|stop|restart|reload|force-reload|status
S1E2R3V4R5:~# /etc/init.d/mysql status
MySQL is stopped.
Na het stop command:S1E2R3V4R5:~# /etc/init.d/mysql start
Starting MySQL database server: mysqld.
.
.
.
.
.
.
.
.
.
.
.
.
.
...failed or took more than 6s.
Please take a look at the syslog.
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
My.cnf:S1E2R3V4R5:~# /etc/init.d/mysql stop
Stopping MySQL database server: mysqld...failed.
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
Killing MySQL database server by signal: mysqld.
#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/se...variables.html
# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock
# Here is entries for some specific programs
# The following values assume you have at least 32M ram
# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0
[mysqld]
#
# * Basic Settings
#
user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql
tmpdir = /tmp
language = /usr/share/mysql/english
skip-external-locking
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
old_passwords = 1
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address = 127.0.0.1
#
# * Fine Tuning
#
key_buffer = 16M
max_allowed_packet = 16M
thread_stack = 128K
#
# * Query Cache Configuration
#
query_cache_limit = 1048576
query_cache_size = 16777216
query_cache_type = 1
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log = /var/log/mysql.log
#log = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement
#
# Here you can see queries with especially long duration
#log-slow-queries = /var/log/mysql/mysql-slow.log
#
# The following can be used as easy to replay backup logs or for replication.
#server-id = 1
log-bin = /var/log/mysql/mysql-bin.log
expire-logs-days = 20
max_binlog_size = 104857600
#binlog-do-db = include_database_name
#binlog-ignore-db = include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# If you want to enable SSL support (recommended) read the manual or my
# HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt.gz
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem
[mysqldump]
quick
quote-names
max_allowed_packet = 16M
[mysql]
#no-auto-rehash # faster start of mysql but no tab completition
[isamchk]
key_buffer = 16M
#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the ndbd storage daemons,
# not from the ndb_mgmd management daemon.
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1
Probeer eens handmatig mysql te stoppen.. doe eens ps aux | grep mysqld , als het goed zie je dan de PIDs van mysqld, die stoppen met kill -9 pid
Hij verandert de hele tijd van pid
S1E2R3V4R5:~# ps aux | grep mysqld
root 526 0.0 0.0 1756 572 pts/0 R+ 19:12 0:00 grep mysqld
S1E2R3V4R5:~# ps aux | grep mysqld
root 528 0.0 0.0 1756 572 pts/0 R+ 19:12 0:00 grep mysqld
S1E2R3V4R5:~# ps aux | grep mysqld
root 530 0.0 0.0 1756 572 pts/0 R+ 19:12 0:00 grep mysqld
S1E2R3V4R5:~# ps aux | grep mysqld
root 532 0.0 0.0 1756 572 pts/0 R+ 19:12 0:00 grep mysqld
S1E2R3V4R5:~# ps aux | grep mysqld
root 534 0.0 0.0 1756 572 pts/0 R+ 19:12 0:00 grep mysqld
S1E2R3V4R5:~# ps aux | grep mysqld
root 536 0.0 0.0 1756 572 pts/0 R+ 19:12 0:00 grep mysqld
S1E2R3V4R5:~# ps aux | grep mysqld
root 538 0.0 0.0 1756 572 pts/0 R+ 19:12 0:00 grep mysqld
S1E2R3V4R5:~# ps aux | grep mysqld
root 540 0.0 0.0 1756 572 pts/0 R+ 19:12 0:00 grep mysqld
S1E2R3V4R5:~#

Hier heeft men nou logfiles voor uitgevonden.
idd en die kan je dus lezen op de vorige pagina...
hij verandert van pid... :S
SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
Wat staat er voor "ps -aux | grep mysql" na een mysql-start?
Probeer het eens zonder my.cnf, werkt het dan wel? Als je my.cnf even renamed naar my.cnf.bak?
Het kan komen door een foutieve my.cnf instelling. En anders kun je eventueel MySQL + alle onderdelen updaten naar de nieuwste versie, desnoods met --force.
nop dat gaat ook niet, ik ben eens aan het kijken wat een "upgrade" doet.
wat staat er in de /etc/mysql/debian.cnf file?
Ok het is gefixed
Ik heb alles gewoon geupgrade:
apt-get upgrade
en nu doet hij het opnieuw. Nu nog mijn andere fout oplossen![]()
alleen weet je nu niet wat de oorzaak was...
Neen dat is waar, maar die file die ik niet had, is terug dus misschien was het dat.
Merci voor de hulp ! Ik hoop dat ik dezelfde kan krijgen bij deze tread: http://www.webhostingtalk.nl/scripti...ergegeven.html
Stop je mysql eens.. zul je zien dat die file ook weg is![]()