Beste mensen,
Ik ben 2 dagen geleden begonnen met het installeren van een nieuwe asterisk server. Het begin ging zeer voorspoedig echter kwam het onweer al snel.
Wat is nu het probleem. Ik heb een nummer bij Budgetphone. In de config heb ik dit ingesteld en hij lijkt goed te registeren.
Als ik mijn nummer bel krijg ik echter te horen dat het nummer niet bestaat. Ik heb via de console geprobeerd uit te zoeken waar dit mee te maken heeft. Volgens de foutmelding bestaat de extensie niet.
Nou snap ik er niets van. Ik heb de extensie wel aangemaakt. Ik heb alle gegevens onderaan bijgevoegd.
Mijn vraag aan jullie waar doe ik het fout.
Mijn sip.conf
Mijn extensions.confCode:[general] context=default bindport=5060 bindaddr=0.0.0.0 svrlookup=yes register => 31717110290:<ww>@budgetphone.nl/31717110290 [budgetphone] nat=no type=friend host=sip.budgetphone.nl fromuser=31717110290 username=31717110290 secret=<ww> qualify=no fromdomain=budgetphone.nl context=incoming insecure=very [1000] type=friend context=toll-access host=dynamic callerid="1000" <10> canreinvite=no disallow=all allow=gsm allow=alaw qualify=no secret=1234
De asterisk console zegtCode:[default] static=yes writeprotect=no autofallthrough=yes clearglobalvars=no priorityjumping=no exten => 31717110290,1,Dial(SIP/1000,20) [generals] [globals] [extensions] exten => _XX,1,Dial(SIP/${EXTEN},13) exten => _XX,n,GotoIf($["${DIALSTATUS}" = "BUSY"]?busy,unavail) exten => _XX,n(unavail),VOiceMail(1000@default,u) exten => _XX,n,Hangup() exten => _XX,n(busy),VoiceMail(1000@default,u) exten => _XX,n,Hangup() exten => 900,1,VoiceMailMain() [toll-access] include => extensions exten => _0XXXX.,1,Dial(SIP/${EXTEN}@budgetphone) [incoming] exten => s,1,Dial(SIP/1000,20) exten => 501,1,Dial(SIP/1000,20) ;exten => 31717110290,1,Goto(SIP/1000,1) [1000] exten => s,1,Dial(SIP/1000,20) [31717110290] exten => s,1,Dial(SIP/1000,20)
Als ik bel naar 071-7110290Code:Asterisk*CLI> reload [Jun 26 21:03:01] NOTICE[1548]: cdr.c:1373 do_reload: CDR simple logging enabled. [Jun 26 21:03:01] NOTICE[1548]: manager.c:2923 init_manager: Unable to open management configuration manager.conf. Call management disabled. == RTP Allocating from port range 5000 -> 31000 Asterisk Event Logger restarted Asterisk Queue Logger restarted -- Reloading module 'res_musiconhold.so' (Music On Hold Resource) -- Reloading module 'res_adsi.so' (ADSI Resource) -- Reloading module 'res_crypto.so' (Cryptographic Digital Signatures) -- Reloading module 'app_meetme.so' (MeetMe conference bridge) -- Reloading module 'app_voicemail.so' (Comedian Mail (Voicemail System)) == Parsing '/etc/asterisk/voicemail.conf': Found -- Reloading module 'codec_adpcm.so' (Adaptive Differential PCM Coder/Decoder) -- Reloading module 'chan_zap.so' (Zapata Telephony) [Jun 26 21:03:01] ERROR[1548]: chan_zap.c:11295 setup_zap: Unable to load config zapata.conf -- Reloading module 'codec_gsm.so' (GSM Coder/Decoder) -- Reloading module 'codec_lpc10.so' (LPC10 2.4kbps Coder/Decoder) -- Reloading module 'codec_ulaw.so' (mu-Law Coder/Decoder) -- Reloading module 'app_playback.so' (Sound File Playback Application) -- Reloading module 'codec_zap.so' (Generic Zaptel Transcoder Codec Translator) -- Reloading module 'codec_g726.so' (ITU G.726-32kbps G726 Transcoder) -- Reloading module 'chan_sip.so' (Session Initiation Protocol (SIP)) Reloading SIP == Parsing '/etc/asterisk/sip.conf': Found -- Reloading module 'codec_alaw.so' (A-law Coder/Decoder) -- Reloading module 'pbx_config.so' (Text Extension Configuration) == Parsing '/etc/asterisk/extensions.conf': Found -- Registered extension context 'default' -- Added extension '31717110290' priority 1 to default -- Registered extension context 'generals' -- Registered extension context 'extensions' -- Added extension '_XX' priority 1 to extensions -- Added extension '_XX' priority 2 to extensions -- Added extension '_XX' priority 3 to extensions -- Added extension '_XX' priority 4 to extensions -- Added extension '_XX' priority 5 to extensions -- Added extension '_XX' priority 6 to extensions -- Added extension '900' priority 1 to extensions -- Registered extension context 'toll-access' -- Including context 'extensions' in context 'toll-access' -- Added extension '_0XXXX.' priority 1 to toll-access -- Registered extension context 'incoming' -- Added extension 's' priority 1 to incoming -- Added extension '1000' priority 1 to incoming -- Registered extension context '1000' -- Added extension 's' priority 1 to 1000 -- Registered extension context '31717110290' -- Added extension 's' priority 1 to 31717110290 -- ast_get_srv: SRV lookup for '_sip._udp.budgetphone.nl' mapped to host proxy.sipthor.net, port 5060
[Jun 26 21:09:13] NOTICE[1419]: chan_sip.c:15094 handle_request_subscribe: Received SIP subscribe for peer without mailbox: 1000
[Jun 26 21:09:14] NOTICE[1419]: chan_sip.c:14035 handle_request_invite: Call from '31717110290' to extension '31717110290' rejected because extension not found.

Likes:



Quote