Resultaten 1 tot 6 van de 6

Onderwerp: Proxmox cluster

  1. #1
    Proxmox cluster
    www.xenius.be
    1.524 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    40 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter

    Proxmox cluster

    Even de vraag in het Engels aangezien ik ze ook op het Proxmox forum heb gezet.. misschien dat iemand hier het antwoord direct weet ;-)

    I'm trying to create a new 2 node cluster (that we'll extend to a 3 node HA cluster in a couple of weeks)..
    Currently I got 2 nodes:

    prox01 - 192.168.100.171
    prox02 - 192.168.100.174

    both nodes are configured with a default proxmox 4.2 setup and basic network config, on prox01 I executed the

    pvecm create CLUSTER01 command to create the cluster

    but when I than run a pvecm status I receive the following error:

    Cannot initialize CMAP service

    I searched a bit in the forums and found a thread where someone stated that this is an error that occurs on single node clusters (which we have at this point)..
    So i continued the manual and on prox02 I executed the

    pvecm add 192.168.100.171

    command. I received the SSH warning and trusted the relationship between them , entered my root password for prox01 but after a couple of seconds I receive the error "Couldn't copy SSH key".

    I don't know what i'm doing wrong, but I think it isn't normal that i receive te cannot initialize CMAP service on my first node ?

    Can somebody help me out ?

    with regards,
    Xenius.be | Our solutions, our products, your success !

  2. #2
    Proxmox cluster
    geregistreerd gebruiker
    505 Berichten
    Ingeschreven
    26/01/10

    Locatie
    Zierikzee

    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    12 Berichten zijn liked


    Naam: Peter
    Bedrijf: WebhostNow
    URL: www.webhostnow.nl
    Registrar SIDN: NEE
    ISPConnect: Lid
    KvK nummer: 20169256

    Waarschijnlijk is je cluster niet quorate.

    Probeer eens: pvecm expected 1

    Werkt dat niet?

    service pve-cluster stop
    pmxcfs -l

    En pas je quorate file aan (node verwijderen. Hierna rebooten en nog eens proberen).

    Maak wel even een backupje van de bestanden.



  3. #3
    Proxmox cluster
    www.xenius.be
    1.524 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    40 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter
    mmm nee dat werkt ook niet..
    De cluster is inderdaad niet quorate maar dat is ook logisch, ik wil net een cluster maken :-) dit is dus de eerste node waarop ik de cluster services activeer dus ook logisch dat er geen quorum is..

    mvg,
    Xenius.be | Our solutions, our products, your success !

  4. #4
    Proxmox cluster
    Dennis.
    3.786 Berichten
    Ingeschreven
    11/07/06

    Locatie
    Oosterhout

    Post Thanks / Like
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    262 Berichten zijn liked


    Naam: Dennis
    Registrar SIDN: JA
    KvK nummer: 20144338

    Als je de SSH keys handmatig er in plaatst en dan nog een keer de node toevoegt aan het cluster?
    Proxmox gaat eerst de SSH keys toevoegen en daarna als dat succesvol is de configuraties aan maken van het cluster / node die toegevoegd is.

  5. #5
    Proxmox cluster
    geregistreerd gebruiker
    505 Berichten
    Ingeschreven
    26/01/10

    Locatie
    Zierikzee

    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    12 Berichten zijn liked


    Naam: Peter
    Bedrijf: WebhostNow
    URL: www.webhostnow.nl
    Registrar SIDN: NEE
    ISPConnect: Lid
    KvK nummer: 20169256

    Citaat Oorspronkelijk geplaatst door bibawa Bekijk Berichten
    mmm nee dat werkt ook niet..
    De cluster is inderdaad niet quorate maar dat is ook logisch, ik wil net een cluster maken :-) dit is dus de eerste node waarop ik de cluster services activeer dus ook logisch dat er geen quorum is..

    mvg,
    Wanneer er slechts één node aanwezig is, zou het quorate moeten zijn. Wanneer dat niet zo is gaat alles in read-only en kan je geen wijzigingen maken/services opstarten. Kan je eens een ls uitvoeren in /etc/pve en de output doorgeven?

  6. #6
    Proxmox cluster
    www.xenius.be
    1.524 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    40 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter
    Ik heb er deze avond even zelf nog eens wat mee zitten spelen en heb de corosync service op prox01 kunnen startten. Blijkbaar was de corosync.conf file zo ingesteld dat deze bound was op een verkeerd IP adres, heb dit gewijzigd naar zijn lokaal ip 192.168.100.171 en daarna kwam de service op en kwam er ook output van een pvecm status.

    Dus ik helemaal blij, op prox02 aangemeld en daar die node toegevoegd aan het cluster ip 192.168.100.171 via de commando's, hij kwam me deze keer opnieuw vragen naar het ssh wachtwoord en begon daarna vrolijk vanalles te kopieren, echter bij de stap "backup exsising db" blijft hij hangen en uiteindelijk crasht hij daar dan ook op..

    Vraag ik dan op prox01 een status op van de cluster dan is deze opnieuw gecrasht zoals voorheen met dezelfde foutmelding...

    Ik denk dat ik iets fundamenteels fout doe :-)
    Xenius.be | Our solutions, our products, your success !

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2018 Webhostingtalk.nl.
Web Statistics