Hulp gevraagd. Apache en pHp starten niet meer na update

Onderwerp: Hulp gevraagd. Apache en pHp starten niet meer na update

  1. Hulp gevraagd. Apache en pHp starten niet meer na update

    balen001 said:

    Hulp gevraagd. Apache en pHp starten niet meer na update

    Ik heb een VPS draaien met enkele websites. Niet commercieel. Gewoon een hobby. De VPS draait op CentOS en DirectAdmin. De pHp versie was verouderd en ik had de laatste tijd last van een spammer. Ik heb er tegenaan gehikt maar uiteindelijk besloten om de update uit te voeren. Als eerste heb ik CentOs geüpgraded naar versie 6.6. Vervolgens heb ik geprobeerd om met yum de pHp versie te updaten. Zo te zien liep alles goed maar het resultaat was dat de oude versie nog steeds aanwezig was. Googelen leverde op dat de procedure voor een server met CentOs met DirectAdmin anders was. Via Custombuild. Hier bleek de versie van Custombuild ook verouderd. Deze heb ik eerst geüpgraded naar versie 2.0. Dat is goed gegaan. Vervolgens heb ik de upgrade van pHp uitgevoerd:
    cd /usr/local/directadmin/custombuild
    ./build set php1_release 5.6
    ./build update
    ./build php n
    ./build rewrite_confs

    Dit leek goed te gaan tot op het laatste moment, zie het laatste deel van het logfile. Volgens DirectAdmin is pHp 5.6 geïnstalleerd maar draait niet. En Apache wil niet meer starten. Zie de afbeelding uit DirectAdmin. Wat heb ik over het hoofd gezien of verkeerd gedaan?


    Laatste deel logfile:
    Zend/zend_execute.lo main/internal_functions_cli.lo sapi/cgi/cgi_main.lo sapi/cgi/fastcgi.lo -lcrypt -lz -lexslt -lcrypt -lrt -lmcrypt -lltdl -lstdc++ -liconv -lpng -lz -ljpeg -lcurl -lz -lpcre -lrt -lm -ldl -lnsl -lxml2 -lz -liconv -lm -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lssl -lcrypto -lcurl -lxml2 -lz -liconv -lm -lssl -lcrypto -lfreetype -lz -ldl -lm -licui18n -licuuc -licudata -ldl -lm -licuio -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lcrypt -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxml2 -lz -liconv -lm -lxslt -lxml2 -lz -liconv -lm -lssl -lcrypto -lcrypt -o sapi/cgi/php-cgi
    /bin/sh /usr/local/directadmin/custombuild/php-5.6.26/libtool --silent --preserve-dup-deps --mode=install cp ext/opcache/opcache.la /usr/local/directadmin/custombuild/php-5.6.26/modules
    Generating phar.php
    Generating phar.phar
    PEAR package PHP_Archive not installed: generated phar will require PHP's phar extension be enabled.
    clicommand.inc
    directorygraphiterator.inc
    invertedregexiterator.inc
    directorytreeiterator.inc
    pharcommand.inc
    phar.inc

    Build complete.
    Don't forget to run 'make test'.

    Make Complete
    Making PHP 5.6 installation compatible with php.ini file
    Installing php...
    Installing PHP SAPI module: apache2handler
    /var/www/build/instdso.sh SH_LIBTOOL='/var/www/build/libtool' libphp5.la /usr/lib/apache
    /var/www/build/libtool --mode=install cp libphp5.la /usr/lib/apache/
    cp .libs/libphp5.so /usr/lib/apache/libphp5.so
    cp .libs/libphp5.lai /usr/lib/apache/libphp5.la
    libtool: install: warning: remember to run `libtool --finish /usr/local/directadmin/custombuild/php-5.6.26/libs'
    chmod 755 /usr/lib/apache/libphp5.so
    [activating module `php5' in /etc/httpd/conf/httpd.conf]
    Installing shared extensions: /usr/local/lib/php/extensions/no-debug-non-zts-20131226/
    Installing PHP CLI binary: /usr/local/bin/
    Installing PHP CLI man page: /usr/local/php/man/man1/
    Installing PHP CGI binary: /usr/local/bin/
    Installing PHP CGI man page: /usr/local/php/man/man1/
    Installing build environment: /usr/local/lib/php/build/
    Installing header files: /usr/local/include/php/
    Installing helper programs: /usr/local/bin/
    program: phpize
    program: php-config
    Installing man pages: /usr/local/php/man/man1/
    page: phpize.1
    page: php-config.1
    Installing PEAR environment: /usr/local/lib/php/
    Failed loading /usr/local/lib/ioncube_loader_lin_5.3.so: /usr/local/lib/ioncube_loader_lin_5.3.so: undefined symbol: execute
    Zend Guard Loader requires Zend Engine API version 220090626.
    The Zend Engine API version 220131226 which is installed, is newer.
    Contact Zend Technologies at http://www.zend.com/ for a later version of Zend Guard Loader.

    [PEAR] Archive_Tar - upgraded: 1.4.0
    [PEAR] Console_Getopt - upgraded: 1.4.1
    pear/pear dependency package "pear/Structures_Graph" downloaded version 1.1.1 is not the recommended version 1.0.4, but may be compatible, use --force to install
    pear/Structures_Graph cannot be installed, conflicts with installed packages
    [PEAR] Structures_Graph- upgraded: 1.1.1
    pear/pear dependency package "pear/XML_Util" downloaded version 1.3.0 is not the recommended version 1.2.3, but may be compatible, use --force to install
    pear/XML_Util cannot be installed, conflicts with installed packages
    [PEAR] XML_Util - upgraded: 1.3.0
    [PEAR] PEAR - upgraded: 1.10.1
    Wrote PEAR system config file at: /usr/local/etc/pear.conf
    You may want to add: /usr/local/lib/php to your php.ini include_path
    /usr/local/directadmin/custombuild/php-5.6.26/build/shtool install -c ext/phar/phar.phar /usr/local/bin
    ln -s -f phar.phar /usr/local/bin/phar
    Installing PDO headers: /usr/local/include/php/ext/pdo/
    Copying php.ini..
    /usr/local/lib/php.ini already exists, skipping.
    Enabling mail.add_x_header option in /usr/local/lib/php.ini
    PHP 5.6.26 Installed.
    Rewriting all users httpd.conf files, please wait...
    Debug mode. Level 10

    dataskq: command: action=rewrite&value=httpd
    Restarting apache.
    Stopping httpd: [ OK ]
    Starting httpd: httpd: Syntax error on line 19 of /etc/httpd/conf/httpd.conf: Syntax error on line 3 of /etc/httpd/conf/extra/httpd-phpmodules.conf: Cannot load /usr/lib/apache/mod_mpm_prefork.so into server: /usr/lib/apache/mod_mpm_prefork.so: cannot open shared object file: No such file or directory

    [root@mijnsites custombuild]#

    (unknown) at 17:31 ...

    The system is going down for reboot NOW!
    Control-Alt-Delete pressed
    Bijgevoegde Thumbnails Bijgevoegde Thumbnails
    Laatst gewijzigd door balen001; 11/10/16 om 08:41.
    Ik ben een n00b op het gebied van hosting. Van fotografie, CameraHobby, weet ik meer.
  2. systemdeveloper's Avatar

    systemdeveloper said:
    ./build apache nog even doen
    SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
  3. Hulp gevraagd. Apache en pHp starten niet meer na update

    balen001 said:
    #systemdeveloper , dank voor jouw reactie en meedenken. Geprobeerd, helpt niet.

    Laatste stukje van het logfile:

    Restarting apache.
    Stopping httpd: [FAILED]
    Starting httpd: httpd: Syntax error on line 19 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf/extra/ht
    tpd-phpmodules.conf: Cannot load /usr/lib/apache/mod_ruid2.so into server: /usr/lib/apache/mod_ruid2.so: undefined symbol: unixd
    _config
    [FAILED]
    Ik ben een n00b op het gebied van hosting. Van fotografie, CameraHobby, weet ik meer.
  4. systemdeveloper's Avatar

    systemdeveloper said:
    dan ook ./build mod_ruid2 doen

    Let goed op de meldingen, he. Als je php update met 'n' gaat dat niet altijd lekker als je naar een te hoge versie gaat.
    Vaak moeten alle modulen ook hercompileerd worden.

    Je kunt een ./build all doen. Duurt even een kwartier of zo, maar dan heb je wel alles werkend (waarschijnlijk).
    SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
  5. Hulp gevraagd. Apache en pHp starten niet meer na update

    balen001 said:
    Aanvulling op bovenstaande

    Regel 19 uit httpd.conf is:
    Include /etc/httpd/conf/extra/httpd-phpmodules.conf

    Regel 1 uit httpd-phpmodules.conf is:
    LoadModule ruid2_module /usr/lib/apache/mod_ruid2.so
    Ik ben een n00b op het gebied van hosting. Van fotografie, CameraHobby, weet ik meer.
  6. Hulp gevraagd. Apache en pHp starten niet meer na update

    balen001 said:
    ./build mod_ruid2 uitgevoerd. geeft nu een fout in en andere regel

    Restarting apache.
    Stopping httpd: [FAILED]
    Starting httpd: httpd: Syntax error on line 19 of /etc/httpd/conf/httpd.conf: Syntax error on line 4 of /etc/httpd/conf/extra/httpd-phpmodules.conf: Cannot load /usr/lib/apache/libphp5.so into server: /usr/lib/apache/libphp5.so: undefined symbol: unixd_config
    [FAILED]

    heb nu ./build all gestart.
    Ik ben een n00b op het gebied van hosting. Van fotografie, CameraHobby, weet ik meer.
  7. systemdeveloper's Avatar

    systemdeveloper said:
    Als het niet lukt na die build all dan wil ik wel even free voor je kijken.
    SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
  8. Hulp gevraagd. Apache en pHp starten niet meer na update

    balen001 said:
    #systemdeveloper je bent een topper het lijkt weer te werken. Mijn websites zijn weer up!

    Alleen nu is het proces ProFTPd 1.3.4b gestopt. zie de afbeelding hierboven.
    Ik ben een n00b op het gebied van hosting. Van fotografie, CameraHobby, weet ik meer.
  9. systemdeveloper's Avatar

    systemdeveloper said:
    Citaat Oorspronkelijk geplaatst door balen001 Bekijk Berichten
    #systemdeveloper je bent een topper het lijkt weer te werken. Mijn websites zijn weer up!

    Alleen nu is het proces ProFTPd 1.3.4b gestopt. zie de afbeelding hierboven.
    Doe eens een 'service proftpd restart' en kijk eens in de logs dan?
    SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
  10. Hulp gevraagd. Apache en pHp starten niet meer na update

    balen001 said:

    andere ftp server?

    Gek, bij het opnieuw opvragen van de systeeminformatie geeft DirectAdmin aan dat een andere ftp server is geinstalleerd: pure-ftpd 1.0.43 en draait

    Hulp gevraagd. Apache en pHp starten niet meer na update-screenhunter_207-oct-11-11-04-jpg
    Ik ben een n00b op het gebied van hosting. Van fotografie, CameraHobby, weet ik meer.
  11. Hulp gevraagd. Apache en pHp starten niet meer na update

    vDong said:
    Als je daar mee kan leven zou ik dat zo laten. Die 2 zijn redelijk uitwisselbaar.

    In de options.conf staat wel een mogelijkheid om ze te wisselen, maar doe dat alleen als je nu issues met ftp hebt.
  12. systemdeveloper's Avatar

    systemdeveloper said:
    pure-ftpd is tegenwoordig de standaard.

    Het lijkt erop dat je wellicht een oude config had.
    SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks
  13. Hulp gevraagd. Apache en pHp starten niet meer na update

    balen001 said:
    De FTP server draait en is toegankelijk. Ik laat het dan maar zo.

    Mag ik jou, #systemdeveloper , hartelijk bedanken voor jouw hulp. Echt top

    Nu kan ik aan de volgende klus beginnen. Het updaten mijn mijn websites.
    Ik ben een n00b op het gebied van hosting. Van fotografie, CameraHobby, weet ik meer.
  14. systemdeveloper's Avatar

    systemdeveloper said:
    yw, succes met de websites
    SystemDeveloper.NL - 64BitsWebhosting.EU : Softwareontwikkeling & Hosting freaks