Likes Likes:  0
Resultaten 1 tot 13 van de 13
Geen
  1. #1
    Centos 6.5 Permission denied
    www.xenius.be
    1.555 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter

    Centos 6.5 Permission denied

    Ik zit m'n hoofd al een aantal dagen te breken over zaken die om een of andere reden niet werkend te krijgen zijn op een nieuw geinstalleerde centos 6.5 server. Zaken die vroeger wel gewoon zonder problemen werkten stoot ik nu op permission denied errors:

    - yum install mysql-server
    De installatie lukt maar de na-configuratie lukt niet, ik stoot hier op een 'permission error (13)' in de default mysql directories (/var/lib/mysql/...)

    Hier heb ik rond kunnen werken door de mysql directories te verplaatsen naar /usr/local en de my.cnf aan te passen

    Tot hier kon ik er mee leven en dacht dat het aan de mysql installatie zou liggen.. vergeet het !

    - Installatie van zabbix server: installatie loopt als een trein, als zabbix gestart word krijg je een permission denied (13) op /var/zabbix-server/zabbix_server.log

    selinux staat disabled, permissies staan goed en ik kan manueel de file ook aanmaken..

    Na lang googlen heb ik het mysql probleem dus kunnen omzeilen door alles te verplaatsen naar de /usr folder de reden zou iets te maken hebben met fstab maar de solver van het probleem in dat topic wist het ook niet verder.. ik ook niet meer :-)

    Iemand enige ervaring / advies in deze ?
    Xenius.be | Our solutions, our products, your success !

  2. #2
    Centos 6.5 Permission denied
    geregistreerd gebruiker
    390 Berichten
    Ingeschreven
    11/01/10

    Locatie
    Houten

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Kevin Bentlage
    Bedrijf: Cobytes B.V.
    Functie: CTO / Founder
    URL: www.cobytes.com
    Registrar SIDN: nee
    KvK nummer: 67974139
    Ondernemingsnummer: nvt
    View kevinbentlage's profile on LinkedIn

    Vreemd verhaal, je zou verwachten dat dit soort problemen niet optreden op een schone 6.5 install. Ik heb vorige week nog een schone install gedaan met een LAMP configuratie via Yum, geen problemen.

    Kun je handmatig wel directories of files aanmaken onder /var? Misschien is je /var (om welke reden dan ook) in een Read-Only mode terrecht gekomen?

    Ik neem aan dat je met root rechten de packages installeerd?
    Kwalitatieve managed hosting met een persoonlijke service.

  3. #3
    Centos 6.5 Permission denied
    www.xenius.be
    1.555 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter
    Als ik nu bijvoorbeeld zabbix start:

    [root@srv log]# /etc/init.d/zabbix_server start
    Starting Zabbix Server: zabbix_server [17343]: cannot open [/var/log/zabbix-server/zabbix_server.log]: [13] Permission denied
    [ OK ]

    ik kan zabbix_server.log gewoon touchen op die locatie zonder problemen, van zodra ik het move naar /usr/local doet het probleem zich niet meer voor, met het mysql probleem zei men dat het te maken had met het feit dat er in /fstab geen mountpoint naar /usr/local was en voor /var wel wat het probleem zou veroorzaken.. vaag !
    Xenius.be | Our solutions, our products, your success !

  4. #4
    Centos 6.5 Permission denied
    www.xenius.be
    1.555 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter
    Verschil wat ik hier wel zie is dat /var ext4 is en op een andere server ext3.. zou dit een probleem kunnen veroorzaken ?
    Xenius.be | Our solutions, our products, your success !

  5. #5
    Centos 6.5 Permission denied
    ISPConnect
    3.772 Berichten
    Ingeschreven
    10/01/07

    Locatie
    Nieuwegein

    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    134 Berichten zijn liked


    Naam: Marin Heideman
    Bedrijf: DigiState B.V.
    URL: http://www.digistate.nl
    ISPConnect: Lid
    View mheideman's profile on LinkedIn

    Ik denk dat het Selinux is. Zet die eens op Permissive en kijk eens wat ie dan doet? Werkt het dan wel moet je de Selinux config ff napluizen
    Marin Heideman (DigiState B.V.)

  6. #6
    Centos 6.5 Permission denied
    www.xenius.be
    1.555 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter
    SELinux staat disabled dus die hoort niets te doen... :-)

    Log file van zabbix verzet naar /usr/local/zabbix/log en het werkt als een trein..
    Niet echt de bedoeling wel niet
    Xenius.be | Our solutions, our products, your success !

  7. #7
    Centos 6.5 Permission denied
    Professional
    3.115 Berichten
    Ingeschreven
    05/02/05

    Locatie
    Alkmaar

    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    101 Berichten zijn liked


    Naam: Thomas
    Registrar SIDN: JA
    ISPConnect: Lid
    KvK nummer: 76706966

    Ik gok toch op een mount optie die verkeerd staat op /var. Kun je de output van mount en /etc/fstab eens neer zetten?

  8. #8
    Centos 6.5 Permission denied
    www.xenius.be
    1.555 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter
    Mount:

    Code:
    [root@srv user]# mount
    /dev/sda2 on / type ext4 (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    devpts on /dev/pts type devpts (rw,gid=5,mode=620)
    tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
    /dev/sda1 on /boot type ext4 (rw)
    /dev/sda3 on /tmp type ext4 (rw)
    /dev/mapper/vg_cdp01-LogVol_VAR on /var type ext4 (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
    FSTAB:

    Code:
    UUID=f13e2f02-4df0-41ac-b7a7-d112e82ca6d0 /                       ext4    defaults        1 1
    UUID=47c52738-4256-46b5-a238-97c783d93acb /boot                   ext4    defaults        1 2
    UUID=b3e90e1b-99a1-42da-a4fb-57d945ef514b /tmp                    ext4    defaults        1 2
    /dev/mapper/vg_cdp01-LogVol_VAR /var                    ext4    defaults        1 2
    UUID=7462433d-0877-49cf-ba67-bbd4838ca58b swap                    swap    defaults        0 0
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    Op diezelfde server draait ook een Idera CDP en dit zonder issues, de disk is 2TB groot (zit hier nu een probleem mee ...) en Idera schrijft zijn backups ook zonder problemen op /var/idera weg, die installatie heeft gedraait zonder issues.
    Xenius.be | Our solutions, our products, your success !

  9. #9
    Centos 6.5 Permission denied
    geregistreerd gebruiker
    390 Berichten
    Ingeschreven
    11/01/10

    Locatie
    Houten

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Kevin Bentlage
    Bedrijf: Cobytes B.V.
    Functie: CTO / Founder
    URL: www.cobytes.com
    Registrar SIDN: nee
    KvK nummer: 67974139
    Ondernemingsnummer: nvt
    View kevinbentlage's profile on LinkedIn

    Vreemd, geen vreemde chmod's of chowns op je /var staan waardoor jij als ROOT wel dingen kunt die mysql of zabbix niet kunnen?
    Kwalitatieve managed hosting met een persoonlijke service.

  10. #10
    Centos 6.5 Permission denied
    www.xenius.be
    1.555 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter
    Tijdens het booten failen HALD ook en start sendmail ook met errors op, echt bizar dit :/
    Xenius.be | Our solutions, our products, your success !

  11. #11
    Centos 6.5 Permission denied
    Vivor B.V. (vivor.net)
    2.357 Berichten
    Ingeschreven
    19/07/03

    Locatie
    Nijmegen / Diemen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    57 Berichten zijn liked


    Naam: Wisselend
    Bedrijf: Vivor BV
    URL: www.vivor.net
    Registrar SIDN: ja
    KvK nummer: 32095794

    Geef eens een ls -l /var
    Vivor B.V. - Internet voor professionals (contact)

  12. #12
    Centos 6.5 Permission denied
    www.xenius.be
    1.555 Berichten
    Ingeschreven
    26/11/11

    Locatie
    Oud-Turnhout

    Post Thanks / Like
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    73 Berichten zijn liked


    Naam: Steve Vos
    Bedrijf: Xenius
    Functie: Zaakvoerder
    URL: www.xenius.be
    Ondernemingsnummer: 0505928838

    Thread Starter
    Bedankt allemaal voor het meedenken.. Om een of andere reden (ofwel heeft een of ander vies script het gedaan, ofwel heb ik het perongeluk gedaan..) stonden de permissies van /VAR niet meer op 775, heb die nu aangepast naar analogie en de errors tijdens boot zijn weg enkel sendmail geeft nog een error... Dus ik vrees dat die rechten recursief zijn doorgedrukt..

    Iemand enig idee om de permissies op de subfolders van /var te restoren ?
    Xenius.be | Our solutions, our products, your success !

  13. #13
    Centos 6.5 Permission denied
    Professional
    3.115 Berichten
    Ingeschreven
    05/02/05

    Locatie
    Alkmaar

    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    101 Berichten zijn liked


    Naam: Thomas
    Registrar SIDN: JA
    ISPConnect: Lid
    KvK nummer: 76706966

    Code:
    for p in $(rpm -qa); do rpm --setperms $p; done
    for p in $(rpm -qa); do rpm --setugids $p; done
    Zelf nog nooit gebruikt, dus use with care. Maar dat moet in theorie alle rechten goed zetten van de packages welke geïnstalleerd zijn. Misschien dat je een paar globale directories hier mee mist, maar die kun je wel met een find commando terug vinden (bijv. alle bestanden/mappen die niet in de laatste 5 minuten zijn gewijzigd).

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics