Een paar maanden geleden hebben we onze mailserver verplaatst naar een nieuwe VPS provider (transip); voor alle klantendomeinen de dns aangepast zodat het ipadres van de hostname waar de MX records naar wijzen, het nieuwe IP is. Nieuwe serials in de zones, alles gewoon zoals altijd. Alle 3 de nameservers netjes alle zones gereload. Werkt goed; mail begon al snel op de nieuwe server binnen te komen. Op de oude voorlopig port 25 geforward naar de nieuwe server zodat er niets kwijt raakt. Werkt ook goed.
Na een maand kwam er niets meer binnen op de oude server en zette ik de forwarder uit. Even later begon de ellende; geen mail meer van microsoft.com/live.com naar geen enkele klant. Forwarder weer aan en hup, daar komt de mail weer binnen. Maar nu komt de grap... de mail die binnenkomt, komt direct op de nieuwe server binnen, niet via de forwarder (ip adres wat postfix in z'n log laat zien is niet m'n oude IP, maar echt een microsoft IP). Er staan GEEN connects vanaf m'n oude IP in de postfix logfile.
Zet ik de forwarder weer uit, begint de ellende gelijk weer, klanten krijgen geen mail, binnen hotmail na een tijdje zelfs meldingen als "Unable to deliver message to the following recipients, due to being unable to connect successfully to the destination mail server.". Zet ik de forwarder weer aan, komt binnen een paar minuten alsnog die mail van hotmail binnen. Maar dus weer direct op 't goede IP adres...
Het is ook echt puur mail vanaf hotmail/live.com die raar doet; alle andere mail gaat gewoon normaal. Ook uitgaand naar hotmail gaat perfect.
Microsoft support wil een paar honderd eurootjes om ook maar door te verbinden naar een technische medewerker; ik was niet van plan om ze te betalen voor iets wat idioot gaat aan hun kant...
Heeft iemand enig idee WTF dit kan zijn en hoe dit op te lossen valt? Wordt er een beetje moe van, het enige wat via die forwarder binnen komt is spam... maar uitzetten is zo geen optie.

Likes:


Quote