mysql 5.1 errors

Onderwerp: mysql 5.1 errors

  1. mysql 5.1 errors

    johan.smits said:

    mysql 5.1 errors

    Ik ben onlangs geupdate van MySQL 5.0 naar 5.1 en nu heb ik veel van deze errors:
    Code: [Bekijk]
    Statement may not be safe to log in statement format. Statement: UPDATE `player` SET `update_status` = '2' WHERE `id` ='711' LIMIT 1
    De MySQL servers draaien in een master 2 master set-up.

    Nu heb ik al het e.e.a. gelezen op het web, maar waardoor krijg ik deze warning op deze query.
    Komt dit door de LIMIT ?

    Kan dit lastig testen omdat er erg veel verkeer doorheen gaat en deze statements voorbij vliegen.
  2. mysql 5.1 errors

    Yourwebhoster said:
    Zie http://dev.mysql.com/doc/refman/5.1/...g-formats.html

    With statement-based replication, there may be issues with replicating nondeterministic statements. In deciding whether or not a given statement is safe for statement-based replication, MySQL determines whether it can guarantee that the statement can be replicated using statement-based logging. If MySQL cannot make this guarantee, it marks the statement as potentially unreliable and issues the warning, Statement may not be safe to log in statement format.

    Prior to MySQL 5.1.36, this warning read, Statement is not safe to log in statement format. (Bug#42415)

    You can avoid these issues by using MySQL's row-based replication instead.
    Met vriendelijke groet, Yourwebhoster.eu - Managed VPS diensten met Epyc performance op 100% SSDs

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!
  3. mysql 5.1 errors

    ichosting said:
    Deze waarschuwingen zijn er altijd al geweest, alleen in eerdere versies werd het niet in de log getoond.

    Hier wat informatie wat je zou kunnen helpen: hier en hier
  4. mysql 5.1 errors

    johan.smits said:
    Het is me nu duidelijk.
    Omdat ik een LIMIT gebruik zonder bv te sorteren krijg ik deze waarschuwingen.
    Duidelijk gevalletje query's aanpassen.
  5. mysql 5.1 errors

    vDong said:
    Citaat Oorspronkelijk geplaatst door johan.smits Bekijk Berichten
    Het is me nu duidelijk.
    Omdat ik een LIMIT gebruik zonder bv te sorteren krijg ik deze waarschuwingen.
    Duidelijk gevalletje query's aanpassen.
    En je replicatie opnieuw opbouwen, want het is vrijwel zeker uit sync.