Likes Likes:  0
Resultaten 1 tot 15 van de 15
Geen

Onderwerp: apache probleem

  1. #1
    apache probleem
    geregistreerd gebruiker
    34 Berichten
    Ingeschreven
    24/07/07

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    apache probleem

    Ik draai debian met directadmin en sinds vanmorgen zijn de websites die ik host niet meer bereikbaar. Verder draait alles stabiel. Directadmin geeft aan dat httpd gewoon draait, maar als ik via DA probeer te restarten krijg ik een error zonder details. Via ssh krijg ik de volgende error

    Code:
    ~$ sudo /etc/init.d/httpd restart
    Stopping httpd: 
    Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:80
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    in httpd/error_log vind ik de volgende fouten:

    Code:
    [Sat Feb 14 00:10:02 2009] [notice] SIGHUP received.  Attempting to restart
    [Sat Feb 14 00:10:03 2009] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
    [Sat Feb 14 00:10:03 2009] [warn] Init: SSL server IP/port conflict: ****:443 (/********/httpd.conf:48) vs. www.****.nl:443 (/******/httpd.conf:48)
    [Sat Feb 14 00:10:03 2009] [warn] Init: SSL server IP/port conflict: www.*******.com:443 (/*******/httpd.conf:48) vs. www.********.nl:443 (/******/httpd.conf:48)
    [Sat Feb 14 00:10:03 2009] [warn] Init: SSL server IP/port conflict: localhost:443 (/etc/httpd/conf/extra/httpd-vhosts.conf:38) vs. www.*******.nl:443 (/******/httpd.conf:48)
    [Sat Feb 14 00:10:03 2009] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
    [Sat Feb 14 00:10:03 2009] [notice] Apache/2.2.10 (Unix) mod_ssl/2.2.10 OpenSSL/0.9.8c DAV/2 PHP/5.2.6 configured -- resuming normal operations
    [Sat Feb 14 00:11:01 2009] [notice] caught SIGTERM, shutting down
    iemand enig idee?

  2. #2
    apache probleem
    www.fusa.be
    2.211 Berichten
    Ingeschreven
    21/01/08

    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    54 Berichten zijn liked


    Naam: null

    probeer eerst eens exim te herstarten en dan http...

  3. #3
    apache probleem
    geregistreerd gebruiker
    34 Berichten
    Ingeschreven
    24/07/07

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door Tim.Bracquez Bekijk Berichten
    probeer eerst eens exim te herstarten en dan http...
    bedankt voor je antwoord, ik heb het geprobeerd maar apache startte nog steeds niet.

  4. #4
    apache probleem
    Meneer DE Directeur!
    62 Berichten
    Ingeschreven
    14/03/08

    Locatie
    Heerugowaard / Wormerveer

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 37148496
    Ondernemingsnummer: nvt

    ik heb oplossing voor je:
    ipcs -s | grep apache | perl -e 'while (<STDIN>) { @a=split(/\s+/); print `ipcrm sem $a[1]`}'

  5. #5
    apache probleem
    geregistreerd gebruiker
    1.712 Berichten
    Ingeschreven
    03/01/07

    Locatie
    Winschoten / Groningen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Kobus Draijer
    Bedrijf: IC Hosting
    URL: www.ic-hosting.nl
    Registrar SIDN: ja
    KvK nummer: 02079831
    Ondernemingsnummer: nvt
    TrustCloud: ichosting

    Doe anders eerst een killall -9 httpd en probeer het dan nog eens op te starten

  6. #6
    apache probleem
    Meneer DE Directeur!
    62 Berichten
    Ingeschreven
    14/03/08

    Locatie
    Heerugowaard / Wormerveer

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 37148496
    Ondernemingsnummer: nvt

    misschien exim ook ff killen, dus:
    service exim stop
    service httpd stop
    killall -9 exim
    killall -9 httpd
    service httpd start
    service exim start

  7. #7
    apache probleem
    geregistreerd gebruiker
    676 Berichten
    Ingeschreven
    22/01/09

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door Noordwest Bekijk Berichten
    in httpd/error_log vind ik de volgende fouten:

    Code:
    [Sat Feb 14 00:10:02 2009] [notice] SIGHUP received.  Attempting to restart
    [Sat Feb 14 00:10:03 2009] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
    [Sat Feb 14 00:10:03 2009] [warn] Init: SSL server IP/port conflict: ****:443 (/********/httpd.conf:48) vs. www.****.nl:443 (/******/httpd.conf:48)
    [Sat Feb 14 00:10:03 2009] [warn] Init: SSL server IP/port conflict: www.*******.com:443 (/*******/httpd.conf:48) vs. www.********.nl:443 (/******/httpd.conf:48)
    [Sat Feb 14 00:10:03 2009] [warn] Init: SSL server IP/port conflict: localhost:443 (/etc/httpd/conf/extra/httpd-vhosts.conf:38) vs. www.*******.nl:443 (/******/httpd.conf:48)
    [Sat Feb 14 00:10:03 2009] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
    [Sat Feb 14 00:10:03 2009] [notice] Apache/2.2.10 (Unix) mod_ssl/2.2.10 OpenSSL/0.9.8c DAV/2 PHP/5.2.6 configured -- resuming normal operations
    [Sat Feb 14 00:11:01 2009] [notice] caught SIGTERM, shutting down
    iemand enig idee?
    *snip*

    Openssl heeft tegenwoodig al versie 0.9.8j , maar dat terzijde.

    Heb je uberhaupt de bovenstaande "failure" geleze ?

  8. #8
    apache probleem
    <?php phpinfo(); ?>
    764 Berichten
    Ingeschreven
    10/05/06

    Locatie
    Sevenum

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 12037834
    Ondernemingsnummer: nvt

    Probeer eens onderstaand uit te voeren
    Code:
    ipcs | grep apache | awk '{print $2}' > sem.txt
    for i in `cat sem.txt`; do { ipcrm -s $i; }; done;
    Zodra je dit hebt gedaan probeer je HTTPd te restarten.

  9. #9
    apache probleem
    Meneer DE Directeur!
    62 Berichten
    Ingeschreven
    14/03/08

    Locatie
    Heerugowaard / Wormerveer

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 37148496
    Ondernemingsnummer: nvt

    En anders gewoon even je server rebooten....

  10. #10
    apache probleem
    Ja..
    116 Berichten
    Ingeschreven
    01/12/03

    Locatie
    Zeeland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Marnix
    Registrar SIDN: nee
    KvK nummer: 22058555
    Ondernemingsnummer: nvt

    Volgens mij is de melding wel duidelijk uit de error_log.

    You should not use name-based virtual hosts in conjunction with SSL!!

    volgens mij valt dit onder name-based "www.*******.com"
    Laatst gewijzigd door Allround; 15/02/09 om 12:09. Reden: Wat meer info

  11. #11
    apache probleem
    geregistreerd gebruiker
    3.709 Berichten
    Ingeschreven
    22/05/05

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    24 Berichten zijn liked


    Naam: Jeroen

    Citaat Oorspronkelijk geplaatst door DeTaas Bekijk Berichten
    Volgens mij is de melding wel duidelijk uit de error_log.

    You should not use name-based virtual hosts in conjunction with SSL!!

    volgens mij valt dit onder name-based "www.*******.com"
    Dit is een warning en niet de reden van het niet functioneren..

    Oplossing moet inderdaad zijn apache helemaal killen (killall -9 httpd) en daarna gewoon starten. Mocht je er niet uit komen stuur maar even een PM, dan los ik het voor je op.

  12. #12
    apache probleem
    Ja..
    116 Berichten
    Ingeschreven
    01/12/03

    Locatie
    Zeeland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    Naam: Marnix
    Registrar SIDN: nee
    KvK nummer: 22058555
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door DutchTSE Bekijk Berichten
    Dit is een warning en niet de reden van het niet functioneren..
    Sorry ik had niet helemaal goed gelezen.
    Deze regel geeft aan dat er nog wat op poort 80 zit: could not bind to address 0.0.0.0:80

  13. #13
    apache probleem
    geregistreerd gebruiker
    34 Berichten
    Ingeschreven
    24/07/07

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    dank voor jullie hulp! een reboot deed het inderdaad oplossen. Nu herhaalde het probleem zich weer 2 keer de afgelopen dagen. Ik vermoed dat het aan de roundcube vulnerability lag, ik heb zojuist roundcube geupdate. Ik hoop dat het probleem is opgelost, hou jullie op de hoogte!

  14. #14
    apache probleem
    <?php phpinfo(); ?>
    764 Berichten
    Ingeschreven
    10/05/06

    Locatie
    Sevenum

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 12037834
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door Noordwest Bekijk Berichten
    dank voor jullie hulp! een reboot deed het inderdaad oplossen. Nu herhaalde het probleem zich weer 2 keer de afgelopen dagen. Ik vermoed dat het aan de roundcube vulnerability lag, ik heb zojuist roundcube geupdate. Ik hoop dat het probleem is opgelost, hou jullie op de hoogte!
    Dit probleem was ook op te lossen zonder reboot.

    überhaupt mijn 'oplossing' enkele posts eerder wel geprobeerd?
    Anders ook eerst even 'killall -9 exim' doen en als laatste httpd restart.

  15. #15
    apache probleem
    geregistreerd gebruiker
    34 Berichten
    Ingeschreven
    24/07/07

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Citaat Oorspronkelijk geplaatst door daveww Bekijk Berichten
    Dit probleem was ook op te lossen zonder reboot.

    überhaupt mijn 'oplossing' enkele posts eerder wel geprobeerd?
    Anders ook eerst even 'killall -9 exim' doen en als laatste httpd restart.
    ik heb de oplossing nog niet geprobeerd omdat ik niet precies zag wat t deed (ben nog een redelijke beginner met linux). Apache draait nu sinds vannacht stabiel. Vind wel nog "caught SIGTERM, shutting down" in de logs..

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics