Likes Likes:  0
Resultaten 1 tot 2 van de 2
Geen
  1. #1
    ldapsearch invalid credentials AcceptSecurityContext error
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter

    ldapsearch invalid credentials AcceptSecurityContext error

    Beste WHT'ers,

    Ik ben bezig SSH LDAP authenticatie op te zetten op een CentOS 6.4 x86_64 box met een Windows 2008 R2 LDAP server (AD). Nu blijft nslcd deze error geven invalid credentials, no available LDAP server found.

    Nu ben ik een stapje terug gegaan en probeer ik eerst e.e.a. werkend te krijgen via ldapsearch, echter lijkt het erop dat wat ik ook mee geef aan basedn en binddn hij dit niet meestuurt.

    Bijvoorbeeld onderstaande commando's geven allemaal dezelfde AcceptSecurityContext error

    ldapsearch -h host -p 389 -x -D "uid=<user>,ou=,<firma>,dc=<firma>,dc=local" -b "ou=<firma>,dc=<firma>,dc=local" -W -v
    ldapsearch -h host -p 389 -x -D "cn=<user>,ou=,<firma>,dc=<firma>,dc=local" -b "ou=<firma>,dc=<firma>,dc=local" -W -v
    ldapsearch -h host -p 389 -x -D "uid=<user>,ou=,<firma>,dc=<firma>,dc=local" -W -v
    ldapsearch -h host -p 389 -x -D "cn=<user>,ou=,<firma>,dc=<firma>,dc=local" -W -v
    ldapsearch -h host -p 389 -x -D "uid=<user>,dc=<firma>,dc=local" -W -v
    ldapsearch -h host -p 389 -x -D "cn=<user>,dc=<firma>,dc=local" -W -v

    Iemand enig idee hoe dit probleem verder te debuggen?

  2. #2
    ldapsearch invalid credentials AcceptSecurityContext error
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    Problem solved, de AcceptSecurityContext error was volledig terecht. Blijkbaar was ik toch nog een aantal dingen vergeten in DN, de exacte DN heb ik uiteindelijk uit de Active Directory gekopieerd (distinguishedName is namelijk gewoon een attribuut van de gebruiker welke je terug kunt vinden in de attribute editor, je moet het maar net weten).

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics