Hey all,
Na wat dingen te hebben gelezen over nginx wilde ik dit wel eens gaan proberen.
De installatie van nginx ging vrij gemakkelijk met het opzetten van virtualhosts echter is het php deel een heel ander verhaal.
Ik krijg het maar niet voor elkaar om de php bestanden te laten uitvoeren, wanneer je naar een php bestand gaat wordt deze gedownload ipv uitgevoerd.
Wanneer ik op de commandline php /bestandlocatie/iets.php doet wordt deze wel netjes uitgevoerd.
Ik ben aan de slag gegaan met verschillende tutorials. Waar het bij hun schijnbaar werkt krijg ik het niet voor elkaar ik denk dus dat ik iets over het hoofd zie.
Ik heb php geïnstalleerd doormiddel van:
Mijn /etc/nginx/sites-available/default:Code:sudo apt-get install php-fpm
Alvast bedankt voor jullie tijd en moeite.Code:server { listen 80; ## listen for ipv4; this line is default and implied listen [::]:80 default ipv6only=on; ## listen for ipv6 root /usr/share/nginx/www; index index.html index.htm; # Make site accessible from http://localhost/ server_name localhost; location / { # First attempt to serve request as file, then # as directory, then fall back to index.html try_files $uri $uri/ /index.html; # Uncomment to enable naxsi on this location # include /etc/nginx/naxsi.rules } location /doc/ { alias /usr/share/doc/; autoindex on; allow 127.0.0.1; deny all; } # Only for nginx-naxsi : process denied requests #location /RequestDenied { # For example, return an error code #return 418; #} #error_page 404 /404.html; # redirect server error pages to the static page /50x.html # #error_page 500 502 503 504 /50x.html; #location = /50x.html { # root /usr/share/nginx/www; #} # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000 # #location ~ \.php$ { # fastcgi_split_path_info ^(.+\.php)(/.+)$; # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini # try_files $uri =404; # # With php5-cgi alone: # fastcgi_pass 127.0.0.1:9000; # # With php5-cgi alone: # fastcgi_pass 127.0.0.1:9000; # With php5-fpm: # fastcgi_pass unix:/var/run/php5-fpm.sock; # fastcgi_index index.php; # include fastcgi_params; #} location ~ \.php$ { fastcgi_split_path_info ^(.+\.php)(/.+)$; fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; include fastcgi_params; } # deny access to .htaccess files, if Apache's document root # concurs with nginx's one # #location ~ /\.ht { # deny all; #} } # another virtual host using mix of IP-, name-, and port-based configuration # #server { # listen 8000; # listen somename:8080; # server_name somename alias another.alias; # root html; # index index.html index.htm; # # location / { # try_files $uri $uri/ /index.html; # } #} server { listen 80; server_name nginx.domein.nl; index index.html index.php index.html; root /home/ruben/www; } # HTTPS server # #server { # listen 443; # server_name localhost; # # root html; # index index.html index.htm; # # ssl on; # ssl_certificate cert.pem; # ssl_certificate_key cert.key; # # ssl_session_timeout 5m; # # ssl_protocols SSLv3 TLSv1; # ssl_ciphers ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv3:+EXP; # ssl_prefer_server_ciphers on; # # location / { # try_files $uri $uri/ /index.html; # }

Likes:


Quote

.
snap er echt werkelijk niks van.