Likes Likes:  0
Resultaten 1 tot 10 van de 10
Geen
  1. #1
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    19 Berichten
    Ingeschreven
    12/06/08

    Locatie
    nvt

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    Postfix andere poort dan poort 25 gebruiken voor Ziggo

    Sinds kort ben ik overgestapt op Ziggo webhosting.

    Omdat ik mijn computer gebruik voor het bouwen van websites heb ik om de mailfunctionaliteit te testen altijd gebruik gemaakt van postfix.
    Nu ben ik erachter dat ziggo port 25 blokkeert en daardoor werkt mijn postfix niet meer.

    Nu vond ik op internet een aantal mogelijke oplossingen om poort 587 te gebruiken maar om de een of andere reden hebben deze geen enkel effect.

    Code:
    smtp      inet  n       -       n       -       -       smtpd
    veranderen in
    Code:
    587      inet  n       -       n       -       -       smtpd
    Gebeurde niets meer geen foutmelding in mail.log en geen activiteiten in de mailque

    Ook heb ik het # voor deze regel weggehaald
    Code:
    submission inet n       -       n       -       -       smtpd
    Maar ook dit leverde niet het resultaat die ik veawacht had.


    Zonder foutmelding word het wel heel moeilijk, maar de oplossingen die ik tot nu toe gevonden heb bleken stuk voor stuk geen effect te hebben.

    In de normale situatie krijg ik de volgende foutmelding

    Code:
    (connect to fw1-shared.isp-services.nl[212.79.236.226]:25: Operation timed out)
    Het gaat dus altijd om poort 25 een nandere poort krijgen lukt niet dus weet ik ook niet of er in zo'n geval wel mail verstuurd wordt.
    Laatst gewijzigd door gerda; 07/04/12 om 11:38.

  2. #2
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    487 Berichten
    Ingeschreven
    09/09/05

    Locatie
    Beilen / Groningen

    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    25 Berichten zijn liked


    Naam: Jasper Aikema
    Bedrijf: ja - advies en beheer
    Functie: Eigenaar
    URL: www.jasperaikema.nl
    KvK nummer: 55931480
    View jasperaikema's profile on LinkedIn

    Je geeft aan dat je niet het resultaat kreeg welke je verwachte. Wat voor resultaat kreeg je wel?

    Ging postfix wel op poort 587 luisteren?

    Ik heb het destijds op zo goed als dezelfde manier opgelost, maar dat wel met authenticatie.

    Zie ook: http://jasperaikema.nl/wordpress/201...ticatie-mysql/

  3. #3
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    19 Berichten
    Ingeschreven
    12/06/08

    Locatie
    nvt

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Ik heb nu

    Code:
    smtp      inet  n       -       n       -       -       smtpd
    submission inet n       -       n       -       -       smtpd
    Postfix blijft gewoon naar pport 25 luisteren.

    Code:
    (connect to fw3-shared.isp-services.nl[195.245.199.8]:25: Operation timed out)
    Maar ik ga nu eens proberen wat er in de link staat die jij mij gestuurd hebt.
    Laatst gewijzigd door gerda; 07/04/12 om 11:48.

  4. #4
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    Dennis.
    3.867 Berichten
    Ingeschreven
    11/07/06

    Locatie
    Oosterhout

    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    262 Berichten zijn liked


    Naam: Dennis
    Registrar SIDN: JA
    KvK nummer: 20144338

    Dit gaat niet werken natuurlijk, je moet ergens anders een SMTP server hebben die kan verzenden naar een andere server via poort 25.

    [root@www ~]# telnet fw1-shared.isp-services.nl 587
    Trying 212.79.236.226...
    telnet: connect to address 212.79.236.226: Connection timed out

  5. #5
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    19 Berichten
    Ingeschreven
    12/06/08

    Locatie
    nvt

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Daar begin ik inmiddels ook achter te komen dat dit een doodlopende straat is.
    Ook heet bij mij de map default defaults en staat daar geen sasl.

    Wel heb ik nu een andere foutmelding en dat is er 1 die nog voor de queu komt

    Code:
    Apr  7 12:14:16 werkcomputer postfix/smtpd[11236]: connect from werkcomputer.fritz.box[127.0.0.1]
    Apr  7 12:14:16 werkcomputer postfix/smtpd[11236]: NOQUEUE: reject: RCPT from werkcomputer.fritz.box[127.0.0.1]: 554 5.7.1 <offerte@gorter-webdevelopment.nl>: Sender address rejected: Access denied; from=<offerte@gorter-webdevelopment.nl> to=<info@gorter-webdevelopment.nl> proto=ESMTP helo=<localhost.localdomain>
    Apr  7 12:14:16 werkcomputer postfix/smtpd[11236]: disconnect from werkcomputer.fritz.box[127.0.0.1]
    Daarvoor moet ik dan wel het hekje voor de smpt weghalen.

    Code:
     
    smtp      inet  n       -       -       -        -       smtpd
    Alleen de smpt werkt dus bij mij en met deze wijzigingen kom ik nog niet eens tot aan de queu dus van een andere poort kan al helemaal geen sprake zijn.

  6. #6
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    19 Berichten
    Ingeschreven
    12/06/08

    Locatie
    nvt

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Ik heb nu de bovenste regels weer weg gehaald.
    Hij zit nu weer op poort 25 te proberen en geeft de bekende error.

    Waarom is het nu zo moeilijk om postfix naar een andere poort te laten wijzen.

  7. #7
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    1.453 Berichten
    Ingeschreven
    20/03/09

    Locatie
    Barendrecht

    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    178 Berichten zijn liked


    Naam: Patrick Ekkel
    Bedrijf: Unsal Infratechniek B.V.
    Functie: Monteur Laagspanning
    URL: unsal.nl

    Is dit niet veel makkelijker ?
    iptables -A PREROUTING -t nat -p tcp --dport 26 -j REDIRECT --to-port 25

    Je kan uiteraard ook een andere port pakken dan 26

  8. #8
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    1.555 Berichten
    Ingeschreven
    20/07/10

    Locatie
    's-Gravenhage

    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    308 Berichten zijn liked



    Citaat Oorspronkelijk geplaatst door gerda Bekijk Berichten
    Ik heb nu de bovenste regels weer weg gehaald.
    Hij zit nu weer op poort 25 te proberen en geeft de bekende error.

    Waarom is het nu zo moeilijk om postfix naar een andere poort te laten wijzen.
    Dat is niet zo moeilijk, maar welk probleem wil je nou oplossen ?
    Wil je mail verzenden , en is dus uitgaand poort 25 geblokkeerd ?
    Dan moet je de smarthost van je provider gebruiker, want anders gaat het gewoon niet werken.

    Wil je mail ontvangen, dan heeft het ook heel weinig zin om op een andere poort te gaan zitten.
    De rest van de wereld weet namelijk niet dat jouw mailserver op een andere poort zit.

    De constructie met mail op bijvoorbeeld poort 26 heeft alleen zin als er elders een mailserver staat die de mail ontvangt, en dan doorstuurt naar jouw mailserver op die poort 26.

    Poort 587 (smtp submit) is bedoeld voor mail submit, waarbij die mailserver smarthost is voor clients.
    De poort die iemand in z'n mail client (iMail, outlook, etc) instelt bij "de mailserver van je provider".

    Ik ken ziggo webhosting niet als product, maar als ze poort 25 blokkeren (wel een beetje vreemd voor een hosting product) zal er vast in de product beschrijving wel iets staan over hoe je "mail" kunt doen.

    Wees dus duidelijk vanaf welke computer/isp je wat naar waar probeert te doen.

    Probeer je vanaf je thuis-ziggo aansluiting (consument ?) met dan postfix als mailer naar poort 25 van "een mailserver ergens op internet" te connecten en werkt dat niet ?

  9. #9
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    19 Berichten
    Ingeschreven
    12/06/08

    Locatie
    nvt

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Bedankt Visser.
    de oplossing van de smarthost werkt dankzij jouw antwoord heb ik deze link gevonden.

    http://ziggo-gebruikers.nl/forum/arc...p/t-26533.html

    Ik heb met een Ruby on rails app al een aantal mails verstuurd en dat werkt geweldig.
    Nu moet ik alleen nog voor PHP in de php.ini iets veranderen want daar worden mijn mails verstuurd door nobody@werkcomputer.local dus dat word nog even zoeken.

  10. #10
    Postfix andere poort dan poort 25 gebruiken voor Ziggo
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    want daar worden mijn mails verstuurd door nobody@werkcomputer.local dus dat word nog even zoeken.
    Volgens mij is dat eenvoudig te fixen door in Postfix de domain masquerading te gebruiken. Daarnaast zou ik de hostnaam van werkcomputer.local ook wijzigen naar iets als werkcomputer.gorter-webdevelopment.nl dan ben je daar als het goed is ook vanaf.
    Tenzij je dat werkcomputer.local in Postfix hebt ingesteld, dan daar die domeinnaam ff wijzigen.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics