Resultaten 1 tot 9 van de 9
Geen
  1. #1
    MySQL versie verschil oorzaak restore error
    geregistreerd gebruiker
    117 Berichten
    Ingeschreven
    14/04/06

    Locatie
    Spijkenisse

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    URL: www.unipolair.com
    Registrar SIDN: JA
    KvK nummer: 24476622

    Thread Starter

    MySQL versie verschil oorzaak restore error

    Kan het zijn dat een versie verschil (5.1.56 tov 5.0.51a) de oorzaak is van een error tijdens een restore van een database?

  2. #2
    MySQL versie verschil oorzaak restore error
    geregistreerd gebruiker
    99 Berichten
    Ingeschreven
    21/08/09

    Locatie
    Arnhem

    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Wat voor error krijg je precies?

  3. #3
    MySQL versie verschil oorzaak restore error
    .com
    2.656 Berichten
    Ingeschreven
    24/04/09

    Locatie
    Gemeente Castricum

    Post Thanks / Like
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    104 Berichten zijn liked


    Bedrijf: WebMeso ISP
    Functie: Eigenaar
    URL: www.webmeso.com
    KvK nummer: 55691153

    Citaat Oorspronkelijk geplaatst door pimlie Bekijk Berichten
    Wat voor error krijg je precies?
    Het probleem wordt veroorzaakt vanuit deze situatie van het overzetten van de database.

  4. #4
    MySQL versie verschil oorzaak restore error
    geregistreerd gebruiker
    99 Berichten
    Ingeschreven
    21/08/09

    Locatie
    Arnhem

    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Hmm, daar heb ik geen ervaring mee. Je krijgt dus nergens een mysql error te zien?

    Kan je trouwens niet die 5.0.51a server upgraden naar 5.1.56?
    Laatst gewijzigd door pimlie; 06/01/12 om 18:37.

  5. #5
    MySQL versie verschil oorzaak restore error
    Programmeur / Hoster
    3.952 Berichten
    Ingeschreven
    20/06/06

    Locatie
    Wijlre

    Post Thanks / Like
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    647 Berichten zijn liked


    Naam: John Timmer
    Bedrijf: SystemDeveloper.NL
    Functie: Eigenaar
    URL: www.systemdeveloper.nl
    KvK nummer: 14083066
    View johntimmer's profile on LinkedIn

    Probeer eens een:

    perl -pi.bak -e 's/\(\s+USING BTREE\s+\)/g' jouw_mysql_bestand_van_5.1.sql
    Als het goed is moet dat het indextype van het 'create table' verwijderen waardoor je het in mysql server 5.0 kunt importeren.

    Het punt is dat je gewoon even die (USING BTREE) verwijderd en dat kan ook in een editor of zo. Daarna zou je hem moeten kunnen importeren.

  6. #6
    MySQL versie verschil oorzaak restore error
    Programmeur / Hoster
    3.952 Berichten
    Ingeschreven
    20/06/06

    Locatie
    Wijlre

    Post Thanks / Like
    Mentioned
    28 Post(s)
    Tagged
    0 Thread(s)
    647 Berichten zijn liked


    Naam: John Timmer
    Bedrijf: SystemDeveloper.NL
    Functie: Eigenaar
    URL: www.systemdeveloper.nl
    KvK nummer: 14083066
    View johntimmer's profile on LinkedIn

    Citaat Oorspronkelijk geplaatst door systemdeveloper Bekijk Berichten
    Probeer eens een:

    perl -pi.bak -e 's/\(\s+USING BTREE\s+\)/g' jouw_mysql_bestand_van_5.1.sql
    Als het goed is moet dat het indextype van het 'create table' verwijderen waardoor je het in mysql server 5.0 kunt importeren.

    Het punt is dat je gewoon even die (USING BTREE) verwijderd en dat kan ook in een editor of zo. Daarna zou je hem moeten kunnen importeren.
    Edit: Die 'perl...' heb ik niet getest dus maybe moet je hem nog iets aanpassen.

  7. #7
    MySQL versie verschil oorzaak restore error
    geregistreerd gebruiker
    117 Berichten
    Ingeschreven
    14/04/06

    Locatie
    Spijkenisse

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    URL: www.unipolair.com
    Registrar SIDN: JA
    KvK nummer: 24476622

    Thread Starter
    Nou ... ik heb het antwoord ...

    Opgelost door beide op versie 5.1.60 te zetten, problemen opgelost.
    Dus het antwoord is ja .. versie kan wel een probleem veroorzaken ... weer wat kennis erbij.

  8. #8
    MySQL versie verschil oorzaak restore error
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Belangrijke vuistregel: Importeer alleen data in een database versie die gelijk of hoger is aan de originele bron.

    MySQL heeft al de vervelende gewoonte om dumps zo te maken dat een dump die eigenlijk alleen in 5.1 kan draaien zonder 'foutmelding' in 4.1 kan worden geïmporteerd.
    Maar dan begint de ellende pas echt, want geen foutmelding betekend niet dat alles is goed gegaan! Een VIEW bijvoorbeeld word omgezet naar tabel met de data van dat moment. http://www.pfz.nl/archief/1177075-rant-dat-en-mysql/

    En uit oogpunt van stabiliteit is het ook beste om de laatst stabiele versie te gebruiken.

  9. #9
    MySQL versie verschil oorzaak restore error
    geregistreerd gebruiker
    117 Berichten
    Ingeschreven
    14/04/06

    Locatie
    Spijkenisse

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4 Berichten zijn liked


    URL: www.unipolair.com
    Registrar SIDN: JA
    KvK nummer: 24476622

    Thread Starter
    True, het rare was in dit geval... Dat de backup van 5.0 overgezet werd op een hogere versie ... Schiet mij maar lek.

    Probleem is in elk geval nu wel opgelost!

    Bedankt voor het meedenken!

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics