Kan het zijn dat een versie verschil (5.1.56 tov 5.0.51a) de oorzaak is van een error tijdens een restore van een database?
Wat voor error krijg je precies?

Het probleem wordt veroorzaakt vanuit deze situatie van het overzetten van de database.
Hmm, daar heb ik geen ervaring mee. Je krijgt dus nergens een mysql error te zien?
Kan je trouwens niet die 5.0.51a server upgraden naar 5.1.56?
Laatst gewijzigd door pimlie; 06/01/12 om 18:37.
Probeer eens een:
perl -pi.bak -e 's/\(\s+USING BTREE\s+\)/g' jouw_mysql_bestand_van_5.1.sql
Als het goed is moet dat het indextype van het 'create table' verwijderen waardoor je het in mysql server 5.0 kunt importeren.
Het punt is dat je gewoon even die (USING BTREE) verwijderd en dat kan ook in een editor of zo. Daarna zou je hem moeten kunnen importeren.
Nou ... ik heb het antwoord ...
Opgelost door beide op versie 5.1.60 te zetten, problemen opgelost.
Dus het antwoord is ja .. versie kan wel een probleem veroorzaken ... weer wat kennis erbij.
Belangrijke vuistregel: Importeer alleen data in een database versie die gelijk of hoger is aan de originele bron.
MySQL heeft al de vervelende gewoonte om dumps zo te maken dat een dump die eigenlijk alleen in 5.1 kan draaien zonder 'foutmelding' in 4.1 kan worden geïmporteerd.
Maar dan begint de ellende pas echt, want geen foutmelding betekend niet dat alles is goed gegaan! Een VIEW bijvoorbeeld word omgezet naar tabel met de data van dat moment. http://www.pfz.nl/archief/1177075-rant-dat-en-mysql/
En uit oogpunt van stabiliteit is het ook beste om de laatst stabiele versie te gebruiken.
True, het rare was in dit geval... Dat de backup van 5.0 overgezet werd op een hogere versie ... Schiet mij maar lek.
Probleem is in elk geval nu wel opgelost!
Bedankt voor het meedenken!