Op een server hebben we momenteel het probleem dat de error log met grote regelmaat geflood wordt.
Een 20 mb logfile op een paar uurtjes is geen probleem, het gaat hier om de apache errorlog. Server draait op Centos en Cpanel.
De volgende regel is eigenlijk diegene wat continu voorkomt en de flooding veroorzaakt:
Er zijn al verschillende seo.php bestanden geprobeerd en er zijn ook meerdere van deze creloaded shops op de server, maar alleen deze site heeft er last van. Ip is zo te zien van googlebot, dus ik dacht dat googlebot hem dan ook aanriep.[Sun Aug 14 02:57:57 2011] [error] [client 66.249.72.155] PHP Notice: Undefined variable: result in /home/usernaam/public_html/seo.php on line 117
Dus dan zetten we in de robots.txt gewoon:
disallow: /seo.php
maar dat wil van geen kant helpen.
Nu hebben we in een bestaande .htaccess als eerste regeltjes het volgende opgenomen:
Maar toch was er vannacht opnieuw weer flooding met diezelfde alsboven genoemde error op seo.php.<Files seo.php>
order allow,deny
deny from all
</Files>
Ook al geprobeerd een seo.php te kopiëren van een shop die geen last heeft maar ook dat mag niet baten.
Wat doen we fout? Hoe kan het dat ondanks deze "deny from all" toch nog deze melding kan komen?
En hoe komen we nu van deze logfile floodings af? Afgezien dan van creloaded om support vragen...

Likes:


Quote