Ik wil voor een FTP server SSL configureren, maar ik loop ergens tegen aan waar ik niet uit kom.
In /var/log/proftpd/proftpd.tls.log krijg ik de volgende melding:
Dit moet normaal opgelost kunnen worden met TLSOptions NoCertRequest, volgens ProFTPD tenminste.Code:Jul 13 13:55:37 mod_tls/2.4.2[21926]: TLS/TLS-C requested, starting TLS handshake Jul 13 13:55:39 mod_tls/2.4.2[21926]: unable to accept TLS connection: received EOF that violates protocol Jul 13 13:55:39 mod_tls/2.4.2[21926]: TLS/TLS-C negotiation failed on control channel
In de configuratie staat het volgende, dit is overigens aardig default:
Deze staat buiten <Global>. De locatie van de files is correct, we gebruiken deze ook voor Exim bijvoorbeeld. Ook de rechten op deze files zijn default voor een DirectAdmin server. Dat ik het toch ergens anders vraag is omdat ik denk dat het probleem niet specifiek in DirectAdmin zit. De rechten op zowel de .cert als .key file zijn 644. De firewall in- of uitschakelen maakt geen verschil.Code:<IfModule mod_tls.c> TLSEngine on TLSLog /var/log/proftpd/proftpd.tls.log TLSProtocol TLSv1 TLSVerifyClient off TLSRequired off #Certificates TLSRSACertificateFile /etc/exim.cert TLSRSACertificateKeyFile /etc/exim.key TLSCipherSuite HIGH:MEDIUM:+TLSv1:!SSLv2:+SSLv3 </IfModule>
Ik gebruik FlashFXP om te testen met connection type: FTP using Explicit SSL (Auth TLS). De logging in de applicatie is beperkt tot het volgende:
En nadien gebeurt er niets meer, behalve de foutmelding in /var/log/proftpd/proftpd.tls.log.Code:[R] Connecting to server -> DNS=server IP=192.168.1.251 PORT=21 [R] Connected to server [R] 220 ProFTPD 1.3.3e Server ready. [R] AUTH TLS [R] 234 AUTH TLS successful [R] Connected. Negotiating TLSv1 session
Waar kijk ik overheen?

Likes:


Quote
Maar als je dat al geprobeerd hebt (niet zonder firewall maar echt op een andere poort) houd het op.