Hallo allemaal,
Ik ben redelijk nieuw op dit forum, maar heb er al heel wat nuttig info vandaan gehaald.
Nu heb ik zelf ook een vraag waarvan ik hoop dat iemand mij hiermee kan helpen.
Ik heb in direct admin een Cron job ingesteld die elke ochtend op werkdagen een php script uitvoert. Dit php script verstuurt een e-mail bericht naar gebruikers vanuit een database.
Dit script en de cron job werken prima. Uitdaging waar ik echter tegenaan loop is dat indien de mail via de cron job verstuurd wordt, de mail niet door alle mailservers geaccepteerd wordt.
Ik krijg de volgende meldingen terug:
SMTP error from remote mail server after RCPT TO:<*emailadres*>:
host mail1.d-server.nl [*ip-adres]: 550-Sender has no A, AAAA, or MX DNS
records. srv1.2bsupport.com
550 srv1.2bsupport.com
EN
SMTP error from remote mail server after MAIL FROM:<cos@srv1.2bsupport.com>
SIZE=2666:
host mx1.xs4all.nl [*ip-adres*]: 553 5.1.8 <cos@srv1.2bsupport.com>...
Domain of sender address cos@srv1.2bsupport.com does not exist
EN
SMTP error from remote mail server after RCPT TO:<*emailadres*>:
host mx.****.com [*ip-adres]: 450 4.1.8 <cos@srv1.2bsupport.com>:
Sender address rejected: Domain not found: retry timeout exceeded
Dit wordt volgens mij veroorzaakt doordat de afzender cos@srv1.2bsupport.com is en dat domein bestaat inderdaad niet. In het mail script dat in het php script wordt uitgevoerd, is al een parameter meegenomen om de afzender van het mailbericht mee te geven in de mail. Dit werkt echter niet omdat dit niet werkt als safe_mode op on staat, hetgeen dus het geval is... het is helaas niet mogelijk om safe_mode op off wordt gezet.
Het gekke (in mijn ogen) is dat als ik het script start door het handmatig op te starten in de browser dan gaat het wel goed, maar dus niet als de cron job het doet.
Bestaat er misschien een mogelijkheid om de afzender of de gebruiker van de cron job ergens te wijzigen? Ik gebruik Direct admin voor het managen van de site.
Kan iemand mij hierbij helpen?

Likes:


Quote