Likes Likes:  0
Resultaten 1 tot 6 van de 6
Geen
  1. #1
    Nagios: ndomod could not open data sink!
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter

    Nagios: ndomod could not open data sink!

    Ben bezig met het opzetten van een 2e nagios server, exact dezelfde config als de eerste alleen de ndomod / ndo2db wil niet connecten met de database (MySQL 5.5.8). Heb al vanalles geprobeerd, zoals wachtwoord resetten, losse gebruiker, maar het mag allemaal niet baten.

    Unix of TCP socket maakt ook geen verschil, socket_name en output zijn gelijk aan elkaar.

    Zelfs wanneer ik in debug_level naar -1 (everything) zet krijg ik niks meer te zien als "unable to connect". In de debug.log staat alleen 1 oude regel, maar daar komt verder ook niets bij.

    Iemand enige idee wat ik over het hoofd zie / fout doe? Het gaat om een CentOS 5.5 i386 systeem i.c.m. nagios 3.2.3 en ndo2db.

    Code:
    Jan 25 21:22:33 server nagios: ndomod: Still unable to connect to data sink.  86510 items lost, 5000 queued items to flush.
    Jan 25 21:37:28 server nagios: Caught SIGTERM, shutting down...
    Jan 25 21:37:28 server nagios: Successfully shutdown... (PID=29849)
    Jan 25 21:37:29 server nagios: ndomod: Shutdown complete.
    Jan 25 21:37:29 server nagios: Event broker module '/usr/local/nagios/bin/ndomod.o' deinitialized successfully.
    Jan 25 21:37:31 server nagios: Nagios 3.2.3 starting... (PID=19705)
    Jan 25 21:37:31 server nagios: Local time is Tue Jan 25 21:37:31 CET 2011
    Jan 25 21:37:31 server nagios: LOG VERSION: 2.0
    Jan 25 21:37:31 server nagios: ndomod: NDOMOD 1.4b9 (10-27-2009) Copyright (c) 2009 Nagios Core Development Team and Community Contributors
    Jan 25 21:37:31 server nagios: ndomod: Could not open data sink!  I'll keep trying, but some output may get lost...
    Jan 25 21:37:31 server nagios: Event broker module '/usr/local/nagios/bin/ndomod.o' initialized successfully.
    Jan 25 21:37:31 server nagios: Finished daemonizing... (New PID=19717)
    Laatst gewijzigd door Boyke; 25/01/11 om 21:54. Reden: aanvulling

  2. #2
    Nagios: ndomod could not open data sink!
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    Niemand?

  3. #3
    Nagios: ndomod could not open data sink!
    geregistreerd gebruiker
    3.709 Berichten
    Ingeschreven
    22/05/05

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    24 Berichten zijn liked


    Naam: Jeroen

    Nagios opzich is voor mij geen probleem, werk alleen nooit met de ndomod dus kan je daar niet verder mee helpen

  4. #4
    Nagios: ndomod could not open data sink!
    moderator
    4.752 Berichten
    Ingeschreven
    21/02/09

    Locatie
    Noord-Holland

    Post Thanks / Like
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)
    185 Berichten zijn liked


    Naam: D. Koop
    Bedrijf: Yourwebhoster.eu
    Functie: baas
    URL: yourwebhoster.eu
    KvK nummer: 32165429
    View danielkoop's profile on LinkedIn

    Al
    Code:
    /etc/init.d/ndo2db start
    gedaan? Ik heb enige tijd geleden dit ook gehad, ik weet alleen niet wat de fout en oplossing was, ik dacht dat ik ndo2db gewoon niet gestart had.
    Met vriendelijke groet, Yourwebhoster.eu - Managed VPS diensten met Epyc performance op 100% SSDs

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  5. #5
    Nagios: ndomod could not open data sink!
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    ndo2db draaide gewoon, voor de zekerheid toch maar een keer hestart. Echter zonder resultaat...

    Code:
    [root@server ~]# /etc/init.d/ndo2db status
    ndo2db (pid 13482) is running...
    [root@server ~]# /etc/init.d/ndo2db restart
    Restarting ndo2db: Stopping ndo2db:                        [  OK  ]
    Starting ndo2db:                                           [  OK  ]
    
    Jan 30 17:07:29 server nagios: ndomod: Still unable to connect to data sink.  2291721 items lost, 5000 queued items to flush.

  6. #6
    Nagios: ndomod could not open data sink!
    geregistreerd gebruiker
    701 Berichten
    Ingeschreven
    10/12/08

    Locatie
    's-Hertogenbosch

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    19 Berichten zijn liked


    Naam: Boy
    Registrar SIDN: nee
    KvK nummer: 52000885
    Ondernemingsnummer: nvt

    Thread Starter
    Probleem lijkt opgelost, owner en group van ndomod.cfg en ndo2db.cfg stonden niet goed. Daarna nog een probleempje met de MySQL socket (opgelost met ln -s /tmp/mysql.sock /var/lib/mysql/mysql.sock).

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics