Ben bezig met het opzetten van een 2e nagios server, exact dezelfde config als de eerste alleen de ndomod / ndo2db wil niet connecten met de database (MySQL 5.5.8). Heb al vanalles geprobeerd, zoals wachtwoord resetten, losse gebruiker, maar het mag allemaal niet baten.
Unix of TCP socket maakt ook geen verschil, socket_name en output zijn gelijk aan elkaar.
Zelfs wanneer ik in debug_level naar -1 (everything) zet krijg ik niks meer te zien als "unable to connect". In de debug.log staat alleen 1 oude regel, maar daar komt verder ook niets bij.
Iemand enige idee wat ik over het hoofd zie / fout doe? Het gaat om een CentOS 5.5 i386 systeem i.c.m. nagios 3.2.3 en ndo2db.
Code:Jan 25 21:22:33 server nagios: ndomod: Still unable to connect to data sink. 86510 items lost, 5000 queued items to flush. Jan 25 21:37:28 server nagios: Caught SIGTERM, shutting down... Jan 25 21:37:28 server nagios: Successfully shutdown... (PID=29849) Jan 25 21:37:29 server nagios: ndomod: Shutdown complete. Jan 25 21:37:29 server nagios: Event broker module '/usr/local/nagios/bin/ndomod.o' deinitialized successfully. Jan 25 21:37:31 server nagios: Nagios 3.2.3 starting... (PID=19705) Jan 25 21:37:31 server nagios: Local time is Tue Jan 25 21:37:31 CET 2011 Jan 25 21:37:31 server nagios: LOG VERSION: 2.0 Jan 25 21:37:31 server nagios: ndomod: NDOMOD 1.4b9 (10-27-2009) Copyright (c) 2009 Nagios Core Development Team and Community Contributors Jan 25 21:37:31 server nagios: ndomod: Could not open data sink! I'll keep trying, but some output may get lost... Jan 25 21:37:31 server nagios: Event broker module '/usr/local/nagios/bin/ndomod.o' initialized successfully. Jan 25 21:37:31 server nagios: Finished daemonizing... (New PID=19717)

Likes:


Quote