Heren,
Heb zojuist MySQL database replicatie opgezet, alleen blijf ik met een fout zitten waarvan ik de error niet kan backtracen. Welke sysadmin heeft op zijn vrijdagavond even tijd om mij te helpen tegen een symbolische vergoeding?
Likes: 0
Heren,
Heb zojuist MySQL database replicatie opgezet, alleen blijf ik met een fout zitten waarvan ik de error niet kan backtracen. Welke sysadmin heeft op zijn vrijdagavond even tijd om mij te helpen tegen een symbolische vergoeding?

Het zou handig zijn als je hier de foutmelding + code post. Zo kunnen wij er niks mee.
Laatst gewijzigd door Domenico; 12/04/10 om 12:27.
Nouja, de foutmelding is dat hij niet kan connecten, maar ik heb de user al opnieuw aangemaakt, de poort staat gewoon open dus ik weet het niet meer, vandaar dat ik liever even een sysadmin heb die met me meekijkt...
Heb je het probleem al opgelost, pm mij anders even uw info dan kijk ik wel even

Hi
Als je even verder gemailed had, had ik je waarschijnlijk wel hiermee kunnen helpen (had wel eventjes tijd). Dan was het waarschijnlijk al opgelost.
Weet je in ieder geval of de firewall niets blokkeert?
Met vriendelijke groet, Yourwebhoster.eu - Managed VPS diensten met Epyc performance op 100% SSDs
Lees hier de webhostingtalk.nl forum regels en voorwaarden!
Staat er bij de foutmelding over het niet kunnen connecten niet meer over de reden waarom het niet lukt? ... Connection refused ofzo.
Iets meer info:
Ik heb een mysql replica alleen wanneer ik de status van de slave bekijk krijg ik een 2026 I/O error. OS is CentOS 5.4.
Echter werd ik door iemand op [ame="http://forums.fedoraforum.org/showthread.php?p=1314707"]dit[/ame] gewezen, kan ik er dan van uitgaan dat het een bug is? Zoja, hoe moet ik dan repliceren?
Update:
Inmiddels is het gelukt een van de slaves aan de praat te krijgen. Deze werkt netjes, echter bij het aanhangen van de 2e slave krijg ik weer dezelfde fout:
Het leek me logisch de my.cnf van de werkende slave te kopieren en het server-id met 1 te verhogen.Code:Last_IO_Errno: 1045 Last_IO_Error: error connecting to master 'slaveuser@ip:3306' - retry-time: 60 retries: 86400
Verder staat poort 3306 open en kan ik er met mysql -u root -h ip -p op inloggen en met telnet ip 3306 krijg ik ook verbinding.Code:[mysqld] datadir=/var/lib/mysql socket=/var/lib/mysql/mysql.sock user=mysql # Default to using old password format for compatibility with mysql 3.x # clients (those using the mysqlclient10 compatibility package). old_passwords=1 # changes made to do slave replicate-do-db=db server-id = 3 relay-log = /var/lib/mysql/mysql-relay-bin relay-log-index = /var/lib/mysql/mysql-relay-bin.index log-error = /var/lib/mysql/mysql.err #master-info-file = /var/lib/mysql/mysql-master.info relay-log-info-file = /var/lib/mysql/mysql-relay-log.info datadir = /var/lib/mysql/ # end slave setup [mysqld_safe] log-error=/var/log/mysqld.log pid-file=/var/run/mysqld/mysqld.pid
DE GOUDEN HAND OF TIP ZAL BELOOND WORDEN MET 50 EURO, WANT IK WEET HET NIET MEER.
- Zelfde versies van MySQL gebruikt?
- Ben je zeker dat de replication user ook rechten heeft vanaf het IP van de 2de slave?
- Doe op de 2de slave eens (opnieuw) een "change master" query voor alle zekerheid? Dat helpt soms...
- Wat zegt "show master status" en "show slave status" precies?
- Jep.
- Ja, zeker weten.
- Voor de 5e keer? haha.
- show slave status geeft een I/O error die ik hierboven vermeld heb. Master status geeft de position (106), de locatie van het log bestand (log.000002) en de database naam