Likes Likes:  0
Resultaten 1 tot 12 van de 12
Geen
  1. #1
    MySQL Database Replica
    geregistreerd gebruiker
    611 Berichten
    Ingeschreven
    29/01/09

    Locatie
    Meerlo

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    32 Berichten zijn liked


    Naam: T
    Registrar SIDN: nee
    KvK nummer: 14115174
    Ondernemingsnummer: nvt

    Thread Starter

    MySQL Database Replica

    Heren,

    Heb zojuist MySQL database replicatie opgezet, alleen blijf ik met een fout zitten waarvan ik de error niet kan backtracen. Welke sysadmin heeft op zijn vrijdagavond even tijd om mij te helpen tegen een symbolische vergoeding?

  2. #2
    MySQL Database Replica
    .com
    2.656 Berichten
    Ingeschreven
    24/04/09

    Locatie
    Gemeente Castricum

    Post Thanks / Like
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    104 Berichten zijn liked


    Bedrijf: WebMeso ISP
    Functie: Eigenaar
    URL: www.webmeso.com
    KvK nummer: 55691153

    Het zou handig zijn als je hier de foutmelding + code post. Zo kunnen wij er niks mee.
    Laatst gewijzigd door Domenico; 12/04/10 om 12:27.

  3. #3
    MySQL Database Replica
    geregistreerd gebruiker
    611 Berichten
    Ingeschreven
    29/01/09

    Locatie
    Meerlo

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    32 Berichten zijn liked


    Naam: T
    Registrar SIDN: nee
    KvK nummer: 14115174
    Ondernemingsnummer: nvt

    Thread Starter
    Nouja, de foutmelding is dat hij niet kan connecten, maar ik heb de user al opnieuw aangemaakt, de poort staat gewoon open dus ik weet het niet meer, vandaar dat ik liever even een sysadmin heb die met me meekijkt...

  4. #4
    MySQL Database Replica
    geregistreerd gebruiker
    21 Berichten
    Ingeschreven
    28/05/07

    Locatie
    brugge

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Bram
    Bedrijf: What If
    URL: www.whatif.be
    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: 1004097973

    Heb je het probleem al opgelost, pm mij anders even uw info dan kijk ik wel even

  5. #5
    MySQL Database Replica
    moderator
    4.752 Berichten
    Ingeschreven
    21/02/09

    Locatie
    Noord-Holland

    Post Thanks / Like
    Mentioned
    25 Post(s)
    Tagged
    0 Thread(s)
    185 Berichten zijn liked


    Naam: D. Koop
    Bedrijf: Yourwebhoster.eu
    Functie: baas
    URL: yourwebhoster.eu
    KvK nummer: 32165429
    View danielkoop's profile on LinkedIn

    Hi
    Als je even verder gemailed had, had ik je waarschijnlijk wel hiermee kunnen helpen (had wel eventjes tijd). Dan was het waarschijnlijk al opgelost.

    Weet je in ieder geval of de firewall niets blokkeert?
    Met vriendelijke groet, Yourwebhoster.eu - Managed VPS diensten met Epyc performance op 100% SSDs

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  6. #6
    MySQL Database Replica
    geregistreerd gebruiker
    666 Berichten
    Ingeschreven
    08/01/09

    Locatie
    Halen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Andy

    Staat er bij de foutmelding over het niet kunnen connecten niet meer over de reden waarom het niet lukt? ... Connection refused ofzo.

  7. #7
    MySQL Database Replica
    geregistreerd gebruiker
    611 Berichten
    Ingeschreven
    29/01/09

    Locatie
    Meerlo

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    32 Berichten zijn liked


    Naam: T
    Registrar SIDN: nee
    KvK nummer: 14115174
    Ondernemingsnummer: nvt

    Thread Starter
    Iets meer info:

    Ik heb een mysql replica alleen wanneer ik de status van de slave bekijk krijg ik een 2026 I/O error. OS is CentOS 5.4.

    Echter werd ik door iemand op [ame="http://forums.fedoraforum.org/showthread.php?p=1314707"]dit[/ame] gewezen, kan ik er dan van uitgaan dat het een bug is? Zoja, hoe moet ik dan repliceren?

  8. #8
    MySQL Database Replica
    geregistreerd gebruiker
    611 Berichten
    Ingeschreven
    29/01/09

    Locatie
    Meerlo

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    32 Berichten zijn liked


    Naam: T
    Registrar SIDN: nee
    KvK nummer: 14115174
    Ondernemingsnummer: nvt

    Thread Starter
    Update:

    Inmiddels is het gelukt een van de slaves aan de praat te krijgen. Deze werkt netjes, echter bij het aanhangen van de 2e slave krijg ik weer dezelfde fout:

    Code:
     
    Last_IO_Errno: 1045
    Last_IO_Error: error connecting to master 'slaveuser@ip:3306' - retry-time: 60  retries: 86400
    Het leek me logisch de my.cnf van de werkende slave te kopieren en het server-id met 1 te verhogen.

    Code:
    [mysqld]
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    user=mysql
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1
    # changes made to do slave
    replicate-do-db=db
    server-id = 3
    relay-log = /var/lib/mysql/mysql-relay-bin
    relay-log-index = /var/lib/mysql/mysql-relay-bin.index
    log-error = /var/lib/mysql/mysql.err
    #master-info-file = /var/lib/mysql/mysql-master.info
    relay-log-info-file = /var/lib/mysql/mysql-relay-log.info
    datadir = /var/lib/mysql/
    # end slave setup
    
    [mysqld_safe]
    log-error=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    Verder staat poort 3306 open en kan ik er met mysql -u root -h ip -p op inloggen en met telnet ip 3306 krijg ik ook verbinding.

    DE GOUDEN HAND OF TIP ZAL BELOOND WORDEN MET 50 EURO, WANT IK WEET HET NIET MEER.

  9. #9
    MySQL Database Replica
    geregistreerd gebruiker
    666 Berichten
    Ingeschreven
    08/01/09

    Locatie
    Halen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Andy

    - Zelfde versies van MySQL gebruikt?

    - Ben je zeker dat de replication user ook rechten heeft vanaf het IP van de 2de slave?

    - Doe op de 2de slave eens (opnieuw) een "change master" query voor alle zekerheid? Dat helpt soms...

    - Wat zegt "show master status" en "show slave status" precies?

  10. #10
    MySQL Database Replica
    geregistreerd gebruiker
    611 Berichten
    Ingeschreven
    29/01/09

    Locatie
    Meerlo

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    32 Berichten zijn liked


    Naam: T
    Registrar SIDN: nee
    KvK nummer: 14115174
    Ondernemingsnummer: nvt

    Thread Starter
    - Jep.

    - Ja, zeker weten.

    - Voor de 5e keer? haha.

    - show slave status geeft een I/O error die ik hierboven vermeld heb. Master status geeft de position (106), de locatie van het log bestand (log.000002) en de database naam

  11. #11
    MySQL Database Replica
    geregistreerd gebruiker
    1.913 Berichten
    Ingeschreven
    23/10/03

    Locatie
    Enschede (+ London)

    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    33 Berichten zijn liked


    Naam: Max
    Registrar SIDN: ja
    KvK nummer: 08119406
    Ondernemingsnummer: -

    Citaat Oorspronkelijk geplaatst door T. Verhaeg Bekijk Berichten
    en kan ik er met mysql -u root -h ip -p op inloggen
    Ook met mysql -u slaveuser -h ip -p ?

  12. #12
    MySQL Database Replica
    geregistreerd gebruiker
    666 Berichten
    Ingeschreven
    08/01/09

    Locatie
    Halen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Andy

    Citaat Oorspronkelijk geplaatst door maxnet Bekijk Berichten
    Ook met mysql -u slaveuser -h ip -p ?
    Aangezien hij op mijn 2de vraag in mijn voorgaande post "ja, zeker weten" heeft getypt veronderstel ik van wel...

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics