Likes Likes:  0
Resultaten 1 tot 15 van de 29
Pagina 1 van de 2 1 2 LaatsteLaatste
Geen
  1. #1
    centos yum update error
    geregistreerd gebruiker
    35 Berichten
    Ingeschreven
    16/10/05

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    centos yum update error

    hoi,

    Ik krijg een error voor een update met centos
    iemand een idee hoe ik dit kan verhelpen?

    ---
    filelists.xml.gz | 3.5 MB 00:13
    filelists.xml.gz | 1.0 MB 00:00
    Traceback (most recent call last):
    File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
    File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)
    File "/usr/share/yum-cli/yummain.py", line 145, in main
    (result, resultmsgs) = base.buildTransaction()
    File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 647, in buildTransaction
    (rescode, restring) = self.resolveDeps()
    File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 704, in resolveDeps
    for po, dep in self._checkFileRequires():
    File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 939, in _checkFileRequires
    if not self.tsInfo.getOldProvides(filename) and not self.tsInfo.getNewProvides(filename):
    File "/usr/lib/python2.4/site-packages/yum/transactioninfo.py", line 414, in getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
    File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 300, in getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
    File "/usr/lib/python2.4/site-packages/yum/packageSack.py", line 470, in _computeAggregateDictResult
    sackResult = apply(method, args)
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 861, in getProvides
    return self._search("provides", name, flags, version)
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 837, in _search
    for pkg in self.searchFiles(name, strict=True):
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 43, in newFunc
    return func(*args, **kwargs)
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 586, in searchFiles
    self._sql_pkgKey2po(rep, cur, pkgs)
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 470, in _sql_pkgKey2po
    pkg = self._packageByKey(repo, ob['pkgKey'])
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 413, in _packageByKey
    po = self.pc(repo, cur.fetchone())
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 68, in __init__
    self._read_db_obj(db_obj)
    File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 94, in _read_db_obj
    setattr(self, item, _share_data(db_obj[item]))
    TypeError: unsubscriptable object

    ---

  2. #2
    centos yum update error
    geregistreerd gebruiker
    676 Berichten
    Ingeschreven
    22/01/09

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Google zegt er een hele hoop over;

    Het volgende zou je kunnen helpen;

    http://just-another.net/2008/11/22/c...grade-and-yum/

    Eeek! Got the same error when running yum makecache. Quick look at the traceback is somewhat obvious, the DB schema changed, but the DB didn’t get upgraded! Easy fix is to clear out your yum cache like so:

    # cd /var/cache/yum
    # rm -r *
    And then you’ll want to regenerate your cache like so:

    # yum makecache

  3. #3
    centos yum update error
    geregistreerd gebruiker
    35 Berichten
    Ingeschreven
    16/10/05

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    bedankt!

  4. #4
    centos yum update error
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Ik had hetzelde probleem, alternatieve makkelijke oplossing:

    yum clean metadata

    Daarna werkt yum update ook weer gewoon.

    Edit: Zie nu opeens, oude post die na 4 dagen opeens als nieuw werd aangegeven? Wellicht iemand iets geplaatst en weer gewist ofzo?

  5. #5
    centos yum update error
    Web hosting diensten
    4.705 Berichten
    Ingeschreven
    09/02/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    110 Berichten zijn liked


    Bedrijf: DreamHost.nl Web hosting
    Functie: Managing Director
    URL: www.dreamhost.nl
    Registrar SIDN: JA
    KvK nummer: 24269577

    Citaat Oorspronkelijk geplaatst door Blacky Bekijk Berichten
    Edit: Zie nu opeens, oude post die na 4 dagen opeens als nieuw werd aangegeven? Wellicht iemand iets geplaatst en weer gewist ofzo?
    Wellicht deze thread nog niet eerder bekeken?
    DreamHost.nl Web hosting - cPanel hosting om bij weg te dromen.

  6. #6
    centos yum update error
    geregistreerd gebruiker
    11 Berichten
    Ingeschreven
    10/01/10

    Locatie
    oostburg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    ja ik it nog steeds met zelfde probleem

    na yum update
    krijg ik

    Loadong fastest mirrors
    Traceback (most recent call last):
    File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
    File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    errcode = main(args)

    enz. nog een stukje

    na yum clean metadata
    krijg ik
    Loading "fastestmirror" plugin
    10 metadata files removed

    maar na dan weer yum update te doen
    krijg ik weer
    Traceback (most recent call last):
    File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
    File "/usr/share/yum-cli/yummain.py", line 229, in user_main
    AttributeError: 'module'objesct has no attribute 'iterpaserse'


    na rpm -qa | grep yum
    yum-metadata-parser-1.1.2.2.el5
    yum-fastestmirror-1.1.10.9.el5.centos
    yum-3.2.8.9.el5.centos.2.1

    iemand een idee hoe ik me yum weer goed krijg?
    gebruik een remote system met directadmin er ook op maat dat moet niet uit maken.

    iemand???

  7. #7
    centos yum update error
    geregistreerd gebruiker
    3.709 Berichten
    Ingeschreven
    22/05/05

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    24 Berichten zijn liked


    Naam: Jeroen

    yum clean all

    En de oplossingen die hier genoemd worden: [ame=http://www.google.nl/search?hl=nl&q=yummain.user_main%28sys.argv[1%3A]%2C+exit_code%3DTrue%29&btnG=Zoeken&meta=&aq=f&oq=]yummain.user_main(sys.argv - Google zoeken[/ame]

    al geprobeerd?

  8. #8
    centos yum update error
    geregistreerd gebruiker
    11 Berichten
    Ingeschreven
    10/01/10

    Locatie
    oostburg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    na yum clean all

    Loading "fastestmirror" plugin
    Cleaning up Everything
    Cleaning up list of fastest mirrors


    na update
    ftp.nluug.nl already timed: 0.0132350921631
    * ftp.nluug.nl : 0.013235 secs
    mirrors.nl.kernel.org already timed: 0.0196089744568
    * mirrors.nl.kernel.org : 0.019609 secs
    mirror.leaseweb.com already timed: 0.01500415802
    * mirror.leaseweb.com : 0.015004 secs
    mirror.liteserver.nl already timed: 0.0116460323334
    * mirror.liteserver.nl : 0.011646 secs
    mirror.oxilion.nl already timed: 0.0150899887085
    * mirror.oxilion.nl : 0.015090 secs
    archive.cs.uu.nl already timed: 0.0166440010071
    * archive.cs.uu.nl : 0.016644 secs
    ftp.tudelft.nl already timed: 0.0165159702301
    * ftp.tudelft.nl : 0.016516 secs
    centos.mirror.transip.nl already timed: 0.0204229354858
    * centos.mirror.transip.nl : 0.020423 secs
    * extras: mirror.liteserver.nl
    Excluding Packages in global exclude list
    Terminated


    na nog eens te doen
    [root@3 pluginconf.d]# yum update
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
    * base: mirror.liteserver.nl
    * updates: mirror.liteserver.nl
    * addons: mirror.liteserver.nl
    * extras: mirror.liteserver.nl
    Excluding Packages in global exclude list
    Finished
    Setting up Update Process
    Killed

    maar na yum upgrade krijg ik
    [root@3 pluginconf.d]# yum upgrade
    Loading "fastestmirror" plugin
    Loading mirror speeds from cached hostfile
    * base: mirror.liteserver.nl
    * updates: mirror.liteserver.nl
    * addons: mirror.liteserver.nl
    * extras: mirror.liteserver.nl
    Excluding Packages in global exclude list
    Finished
    Setting up Upgrade Process
    Killed

    en er worden geen upgrades gedaan

  9. #9
    centos yum update error
    geregistreerd gebruiker
    1.674 Berichten
    Ingeschreven
    15/02/04

    Locatie
    Arnhem

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked



    Heb je iets draaien dat lang draaiende processes killed?

  10. #10
    centos yum update error
    geregistreerd gebruiker
    2.731 Berichten
    Ingeschreven
    20/05/05

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked



    Code:
    uname -a

  11. #11
    centos yum update error
    geregistreerd gebruiker
    11 Berichten
    Ingeschreven
    10/01/10

    Locatie
    oostburg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door PeterT Bekijk Berichten
    Heb je iets draaien dat lang draaiende processes killed?
    uu nee niet dat ik weet kan ook niks vinden verder er over.

    en uname -a geeft

    Linux 3.nilix.net 2.6.18-028stab066.8 #1 SMP Fri Nov 27 20:19:25 MSK 2009 x86_64 x86_64 x86_64 GNU/Linux

    iemand een idee??

  12. #12
    centos yum update error
    geregistreerd gebruiker
    1.712 Berichten
    Ingeschreven
    03/01/07

    Locatie
    Winschoten / Groningen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Kobus Draijer
    Bedrijf: IC Hosting
    URL: www.ic-hosting.nl
    Registrar SIDN: ja
    KvK nummer: 02079831
    Ondernemingsnummer: nvt
    TrustCloud: ichosting

    Citaat Oorspronkelijk geplaatst door nilix Bekijk Berichten
    uu nee niet dat ik weet kan ook niks vinden verder er over.
    Daar lijkt het idd wel op. Ben je alle crons nagelopen?

  13. #13
    centos yum update error
    geregistreerd gebruiker
    11 Berichten
    Ingeschreven
    10/01/10

    Locatie
    oostburg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    ja hoor en kan niks vinden dat het killed steeds.
    vind ook niks op google er zo snel er over

  14. #14
    centos yum update error
    geregistreerd gebruiker
    1.712 Berichten
    Ingeschreven
    03/01/07

    Locatie
    Winschoten / Groningen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Kobus Draijer
    Bedrijf: IC Hosting
    URL: www.ic-hosting.nl
    Registrar SIDN: ja
    KvK nummer: 02079831
    Ondernemingsnummer: nvt
    TrustCloud: ichosting

    Nu ja, er is toch echt iets die je opdracht killed. Staat er ook duidelijk onder

    Excluding Packages in global exclude list
    Finished
    Setting up Upgrade Process
    Killed

    Welke crons heb je gezien? Ook die van apache bijvoorbeeld?

  15. #15
    centos yum update error
    geregistreerd gebruiker
    11 Berichten
    Ingeschreven
    10/01/10

    Locatie
    oostburg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    in de file /etc/cron.deny staater

    apache
    webapps
    in de file etc/cron.d/directadmincron


    * * * * * root /usr/local/directadmin/dataskq
    2 0-23/6 * * * root echo 'action=vacation&value=all' >> /usr/local/directadmin/$
    #5 5 * * 0 root /sbin/quotaoff -a; /sbin/quotacheck -augm; /sbin/quotaon -a;
    10 0 * * * root echo 'action=tally&value=all' >> /usr/local/directadmin/data/ta$
    20 4 1 * * root echo 'action=reset&value=all' >> /usr/local/directadmin/data/ta$
    0 4 * * * root echo 'action=check&value=license' >> /usr/local/directadmin/data$


    /etc/cron.daily staan de files
    logrotate
    makewhatis.cron
    mlocate.cron
    rpm
    tmpwatch


    -tmpwatch


    /usr/sbin/tmpwatch -x /tmp/.X11-unix -x /tmp/.XIM-unix -x /tmp/.font-unix \
    -x /tmp/.ICE-unix -x /tmp/.Test-unix 240 /tmp
    /usr/sbin/tmpwatch 720 /var/tmp
    for d in /var/{cache/man,catman}/{cat?,X11R6/cat?,local/cat?}; do
    if [ -d "$d" ]; then
    /usr/sbin/tmpwatch -f 720 "$d"
    fi
    done


    de rpm file

    #!/bin/sh

    /bin/rpm -qa --qf '%{name}-%{version}-%{release}.%{arch}.rpm\n' 2>&1 \
    | /bin/sort > /var/log/rpmpkgs


    de mlocate.cron file
    #!/bin/sh
    nodevs=$(< /proc/filesystems awk '$1 == "nodev" { print $2 }')
    renice +19 -p $$ >/dev/null 2>&1
    /usr/bin/updatedb -f "$nodevs"


    makewhatis.cron

    #!/bin/bash

    LOCKFILE=/var/lock/makewhatis.lock

    # the lockfile is not meant to be perfect, it's just in case the
    # two makewhatis cron scripts get run close to each other to keep
    # them from stepping on each other's toes. The worst that will
    # happen is that they will temporarily corrupt the database...
    [ -f $LOCKFILE ] && exit 0
    trap "{ rm -f $LOCKFILE ; exit 255; }" EXIT
    touch $LOCKFILE
    makewhatis -u -w
    exit 0

    logrotate

    #!/bin/sh

    /usr/sbin/logrotate /etc/logrotate.conf
    EXITVALUE=$?
    if [ $EXITVALUE != 0 ]; then
    /usr/bin/logger -t logrotate "ALERT exited abnormally with [$EXITVALUE]"
    fi
    exit 0



    zie geen apache er bij staan of zo
    of zoek ik verkeert?

Pagina 1 van de 2 1 2 LaatsteLaatste

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics