Likes Likes:  0
Resultaten 1 tot 15 van de 34
Pagina 1 van de 3 1 2 3 LaatsteLaatste
Geen
  1. #1
    API Script Transip.nl
    geregistreerd gebruiker
    24 Berichten
    Ingeschreven
    26/11/09

    Locatie
    Lexmond

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    API Script Transip.nl

    Hallo allemaal,

    Ik heb het API script van transip.nl gedownload en heb de configuratie doorgelezen en ben aan de slag gegaan. https://www.transip.nl/pro/domein-registratie/api/ Ik heb de apisettings.php bewerkt met de juiste gegevens. In een ander documentje de HASH uitgevoerd Nu krijg ik dat nummer Maar mijn vraag is wat moet ik daar nu mee? Waar moet ik die tussen zetten. Vanaf daar loop ik helemaal vast ik heb de hash al in de apisettigs,php gezet en dan kom ik op een blanco pagina. Wie kan mij verder helpen.

    Als ik de apisettings aan de praat krijg kan ik dan gewoon de domeincheck enzo gebruiken?

    alvast bedankt.

  2. #2
    API Script Transip.nl
    geregistreerd gebruiker
    324 Berichten
    Ingeschreven
    06/12/07

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Tijn

    - de hash moet onderaan in ApiSettings.php
    public static $hash = 'HIER';
    - Als je verder in je TransIP control panel de instellingen* goed hebt staan, kun je inderdaad gebruik maken van de domeincheck, maar ook de andere functies die TransIP mogelijk heeft gemaakt.

    * In je TransIP panel: instellingen > Uw reseller opties: API

    Probeer dan eens om bijvoorbeeld het bestand DomainService-checkAvailability.php in je browser te openen, en zie of het werkt. Indien je foutmeldingen krijgt, laat het maar horen.

  3. #3
    API Script Transip.nl
    geregistreerd gebruiker
    24 Berichten
    Ingeschreven
    26/11/09

    Locatie
    Lexmond

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Ik heb nu dit:

    PHP Code:
    <?php

    /**
     * This class holds the settings for the TransIP API.
     */
    class Transip_ApiSettings
    {
        
    /**
         * The mode in which the API operates, can be either:
         *        readonly
         *        readwrite
         *
         * In readonly mode, no modifying functions can be called.
         * To make persistent changes, readwrite mode should be enabled.
         */
        
    public static $mode    = 'readwrite';

        
    /**
         * Your login name on the TransIP website.
         *
         */
        
    public static $login = 'delfos';

        
    /**
         * The authentication hash, md5('login:password@ip')
         */
        
    public static $hash    = 'Login:wachwoord@91.196.171.231';
    }

    ?>

    Of moet er bij $hash = 'hashnummer83832383' staan?

    Edit

    Ik ben er van uitgegaan dat je het 'nummer' bedoelde nu krijg ik de volgende melding:

    PHP Code:
    Fatal error: require_once  [function.require]: Failed opening required 'Transip/DomainService.php' (include_path='.:/usr/local/lib/php') in /home/ibum/domains/ibum.nl/public_html/ 

    Terwijl dit bestand wel geupload staat.
    Laatst gewijzigd door Ibum; 26/11/09 om 18:47.

  4. #4
    API Script Transip.nl
    Joh.3:16
    1.552 Berichten
    Ingeschreven
    31/08/08

    Locatie
    Delfzijl

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    3 Berichten zijn liked



    iets als dit moet het zijn:

    Code:
    	/**
    	 * The authentication hash, md5('login:password@ip')
    	 */
    	public static $hash	= 'jhgjg4jh5gjhg345jh5jh67yk67jh';

  5. #5
    API Script Transip.nl
    geregistreerd gebruiker
    24 Berichten
    Ingeschreven
    26/11/09

    Locatie
    Lexmond

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Dat heb ik nu gedaan, als je nu naar DomainService-checkAvailability.php gaat krijg je de volgende melding:

    Fatal error: require_once [function.require]: Failed opening required 'Transip/DomainService.php' (include_path='.:/usr/local/lib/php') in /home/ibum/domains/ibum.nl/public_html/

    Zoals hier je kunt zien: http://www.ibum.nl/transip/DomainSer...ailability.php

  6. #6
    API Script Transip.nl
    geregistreerd gebruiker
    56 Berichten
    Ingeschreven
    08/10/09

    Locatie
    Tilburg

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Naam: Jurgen
    URL: www.goconnected.net
    Registrar SIDN: Nee
    KvK nummer: 17261325

    Je draait je website op een linux bak? Je weet namelijk dat linux een verschil ziet in hoofdletters en kleine letters? Probeer je required bestand "Transip/..." te veranderen naar "transip/...".

  7. #7
    API Script Transip.nl
    geregistreerd gebruiker
    24 Berichten
    Ingeschreven
    26/11/09

    Locatie
    Lexmond

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Dit maakt geen verschil...

  8. #8
    API Script Transip.nl
    Registered User
    474 Berichten
    Ingeschreven
    01/12/08

    Locatie
    Zuid - Holland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: Nvt
    Ondernemingsnummer: Nvt

    Het lijkt erop dat het bestand niet op de server staat, of het verkeerde bestand wordt aangeroepen in een verkeerde map.

    Code:
    No such file or directory in /home/ibum/domains/ibum.nl/public_html/transip/DomainService-checkAvailability.php on line 2
    Wat staat er bij line 2 ?

  9. #9
    API Script Transip.nl
    geregistreerd gebruiker
    24 Berichten
    Ingeschreven
    26/11/09

    Locatie
    Lexmond

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Dit staat er in regel 2:

    require_once('Transip/DomainService.php');

  10. #10
    API Script Transip.nl
    geregistreerd gebruiker
    324 Berichten
    Ingeschreven
    06/12/07

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Tijn

    Kijk even goed of of je in je FTP ook daadwerkelijk die map Transip hebt staan.
    Stuur me anders een pm met je msn/email, dan help ik je wel even

  11. #11
    API Script Transip.nl
    geregistreerd gebruiker
    324 Berichten
    Ingeschreven
    06/12/07

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Tijn

    Opgelost

  12. #12
    API Script Transip.nl
    Server Freak
    3.640 Berichten
    Ingeschreven
    19/05/06

    Locatie
    Assen

    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    215 Berichten zijn liked


    Naam: Sinterklaas

    Citaat Oorspronkelijk geplaatst door goconnected Bekijk Berichten
    Je draait je website op een linux bak? Je weet namelijk dat linux een verschil ziet in hoofdletters en kleine letters? Probeer je required bestand "Transip/..." te veranderen naar "transip/...".
    Binnen de TransIP api wordt alles goed aangeroepen. Je moet dus niet Transip in transip gaan veranderen, want dan werkt het niet meer op een linuxbak.

  13. #13
    API Script Transip.nl
    geregistreerd gebruiker
    24 Berichten
    Ingeschreven
    26/11/09

    Locatie
    Lexmond

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Probleem opgelost. Het lag aan de mappenstructuur.

    Mijn dank gaat uit naar Moc die ons goed geholpen heeft.

  14. #14
    API Script Transip.nl
    geregistreerd gebruiker
    24 Berichten
    Ingeschreven
    26/11/09

    Locatie
    Lexmond

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Het is nog niet opgelost. Als je naar de volgende link gaat http://http://www.ibum.nl/transip/do...in=testibum.nl Dan heb ik al een domeinnaam ingevuld zolas je ziet is dat testibum.nl

    Dan krijg je de volgende foutmeldingen:

    Code:
    Warning: SoapClient::SoapClient() [soapclient.soapclient]: php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /home/ibum/domains/ibum.nl/public_html/transip/Transip/DomainService.php on line 48
    
    Warning: SoapClient::SoapClient(https://api.transip.nl/wsdl/?service=DomainService) [soapclient.soapclient]: failed to open stream: php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /home/ibum/domains/ibum.nl/public_html/transip/Transip/DomainService.php on line 48
    
    Warning: SoapClient::SoapClient() [soapclient.soapclient]: I/O warning : failed to load external entity "https://api.transip.nl/wsdl/?service=DomainService" in /home/ibum/domains/ibum.nl/public_html/transip/Transip/DomainService.php on line 48

    Hij kan de gegevens niet aanroepen lijkt wel

    Dit staat er op line 48

    Code:
    self::$_soapClient = new SoapClient(self::WSDL, $options);
    
    			self::$_soapClient->__setCookie('login', Transip_ApiSettings::$login);
    			self::$_soapClient->__setCookie('hash', Transip_ApiSettings::$hash);
    			self::$_soapClient->__setCookie('mode', Transip_ApiSettings::$mode);
    Maar die gegevens kloppen echt in ApiSettings.php
    Laatst gewijzigd door Ibum; 27/11/09 om 09:26.

  15. #15
    API Script Transip.nl
    Server Freak
    3.640 Berichten
    Ingeschreven
    19/05/06

    Locatie
    Assen

    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    215 Berichten zijn liked


    Naam: Sinterklaas

    Heb je de API in het TransIP controlepaneel wel geactiveerd?
    Blokkeer je niet de uitgaande poort?

Pagina 1 van de 3 1 2 3 LaatsteLaatste

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics