Likes Likes:  0
Resultaten 1 tot 15 van de 20
Pagina 1 van de 2 1 2 LaatsteLaatste
Geen
  1. #1
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    9 Berichten
    Ingeschreven
    04/04/09

    Locatie
    Europa =)

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    Dovecot wil maar niet starten!

    Hey allemaal,

    Het is al even geleden dat ik nog gepost heb op dit forum maar ik zit nu met een probleem dat uit het niets is opgedoken.

    Ik krijg nu steeds een bericht dat de service dovecot down is op mijn server.

    Hier ziin de commands met hun output:
    Code:
    [root@server ~]# service dovecot stop
    Stopping Dovecot Imap:                                     [FAILED]
    [root@server ~]# service dovecot start
    Starting Dovecot Imap: Warning: Last died with error (see error log for more information): Auth process died too early - shutting down
    Info: If you have trouble with authentication failures,
    enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
                                                               [  OK  ]
    [root@server ~]# service dovecot status
    dovecot dead but pid file exists

    Klik hier om te zien wat er in mijn configuration file staat.

    Als ik dan in mijn /var/log/maillog ga kijken dan staat dit er:

    Code:
    Jul 28 10:16:01 server dovecot[2680]: Dovecot v1.2.1 starting up (core dumps disabled)
    Jul 28 10:16:01 server dovecot[2680]: child 2682 (auth) returned error 89 (Fatal failure)
    Jul 28 10:16:01 server dovecot[2680]: auth(default): Fatal: Support not compiled in for passdb driver 'pam'
    Jul 28 10:16:01 server dovecot[2680]: dovecot: Fatal: Auth process died too early - shutting down
    Mijn box draait op CentOS, ik hoop dat iemand me hier mee kan helpen.

    Groetjes!

  2. #2
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    1.088 Berichten
    Ingeschreven
    30/04/09

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    14 Berichten zijn liked


    KvK nummer: 51985977

    Iets met PAM authenticatie?
    Zet eens een # voor regel 795 (passdb pam {)
    En uiteraard ook op regel 828.

    Probeer daarna nogmaals Dovecot te starten, mocht het niet werken, post dan nogmaals je log.

  3. #3
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    9 Berichten
    Ingeschreven
    04/04/09

    Locatie
    Europa =)

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Ik heb gedaan wat je net gezegd had maar het werkt blijkbaar nog niet.

    Dit staat er nu in de log:

    Code:
    Jul 28 10:29:11 server dovecot[21868]: Dovecot v1.2.1 starting up (core dumps disabled)
    Jul 28 10:29:11 server dovecot[21868]: child 21869 (auth) returned error 89 (Fatal failure)
    Jul 28 10:29:11 server dovecot[21868]: auth(default): Fatal: No passdbs specified in configuration file. PLAIN mechanism needs one
    Jul 28 10:29:11 server dovecot[21868]: dovecot: Fatal: Auth process died too early - shutting down
    Dank je voor de interesse om me verder te helpen. Ik hoop echt dat ik dit opgelost krijg want volgens mij gaat mijn server load er van omhoog omdat hij steeds die dovecot probeert op te starten.

    Ik wacht op verdere hulp.

    Groetjes,

    TheBiaatch

  4. #4
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    1.088 Berichten
    Ingeschreven
    30/04/09

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    14 Berichten zijn liked


    KvK nummer: 51985977

    Het is dus duidelijk te zien dat er iets met passdbs aan de hand is. Kijk ook even alles na in /etc/pam.d/dovecot over authenticatie. En wat doet dovecot -n ?

  5. #5
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    2.731 Berichten
    Ingeschreven
    20/05/05

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked



    [root@server ~]# service dovecot status
    dovecot dead but pid file exists
    Wanneer een proces niet opstart, houd het vaak in dat er nog een proces draait.
    Probeer dovecot eerst eens simpel te killen en daarna opstarten.

    Zonder succes, iets uitgebreider killen m.b.v.
    Code:
    # service dovecot stop
    # rm -f /var/run/dovecot.pid
    # service directadmin start

  6. #6
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    9 Berichten
    Ingeschreven
    04/04/09

    Locatie
    Europa =)

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    @xaban:

    Als ik dovecot -n doe dan krijg ik de volgende output:
    Code:
    [root@server log]# dovecot -n
    # 1.2.1: /etc/dovecot.conf
    # OS: Linux 2.6.18-128.1.14.el5 i686 CentOS release 5.3 (Final) 
    ssl_cert_file: /etc/pki/dovecot/certs/dovecot.pem
    ssl_key_file: /etc/pki/dovecot/private/dovecot.pem
    login_dir: /var/run/dovecot/login
    login_executable: /usr/libexec/dovecot/imap-login
    auth default:
      userdb:
        driver: passwd

    @Geert-Jan:

    Dovecot stoppen enzo werkt niet. had ik al geprobeerd.

    Code:
    [root@server log]# service dovecot stop
    Stopping Dovecot Imap:                                     [FAILED]
    [root@server log]# rm -f /var/run/dovecot.pid
    [root@server log]# service directadmin start
    Starting DirectAdmin: 
    [root@server log]# service dovecot status
    dovecot dead but pid file exists
    [root@server log]# killall -9 dovecott
    dovecott: no process killed
    [root@server log]# service dovecot start
    Starting Dovecot Imap: Warning: Last died with error (see error log for more information): Auth process died too early - shutting down
    Info: If you have trouble with authentication failures,
    enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
                                                               [  OK  ]
    Ik ben nog steeds opzoek naar iemand die me hier mee kan helpen.

    Groetjes,

    TheBiaatch

  7. #7
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    1.088 Berichten
    Ingeschreven
    30/04/09

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    14 Berichten zijn liked


    KvK nummer: 51985977

    Het is duidelijk een configuratie fout. Het gaat verkeerd met de authenticatie. Ik gebruik zelf geen Dovecot, dus moeilijk voor mij om het snel te vinden maar lijkt me erg simpel als je even in de configuratie bestanden duikt.

  8. #8
    Dovecot wil maar niet starten!
    ISPConnect
    3.772 Berichten
    Ingeschreven
    10/01/07

    Locatie
    Nieuwegein

    Post Thanks / Like
    Mentioned
    39 Post(s)
    Tagged
    0 Thread(s)
    134 Berichten zijn liked


    Naam: Marin Heideman
    Bedrijf: DigiState B.V.
    URL: http://www.digistate.nl
    ISPConnect: Lid
    View mheideman's profile on LinkedIn

    Ik denk dat er een useflag niet goed heeft gestaan bij het compilen.. Heb je dovecot met YUM binnen gehaald?
    Marin Heideman (DigiState B.V.)

  9. #9
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    9 Berichten
    Ingeschreven
    04/04/09

    Locatie
    Europa =)

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Vermits ik Directadmin op mijn box staan heb, heb ik het volgend gedaan om dovecot te builden/updaten/installen:

    Code:
    cd /usr/local/directadmin/customapache
    ./build update
    ./build clean
    ./build update_dovecot
    ./build dovecot
    /sbin/service dovecot restart

  10. #10
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    1.712 Berichten
    Ingeschreven
    03/01/07

    Locatie
    Winschoten / Groningen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Kobus Draijer
    Bedrijf: IC Hosting
    URL: www.ic-hosting.nl
    Registrar SIDN: ja
    KvK nummer: 02079831
    Ondernemingsnummer: nvt
    TrustCloud: ichosting

    Niet goed gelezen

  11. #11
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    2.731 Berichten
    Ingeschreven
    20/05/05

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked



    Handig als je dat in je openingspost vermeld....

    apache is oud en word niet meer ondersteund, go to build.

  12. #12
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    9 Berichten
    Ingeschreven
    04/04/09

    Locatie
    Europa =)

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Zou iemand me dan kunnen zeggen wat ik moet doen?

    Sorry dat ik het niet vermeld heb in mijn post maar zoals jullie al wel ondervonden hebben ben ik niet super op gebied van server administration.

  13. #13
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    1.712 Berichten
    Ingeschreven
    03/01/07

    Locatie
    Winschoten / Groningen

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Naam: Kobus Draijer
    Bedrijf: IC Hosting
    URL: www.ic-hosting.nl
    Registrar SIDN: ja
    KvK nummer: 02079831
    Ondernemingsnummer: nvt
    TrustCloud: ichosting

    Zoals GeertJan aangeeft zou je apache kunnen updaten naar versie 2.x via custombuild van directadmin.

  14. #14
    Dovecot wil maar niet starten!
    geregistreerd gebruiker
    2.731 Berichten
    Ingeschreven
    20/05/05

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    6 Berichten zijn liked



    Citaat Oorspronkelijk geplaatst door TheBiaatch Bekijk Berichten
    Zou iemand me dan kunnen zeggen wat ik moet doen?

    Sorry dat ik het niet vermeld heb in mijn post maar zoals jullie al wel ondervonden hebben ben ik niet super op gebied van server administration.
    Dat laatste is geen probleem, alleen vervelend omdat we dan hier in Yum denken i.p.v. build...

    Dat eerste, koffie zetten en naar build gaan, apache wordt niet meer zo ondersteund, en je bent up_2_date.

  15. #15
    Dovecot wil maar niet starten!
    Allround Fixer
    1.647 Berichten
    Ingeschreven
    09/02/06

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 24334504
    Ondernemingsnummer: nvt

    ik weet niet of je nog iemand/hulp zoekt, maar je kan me even pmmen, kan ik er wel even naar kijken als je wilt

Pagina 1 van de 2 1 2 LaatsteLaatste

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics