Betreft een nieuwe installatie op een testmachine, Centos 5 en httpd met yum geinstalleerd.
Ik ben er al urenlang naar aan het zoeken met google maar krijg geen oplossing gevonden.
Dit krijg ik als foutmelding in de errorlog bij het bezoeken van een domein:
[client 82.168.xx.xx] Directory index forbidden by Options directive: /var/www/html/
Ik krijg dan op beide virtuele sites wel gewoon netjes de welkom pagina te zien van apache.
Oplossing volgens google: Maak in de /var/www/html een lege index.html aan en het probleem is opgelost.
Nou niet dus. Gevolg hiervan is dat er bij het bezoeken van de site gewoon een lege pagina zichtbaar wordt.
Dit staat dan in de error log:
[error] [client ::1] Directory index forbidden by Options directive: /var/www/html/
Nu heb ik de userdir in apache uitgeschakeld en dan krijg je het volgende weer. Geen errorlog meldingen meer, maar wel dit in de access log:
Dus bij de ene site 304's en bij de tweede virtual host die internal dummy connection.Code:82.168.xxx.xxx - - [19/Sep/2008:03:17:06 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 1.1.4322)" 82.168.xxx.xxx - - [19/Sep/2008:03:17:08 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 1.1.4322)" 82.168.xxx.xxx - - [19/Sep/2008:03:17:08 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 1.1.4322)" 82.168.xxx.xxx - - [19/Sep/2008:03:17:09 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 1.1.4322)" ::1 - - [19/Sep/2008:03:17:25 +0200] "GET / HTTP/1.0" 200 - "-" "Apache/2.2.3 (CentOS) (internal dummy connection)"
Ook daar is hopen over te vinden, maar de geboden oplossing (Options +indexes) helpt ook niet.
Op m'n andere bak had ik nog apache 2.0 staan en daar had ik geen problemen, zelfde wijze geconfigureerd.
Hier wat gegevens uit de httpd.conf:
en dan nog de virtual hosts:Code:DocumentRoot "/var/www/html" <Directory /> Options FollowSymLinks AllowOverride Options </Directory> <Directory "/var/www/html"> Options Indexes FollowSymLinks AllowOverride AuthConfig Order allow,deny Allow from all </Directory> <Directory /home/*/public_html> AllowOverride FileInfo AuthConfig Limit Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec <Limit GET POST OPTIONS> Order allow,deny Allow from all </Limit> <LimitExcept GET POST OPTIONS> Order deny,allow Deny from all </LimitExcept> </Directory>
Ik zie door de bomen het bos niet meer, met apache 1.3 liep dit zo perfekt. Als er meer informatie nodig is hoor ik het graag.Code:NameVirtualHost 10.0.0.2:80 <VirtualHost 10.0.0.2:80> DocumentRoot /home/jantje/public_html ServerName jantje.dhs.org ServerAdmin info@jantje.dhs.org ErrorLog /var/log/httpd/jantje.log </VirtualHost> <VirtualHost 10.0.0.2:80> DocumentRoot /home/pietje/public_html ServerName pietje.dyndns.org ServerAdmin info@pietje.dyndns.org ErrorLog /var/log/httpd/pietje.log </VirtualHost>

Likes:


Quote