Likes Likes:  0
Resultaten 1 tot 6 van de 6
Geen
  1. #1
    virtualhosts dns probleem
    geregistreerd gebruiker
    15 Berichten
    Ingeschreven
    16/08/07

    Locatie
    delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    virtualhosts dns probleem

    goedendag
    ik ben nu toch zover om het toch hier maar te vragen.
    na een aantal malen proberen en veel lezen kom ik er toch niet helemaal uit.

    http://gathering.tweakers.net/forum/...9355#imagelist
    http://apptools.com/phptools/virtualhost.php
    http://textbook.textpattern.net/wiki...n)_for_Windows

    dit zijn een paar links waar ik mijn info gelezen heb.

    ik heb thuis een server waar ik twee websites op wil hebben.
    nu is het eerste probleem al dat ik niet altijd hetzelfde ip heb,
    dat heb ik opgelost door bij dyndns twee namen te registreren, die dus met een updater constant het juiste ip houden.

    is het nu mogenlijk met virtualhost om met die twee namen wat te doen?
    dit wil ik eigenlijk eerst weten voordat ik moeilijke dingen ga doen.

    of is er een andere mogenlijkheid om met server2003 iets te doen.

    ik gebruik xampp (ja sorry maar is wel makkelijk)

  2. #2
    virtualhosts dns probleem
    Allround Fixer
    1.647 Berichten
    Ingeschreven
    09/02/06

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 24334504
    Ondernemingsnummer: nvt

    geen probleem. Je dns wijst naar het goede ip, de virtual hosts scheidt de namen weer...

  3. #3
    virtualhosts dns probleem
    geregistreerd gebruiker
    15 Berichten
    Ingeschreven
    16/08/07

    Locatie
    delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    ok dus dat moet geen probleem zijn. das mooi

    alleen dan werkt het dus nog niet helemaal.

    ik heb de websites op c:\www\site1
    c:\www\site2

    NameVirtualHost 127.0.0.1:80

    <VirtualHost *:80> (<Virtualhost 127.0.0.1:80> ook geprobeerd
    ## ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot c:/www/site1
    ServerName *****.kicks-ass.net
    ## ErrorLog @rel_logfiledir@/dummy-host.example.com-error_log
    ## CustomLog @rel_logfiledir@/dummy-host.example.com-access_log common
    </VirtualHost>


    <VirtualHost *:80>
    ## ServerAdmin webmaster@dummy-host.example.com
    DocumentRoot c:/www/site2
    ServerName *****.homeftp.net
    ## ErrorLog @rel_logfiledir@/dummy-host.example.com-error_log
    ## CustomLog @rel_logfiledir@/dummy-host.example.com-access_log common
    </VirtualHost>

    in de httpd.conf staat deze regel # Virtual hosts
    Include conf/extra/httpd-vhosts.conf

    dus die wordt verwezen nar de .conf die ik hierboven heb gepost.

    nu staat document root ook nog in de httpd.conf
    DocumentRoot "C:/www/"
    en nog 1
    <Directory "C:/www/">

    ik heb het idee dat ie gewoon naar deze blijft kijken.
    als ik er een # voorzet is niks meer te bereiken.

    ook heb ik geprobeerd om de hostfile van windows aan te passen
    zodat die 2 namen localhost zijn

  4. #4
    virtualhosts dns probleem
    geregistreerd gebruiker
    15 Berichten
    Ingeschreven
    16/08/07

    Locatie
    delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    klein stapje verder.

    <VirtualHost *:80>
    ServerName XXXXX.kicks-ass.net
    ServerAdmin webmaster@localhost
    DocumentRoot "C:\www\site1"
    </VirtualHost>

    <VirtualHost *:80>
    ServerName xxxx.homeftp.net
    ServerAdmin webmaster@localhost
    DocumentRoot "C:\www\site2"
    </VirtualHost>

    dit gaat volgens mij nu wel goed. want ik krijg nu een error 403
    U hebt niet de toestemming om toegang te krijgen tot de gevraagde map. Er is of wel geen index document of de map is beveiligd tegen lezen

    als ik dit stukje invul en dan allow geeft de server url niet gevonden??
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all <-----Allow from all
    </Directory>

    ik heb dit bovenstaand ook toegepast tussen <virtualhost> </virtualhost>

    ik heb geen idee meer waar ik moet zoeken

  5. #5
    virtualhosts dns probleem
    geregistreerd gebruiker
    15 Berichten
    Ingeschreven
    16/08/07

    Locatie
    delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nvt
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter


    het werkt!!

    ben de hele dag aan het klooien geweest tot ik op het idee kwam ipv de *
    het ip nummer te proberen van die pc 192.168.1.xxx

    en nog even allow all toevoegen

  6. #6
    virtualhosts dns probleem
    geregistreerd gebruiker
    1 Berichten
    Ingeschreven
    07/08/09

    Locatie
    Drachten

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Hallo Ron,
    Ik stuit op hetzelfde probleem, wat jij nu opgelost schijnt te hebben.
    Heb een notebook met besturingssysteem PcLinuxOs2009 (KDE 3.5) en Xampp 1.7.1
    Ik host 6 domeinen op dit webservertje.
    Ik heb het gedaan omdat ik in verschillende bands speel. De muziek van de repetitieavonden wil ik graag online aanbieden. Gezien de omvang en het aantal van deze mp3's is het erg duur om een hostingpakket met zo'n 4 giB schijfruimte te huren. Dat kan beter thuis.
    Vandaar dat ik het zelf wil doen en ook al deed.
    Tot vorige week ging het heel goed. Ik had beperkte webruimte bij de ISP Yourhosting.nl.
    Ik had daar mappen aangemaakt met de naam van het domein met daarin een redirect script, die verwees naar mijn webserver.
    Ik heb mijn pakket bij Yourhosting echter laten downgraden. Ik heb nu geen webruimte meer en moet met DNS bij YourHosting in de weer om de websites op mijn webserver te kunnen bereiken.
    Ik heb de httpd-vhosts.conf aangepast, de hosts en httpd-xampp.conf. Ook heb ik port forwarding op mijn router ingesteld. De webserver (de laptop dus met PcLinuxOs2009) heeft een statisch IP adres (192.168.1.48)
    Mijn externe IP is 85.145.00.00. Dit adres heet dynamisch te zijn volgens mijn inbelprovider Orange/Online/Euronet, maar het is sinds 2005 niet meer gewijzigd.
    Bij Yourhosting kan ik alleen nog iets doen met het DNS beheer. Ik heb er daar voor gezorgd dat de door mij geregistreerde domeinen verwijzen in het A-record naar 85.145.00.00 (mijn (fake) externe ip-adres)
    Wanneer ik van "buiten" mijn eigen lokale netwerk een van mijn websites probeer te bereiken, krijg ik de inlogpagina van Xampp, alwaar gevraagd wordt mijn gebruikersnaam en wachtwoord in te vullen.
    Dat is niet de bedoeling natuurlijk.
    Dit is de inhoud van mijn httpd-vhosts.conf:
    #NameVirtualHost *:80 //werkt niet
    NameVirtualHost 192.168.1.48 //werkt niet
    #NameVirtualHost 85.145.00.00 //werk niet
    Listen 80 //werkt niet
    #
    # VirtualHost example:
    # Almost any Apache directive may go into a VirtualHost container.
    # The first VirtualHost section is used for all requests that do not
    # match a ServerName or ServerAlias in any <VirtualHost> block.
    #
    #<VirtualHost *:80>
    # ServerAdmin webmaster@dummy-host.example.com
    # DocumentRoot /opt/lampp/htdocs/dummy
    # ServerName dummy-host.example.com
    # ServerAlias www.dummy-host.example.com
    # ErrorLog logs/dummy-host.example.com-error_log
    # CustomLog logs/dummy-host.example.com-access_log common
    #</VirtualHost>

    <VirtualHost *:80>
    ServerAdmin splendorjazz@gmail.com
    DocumentRoot /opt/lampp/htdocs/splendorjazz
    ServerAlias www.splendorjazz.net
    ServerName www.splendorjazz.net
    ErrorLog logs/splendor_error_log
    CustomLog logs/splendor-access_log common
    </VirtualHost>
    (Alle andere domeinen zijn overigens volgens het zelfde format gebouwd).

    De inhoud van httpd-xampp.conf
    #
    # New XAMPP security concept
    #
    <LocationMatch ^/(?i?:xampp|security|licenses|phpmyadmin|webalizer|ser ver-status|server-info))">
    # Order deny,allow
    Order allow,deny
    Allow from all
    # Allow from ::1 127.0.0.0/8 \
    # fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \
    # fe80::/10 169.254.0.0/16

    # ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
    </LocationMatch>

    (Heb het bestand in de bovenstaande regels aangepast, om geen beperkingen aan de bereikbaarheid op te leggen. Het uitgecommentarieerde is origineel)

    De inhoud van /etc/hosts
    127.0.0.1 mano localhost
    127.0.0.1 splendorjazz
    127.0.0.1 volgendedomein
    127.0.0.1 enzovoort

    "mano" is de hostname van mijn laptop.

    De portsetting op mijn router (Livebox Orange):
    Diensten ID-actie Type actie Van Naar Van Naar
    MODULEID 1 Redir Port 192.168.1.48 192.168.1.48 80 80 Geactiveerd

    Het DNS record bij Yourhosting:
    A *.splendorjazz.net -> 85.145.00.00 Edit Delete
    A splendorjazz.net -> 85.145.00.00 Edit Delete
    A localhost.splendorjazz.net -> 127.0.0.1

    Zie jij hier ergens problemen of een oorzaak waarom ik steeds de inlogpagina van Xampp krijg?

    Bedankt voor alle moeite en onderzoek!
    Kees Epema

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics