Likes Likes:  0
Resultaten 1 tot 1 van de 1
Geen
  1. #1
    Probleem met Cpan mail::smtp BerkeleyDB
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter

    Probleem met Cpan mail::smtp BerkeleyDB

    Deze wil bij mij niet meer installeren en daardoor wenst Amavisd ook niet meer te draaien.

    Ik heb al geprobeerd met clean BerkeleyDb en opnieuw installeren (met Cpan dus) maar het wil niet, hopen foutmeldingen van dit soort:
    BerkeleyDB.xs:2848: error: request for member `h_ffactor' in something not a structure or union
    en soortgelijke meldingen ook van BerkeleyDB.xs en nog wat anderen.
    En op het einde dit:
    Make had returned bad status, install seems impossible
    Failed during this command:
    PMQS/BerkeleyDB-0.34.tar.gz : make NO
    Iemand enig idee hoe dit te fixen?

    Aanvulling
    Dit is de exacte foutmelding bij het starten van amavisd:
    Code:
    Starting Mail Virus Scanner (amavisd): Problem in Amavis::DB or Amavis::DB::SNMP code: Can't locate BerkeleyDB.pm in @INC (@INC contains: /usr/local/lib/perl5/5.8.8/i686-linux /usr/local/lib/perl5/5.8.8 /usr/local/lib/perl5/site_perl/5.8.8/i686-linux /usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl) at (eval 79) line 15.
    BEGIN failed--compilation aborted at (eval 79) line 15.
    Ik had perl 5.8.5. via yum geinstalleerd staan. Daarna heb ik via source de 5.8.8 geinstalleerd. Ziet er verder allemaal goed uit.
    Onder /usr/local/lib/perl5/site_perl staat alleen de 5.8.8 directory, lijkt me ook goed.
    Via yum is nog altijd de gewone BerkeleyDB ook geinstalleerd, maar dat was eerst ook.

    Met veel gesukkel is het opgelost.
    Spamassin opnieuw erop, Spamassassin delen in cpan geinstalleerd en de Mail Spamassassin van de build lib directory naar de perl directory gecopieerd, handmatig, nu werkt het.

    Ik blijf het maar gesukkel vinden met Amavisd en Spamassassin, de helft via yum geinstaleerd en de andere helft via cpan zoals de doc aangeeft.
    Zo gauw yum een perl update heeft gooit ie de boel in de war.
    Laatst gewijzigd door Blacky; 27/06/08 om 15:07. Reden: Automerged Dubbelpost

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics