Likes Likes:  0
Resultaten 1 tot 3 van de 3
Geen
  1. #1
    Pop-before-smtp en client relay denied
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter

    Pop-before-smtp en client relay denied

    Ik zit een beetje met de handen in het haar. Heb dit ooit werkend gehad maar na nieuwe installatie lukt het niet meer.

    Software:
    Linux Centos, met Postfix 2.2.10 (als ik het goed heb), VM-pop3d-1.1.7f-T7 als pop3server en pop-before-smtp-1.41 voor de clients.
    Grotendeels gevolgde handleiding:
    http://www.howtoforge.com/linux_postfix_virtual_hosting alleen is hier dan geen Dovecot gebruikt. Maarja mail inkomend sturen en gewoon ophalen werkt allemaal perfekt, alleen relayen niet.

    Een paar maildomeinen. Van domein1 zijn er een aantal clients. Post ophalen geen probleem, post versturen naar een van de maildomeinen op de server ook geen probleem, maar op het moment dat ze nu post willen versturen naar een extern domein krijgen ze een relaying denied melding.
    Dit zegt hij:
    NOQUEUE: reject: RCPT from hostnaam.xs4all.nl[80.126.xx.xx]: 554 relaying denied.
    Een paar stukjes uit de main.cf:

    virtual_mailbox_domains = domein1 domein2 domein3
    (is dat goed met spaties of moeten hier komma's tussen?)

    smtpd_helo_restrictions = permit_mynetworks,
    check_helo_access hash:/etc/postfix/helo_access,
    reject_invalid_hostname,
    permit

    smtpd_client_restrictions = check_client_access hash:/etc/postfix/access,
    permit

    smtpd_recipient_restrictions = permit_mynetworks,
    check_client_access hash:/etc/postfix/pop-before-smtp,
    reject_unauth_destination,
    reject_invalid_hostname,
    reject_unauth_pipelining,
    reject_non_fqdn_sender,
    reject_unknown_sender_domain,
    reject_non_fqdn_recipient,
    reject_unknown_recipient_domain,
    check_client_access hash:/etc/postfix/access
    check_helo_access hash:/etc/postfix/helo_access
    reject_rbl_client bl.spamcop.net,
    reject_rbl_client cbl.abuseat.org,
    reject_rbl_client sbl-xbl.spamhaus.org,
    permit

    mtpd_data_restrictions = reject_multi_recipient_bounce,
    reject_unauth_pipelining,
    permit

    In de /etc/postfix directory is een pop-before-smtp.db aanwezig. Als ik die wis en PbSMTP herstart, word deze weer netjes aangemaakt. Staan echter alleen rare tekens in.

    Ik herinner me dat toen het nog werkte, dit een bestand was (misschien zonder extensie .db) wat gewoon te openen was en dan zag je ip adressen van de mensen die het laatst mail opgehaald hadden. Maar misschien was dat een antieke verise?

    Bovenstaand lijkt me niet fout. Waar moet ik nu nog kijken?
    Of zou het kunnen zijn dat Postfix dat .db bestand toch niet uitlezen kan?
    In de config van PbSMTP staat dit gewoon standaard, dus geen BerkeleyDB enabled ofzo. Hij maakt dan standaard gebruik van DB_file aldus de doc.

    Iemand een oplossing voor mijn probleem?

    P.s. 1 ding heb ik ontdekt, het ziet er naar uit dat er geen ip adres in de database komt:
    pop-before-smtp --list
    The database holds 0 IPs.

    Misschien helpt dat bij de ideeën.
    Laatst gewijzigd door Blacky; 29/09/07 om 06:03. Reden: P.s. toegevoegd

  2. #2
    Pop-before-smtp en client relay denied
    DutchVirtual
    364 Berichten
    Ingeschreven
    20/07/05

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    2 Berichten zijn liked


    Registrar SIDN: -
    KvK nummer: 11065157
    Ondernemingsnummer: nvt

    Hmm, je pop-before-smtp daemon draait toch wel?

    En zoja, misschien heb je 'm verkeerd geconfigt. Hij moet namelijk wel naar de goede logfile kijken. Draai de pop-before-smtp daemon eens in debugging mode met de --debug flag, dan vanaf een andere IP effe poppen.

  3. #3
    Pop-before-smtp en client relay denied
    geregistreerd gebruiker
    1.626 Berichten
    Ingeschreven
    18/06/04

    Locatie
    Maastricht

    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    26 Berichten zijn liked


    KvK nummer: 14101842

    Thread Starter
    Het probleem is weer opgelost, maar toch bedankt voor de reply.

    Ik snap er zelf ook niets van alles draaide, ook de PbSMTP daemen.
    Daar heb ik geprobeerd met de $pat instelling voor de oudere versies vm-pop3d in de config van PbSMTP en dat werkte ook niet.

    Daarna heb ik hem weer terug gezet op de $pat voor nieuwere versies en toen werkte het opeens wel, heel vreemd.

    Even in de gaten houden dan, maar toch bedankt voor je reply!
    Als hij weer eens kuren heeft kan ik die debug optie immers eens proberen.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics