Likes Likes:  0
Resultaten 1 tot 15 van de 20
Pagina 1 van de 2 1 2 LaatsteLaatste
Geen

Onderwerp: /var/lib/mysql\r

  1. #1
    /var/lib/mysql\r
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    Question /var/lib/mysql\r

    [root@okill dev]# /sbin/service mysqld restart
    Stoppen van MySQL: [ OK ]
    Initialiseren van de MySQL database: [ OK ]
    chown: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    chown: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    chmod: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill dev]# /sbin/service mysqld start
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill dev]# /sbin/service mysqld start
    Initialiseren van de MySQL database: [ OK ]
    chown: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    chown: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    chmod: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    Starten van MySQL: [ OK ]
    [root@okill dev]#

    Na lang proberen is het me toch gelukt,
    maar wat blijft hij hebben met dat onbestaande bestand genaamd r?

    Waar kan ik het repareren?

    originele my.cnf:
    [mysqld]
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1

    [mysql.server]
    user=mysql
    basedir=/var/lib

    [mysqld_safe]
    err-log=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid


    Ik heb daar nu vanonder het volgende bij gevoegd:
    [mysqld]
    skip-locking
    skip-innodb
    query_cache_limit=1M
    query_cache_size=32M
    query_cache_type=1
    max_connections=500
    interactive_timeout=100
    wait_timeout=30
    connect_timeout=10
    thread_cache_size=128
    key_buffer=16M
    join_buffer=1M
    max_allowed_packet=16M
    table_cache=1024
    record_buffer=1M
    sort_buffer_size=2M
    read_buffer_size=2M
    max_connect_errors=10
    # Try number of CPU's*2 for thread_concurrency
    thread_concurrency=2
    myisam_sort_buffer_size=64M
    log-bin
    server-id=1

    [safe_mysqld]
    open_files_limit=8192

    [mysqldump]
    quick
    max_allowed_packet=16M

    [mysql]
    no-auto-rehash
    #safe-updates

    [isamchk]
    key_buffer=64M
    sort_buffer=64M
    read_buffer=16M
    write_buffer=16M

    [myisamchk]
    key_buffer=64M
    sort_buffer=64M
    read_buffer=16M
    write_buffer=16M

    [mysqlhotcopy]
    interactive-timeout


    Als ik ze allemaal ineens invoegde wilde hij de server niet meer starten, als ik elke [categorie] apart invoeg en steeds opnieuw mysqld start dan werkt hij wel...

    Momenteel werkt hij zonder problemen buiten bij het herstarten steeds de volgende error:

    Initialiseren van de MySQL database: [ OK ]
    chown: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    chown: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    chmod: cannot access `/var/lib/mysql\r': Onbekend bestand of map
    Starten van MySQL: [ OK ]

    Hoe op te lossen?
    Bedankt (en sorry voor het verkeerd posten eerder)

  2. #2
    /var/lib/mysql\r
    uh?
    715 Berichten
    Ingeschreven
    26/04/05

    Locatie
    Den Haag

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 27295404
    Ondernemingsnummer: nvt

    Wat staat er in \r ? moven naar een andere plaats en dan opnieuw proberen?

  3. #3
    /var/lib/mysql\r
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    [root@okill /]# mv /var/lib/mysql/r /var/www/
    mv: cannot stat `/var/lib/mysql/r': Onbekend bestand of map
    [root@okill /]# rm /var/lib/mysql/r/
    rm: cannot lstat `/var/lib/mysql/r/': Onbekend bestand of map
    [root@okill /]# rm /var/lib/mysql/r
    rm: cannot lstat `/var/lib/mysql/r': Onbekend bestand of map
    [root@okill /]#

    Bestaat niet?

  4. #4
    /var/lib/mysql\r
    geregistreerd gebruiker
    961 Berichten
    Ingeschreven
    02/05/04

    Locatie
    Montreal, Canada

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: nvt
    Ondernemingsnummer: 873411853

    uw my.cnf is DOS formatted, gewoon eens openen onder linux en de line breaks weghalen.

  5. #5
    /var/lib/mysql\r
    VoipQ
    1.298 Berichten
    Ingeschreven
    26/07/05

    Locatie
    Delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Ryan Kalkhoven
    Bedrijf: VoipQ
    Registrar SIDN: Nee
    KvK nummer: 27183560
    Ondernemingsnummer: nvt

    ipv handmatig kun je ook het dos2unix commando gebruiken;

    dos2unix my.conf

  6. #6
    /var/lib/mysql\r
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    alle regels verwijderd met vi en nano
    maar ik krijg nu heel mysql niet meer gestart, alle sites down :|

    [root@okill /]# service mysqld restart
    Stoppen van MySQL: [MISLUKT]
    Starten van MySQL: [ OK ]
    [root@okill /]# service mysqld restart
    Stoppen van MySQL: [MISLUKT]
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill /]# service mysqld stop
    Stoppen van MySQL: [MISLUKT]
    [root@okill /]# service mysqld start
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill /]# service mysqld start
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill /]# vi /etc/my.cnf
    [root@okill /]# service mysqld start
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill /]# /sbin/service mysqld restart
    Stoppen van MySQL: [MISLUKT]
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill /]#


    Hoe kan ik dit nu repareren?

    [root@okill etc]# dos2unix my.conf
    dos2unix: converting file my.conf to UNIX format ...
    dos2unix: problems converting file my.conf
    [root@okill etc]#

  7. #7
    /var/lib/mysql\r
    geregistreerd gebruiker
    961 Berichten
    Ingeschreven
    02/05/04

    Locatie
    Montreal, Canada

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: nvt
    Ondernemingsnummer: 873411853

    Gewoon nieuwe my.cnf maken, gewoon cut en paste van je my.cnf die hier staat .

  8. #8
    /var/lib/mysql\r
    VoipQ
    1.298 Berichten
    Ingeschreven
    26/07/05

    Locatie
    Delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Ryan Kalkhoven
    Bedrijf: VoipQ
    Registrar SIDN: Nee
    KvK nummer: 27183560
    Ondernemingsnummer: nvt

    Origineel geplaatst door klasje.be
    alle regels verwijderd met vi en nano
    eehhhh met een lege conf zal die dat idd niet leuk vinden.....

    \r en \n zijn windows tekens. Bijvoorbeeld de \n geeft een enter aan op die plek. Linux vind dit niet altijd geslaagt. Daarom was het de bedoeling om al die tekens te verwijderen, maar niet je hele config te legen!

    het commando dos2unix doet dit automatisch zonder schade voor als je zelf niet door je bestanden wil.

  9. #9
    /var/lib/mysql\r
    VoipQ
    1.298 Berichten
    Ingeschreven
    26/07/05

    Locatie
    Delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Ryan Kalkhoven
    Bedrijf: VoipQ
    Registrar SIDN: Nee
    KvK nummer: 27183560
    Ondernemingsnummer: nvt

    Origineel geplaatst door smurf
    Gewoon nieuwe my.cnf maken, gewoon cut en paste van je my.cnf die hier staat .
    Waar dit forum al niet goed voor is ;-)

  10. #10
    /var/lib/mysql\r
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Ik heb my.cnf verwijderd en een nieuwe gemaakt met nano, daarna het volgende uitgevoerd:
    [root@okill etc]# dos2unix my.cnf
    dos2unix: converting file my.cnf to UNIX format ...
    [root@okill etc]# /sbin/service mysqld start
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill etc]#

    Werkt dus nog niet :s

    Ps: natuurlijk had ik niet alles eruit verwijderd :-p enkel de nieuwe lijnen
    Verder staat er nergens /n ofzo in in nano noch vi
    Laatst gewijzigd door klasje.be; 02/02/06 om 17:43.

  11. #11
    /var/lib/mysql\r
    VoipQ
    1.298 Berichten
    Ingeschreven
    26/07/05

    Locatie
    Delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Ryan Kalkhoven
    Bedrijf: VoipQ
    Registrar SIDN: Nee
    KvK nummer: 27183560
    Ondernemingsnummer: nvt

    eeehhh... hoe leg ik dit uit.

    het probleem waar je mee poste viel op te lossen met een dos2unix.

    Daar heb je met je huidige probleem compleet niets meer aan.

    Nu moet je een nieuwe my.cnf maken en daar weer de inhoud in plaatsen die hier je hier op het forum hebt geplaats en daarna nog eens een restart van mysql proberen.

  12. #12
    /var/lib/mysql\r
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Werkt ook niet, niets werkt :|

    [root@okill etc]# /etc/rc.d/init.d/mysqld restart
    Stoppen van MySQL: [MISLUKT]
    Timeout error occurred trying to start MySQL Daemon.
    Starten van MySQL: [MISLUKT]
    [root@okill etc]#

    Zonder mysql kan de server door het raam!
    aub HELP!

  13. #13
    /var/lib/mysql\r
    blabla
    191 Berichten
    Ingeschreven
    30/08/04

    Locatie
    Nederland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    staat er niet in de log wat er mis is?

  14. #14
    /var/lib/mysql\r
    Webhosting reseller
    255 Berichten
    Ingeschreven
    23/01/05

    Locatie
    Aarschot

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    mysqld started
    060202 17:57:45 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
    060202 17:57:45 [ERROR] Do you already have another mysqld server running on port: 3306 ?
    060202 17:57:45 [ERROR] Aborting

    060202 17:57:45 [Note] /usr/libexec/mysqld: Shutdown complete

    060202 17:57:45 mysqld ended

    060202 17:58:09 mysqld started
    060202 17:58:09 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
    060202 17:58:09 [ERROR] Do you already have another mysqld server running on port: 3306 ?
    060202 17:58:09 [ERROR] Aborting

    060202 17:58:09 [Note] /usr/libexec/mysqld: Shutdown complete

    060202 17:58:09 mysqld ended


    Ik heb dit gedaan:
    http://www.ccc4.nl/instaleer-server.htm
    ondertitel: Syctl.conf Hardening

    edit:
    sysctl.conf hersteld naar originele staat, maar werkt nog steeds niet!
    Laatst gewijzigd door klasje.be; 02/02/06 om 18:18.

  15. #15
    /var/lib/mysql\r
    VoipQ
    1.298 Berichten
    Ingeschreven
    26/07/05

    Locatie
    Delft

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Naam: Ryan Kalkhoven
    Bedrijf: VoipQ
    Registrar SIDN: Nee
    KvK nummer: 27183560
    Ondernemingsnummer: nvt

    Wink

    [offtopic]
    Btw zet hier eerst ff je server-specs.... daaraan kan ik bepalen of ik jou kan helpen of dat ik die server kom opvangen onder je raam
    [/offtopic]

Pagina 1 van de 2 1 2 LaatsteLaatste

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics