Likes Likes:  0
Resultaten 1 tot 14 van de 14
Geen
  1. #1
    FTP fouten en de firewall
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    FTP fouten en de firewall

    Dag,

    Regelmatig heb ik fouten met het uploaden naar mijn server. Ik krijg dan de foutmelding:
    Code:
    ! Receive error: Blocking call cancelled
    .

    Als server gebruik Ocean FTP Server (draait onder Win2003). Om te uploaden gebruik ik WS_FTP LE maar ook met andere programma's heb ik er last van. Dacht eerst dat het aan de PASV mode lag maar dat maakt geen enkel verschil. Mailtje dus gestuurd naar de ontwikkelaar van Ocean FTP Server, krijg ik dit terug:

    These are all data connection problems.



    FTP uses a normal command channel (21 or 990 for implicit SSL) then a separate port in the default range of 1024-5000 for data channels; the data channels not being established due to firewall / router setup problems is the most common FTP problem we see.

    You need to allow ports 21, 990 (SSL) and 1024 - 5000 through your server firewall and forwarded from your router to your server and also enter the router IP in the FTP server general settings. Finally, if your FTP client is behind a firewall you need to use PASV mode on your client as you already are doing.
    Port 21 staat inderdaad open, SSL gebruik ik niet, maar moet ik nu echt port 1024-5000 openzetten??? Als dat zo is, dan ben ik zuur, want in Windows Firewall kan je maar 1 port per keer opgeven of ik kijk ergens overheen.

    Kan iemand mij uit de brand helpen?

  2. #2
    FTP fouten en de firewall
    geregistreerd gebruiker
    1.181 Berichten
    Ingeschreven
    15/12/03

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    die extra porten zijn naar mijn idee voor passive mode.

    zie:
    http://support.ipswitch.com/kb/WS-19980612-BK21.htm

  3. #3
    FTP fouten en de firewall
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Weird, net weer geprobeerd, nu heb ik nergens last van bij het uploaden van files. Als ik echter nu een dir aanmaak (MKDIR), krijg ik deze error:

    Code:
    ! Receive error: connection reset
    Dit is zowel met PASV aan en uit.

  4. #4
    FTP fouten en de firewall
    geregistreerd gebruiker
    121 Berichten
    Ingeschreven
    17/10/04

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Staan verder alle rechten goed?

  5. #5
    FTP fouten en de firewall
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Origineel geplaatst door SystemZ
    Staan verder alle rechten goed?
    Jep!
    Ocean FTP Server is een service die je kan zien in Services.msc. De Ocean Service stopt echter na het maken van zo'n dir.

    Ik post wel heel even de hele mailconversatie:
    Dear Sir/Madam,

    I'm using Ocean FTP for a couple of months. Today I've some problems with the FTP server.

    Problem 1:
    When I upload one single file I get this error at the end (it's bold):
    ======
    - -
    connecting to x:21
    Connected to x port 21
    220-Welkom op x!
    220-PROBLEMEN MET INLOGGEN?
    220 MAIL NAAR x
    USER administrator
    331 Please send PASS now.
    PASS (hidden)
    230-Welcome "administrator".
    230-There are currently 1 of 100 users logged onto this server.
    230-There are currently 1 users logged onto this account.
    230-You have unlimited KB of account allocation left.
    230-You have used 0 KB of your unlimited KB daily limit.
    230-You have used 0 KB of your unlimited KB daily limit.
    230-You have 0 transfer credits remaining.
    230-You lose 0 credits per KB uploaded.
    230-You lose 0 credits per KB downloaded.
    230 You are currently in directory "/".
    PWD
    257 "/" is current directory.
    SYST
    215 UNIX Type: L8
    Host type (S): UNIX (standard)
    TYPE A
    200 Type set to 'A' (ASCII).
    PORT 192,168,123,120,7,7
    200 PORT command successful.
    LIST
    150 Data connection established, beginning transfer.
    Received 285 bytes in 0.1 secs, (20.00 Kbps), transfer succeeded
    226 Transfer complete.
    CWD /D/www
    250 "/D/www" is current directory.
    PWD
    257 "/D/www" is current directory.
    PORT 192,168,123,120,7,8
    200 PORT command successful.
    LIST
    150 Data connection established, beginning transfer.
    Received 948 bytes in 0.1 secs, (90.00 Kbps), transfer succeeded
    226 Transfer complete.
    CWD /D/www/windowsmedia
    250 "/D/www/windowsmedia" is current directory.
    PWD
    257 "/D/www/windowsmedia" is current directory.
    PORT 192,168,123,120,7,9
    200 PORT command successful.
    LIST
    150 Data connection established, beginning transfer.
    Received 895 bytes in 0.1 secs, (80.00 Kbps), transfer succeeded
    226 Transfer complete.
    sending 09 Only One.mp3 as 09 Only One.mp3 (1 of 1)
    TYPE I
    200 Type set to 'I' (IMAGE).
    PORT 192,168,123,120,7,10
    200 PORT command successful.
    STOR 09 Only One.mp3
    150 Data connection established, beginning transfer.
    Transmitted 4553800 bytes in 184.0 secs, (242.58 Kbps), transfer succeeded
    ! Receive error: Blocking call cancelled
    =======
    After that message, de connection is lost and the Ocean FTP service is stopped as I can see in the Services console.

    Problem 2:
    When I try to create a new dir I get this error at the end:
    =====
    220 MAIL NAAR x
    USER administrator
    331 Please send PASS now.
    PASS (hidden)
    230-Welcome "administrator".
    230-There are currently 1 of 100 users logged onto this server.
    230-There are currently 1 users logged onto this account.
    230-You have unlimited KB of account allocation left.
    230-You have used 0 KB of your unlimited KB daily limit.
    230-You have used 0 KB of your unlimited KB daily limit.
    230-You have 0 transfer credits remaining.
    230-You lose 0 credits per KB uploaded.
    230-You lose 0 credits per KB downloaded.
    230 You are currently in directory "/".
    PWD
    257 "/" is current directory.
    SYST
    215 UNIX Type: L8
    Host type (S): UNIX (standard)
    TYPE A
    200 Type set to 'A' (ASCII).
    PORT 192,168,123,120,7,12
    200 PORT command successful.
    LIST
    150 Data connection established, beginning transfer.
    Received 285 bytes in 0.1 secs, (20.00 Kbps), transfer succeeded
    226 Transfer complete.
    CWD D
    250 "/D" is current directory.
    PWD
    257 "/D" is current directory.
    PORT 192,168,123,120,7,13
    200 PORT command successful.
    LIST
    150 Data connection established, beginning transfer.
    Received 1164 bytes in 0.1 secs, (110.00 Kbps), transfer succeeded
    226 Transfer complete.
    CWD www
    250 "/D/www" is current directory.
    PWD
    257 "/D/www" is current directory.
    PORT 192,168,123,120,7,14
    200 PORT command successful.
    LIST
    150 Data connection established, beginning transfer.
    Received 948 bytes in 0.1 secs, (90.00 Kbps), transfer succeeded
    226 Transfer complete.
    CWD windowsmedia
    250 "/D/www/windowsmedia" is current directory.
    PWD
    257 "/D/www/windowsmedia" is current directory.
    PORT 192,168,123,120,7,15
    200 PORT command successful.
    LIST
    150 Data connection established, beginning transfer.
    Received 980 bytes in 0.1 secs, (90.00 Kbps), transfer succeeded
    226 Transfer complete.
    MKD abc
    ! Receive error: connection reset
    ======
    After that message, de connection is AGAIN lost and the Ocean FTP service is stopped as I can see in the Services console.

    Problem 3:
    When I'll try to upload several files in just 1 'click' I get after the first uploaded file the same error als problem 3. Then connection lost and the service stopped.

    My configuration:
    Windows Server 2003 SP1 Standard Edition
    Ocean FTP Version 1.1.6.0
    Intel Pentium 4 2,4 Ghz
    1024 MB RAM

    Can you please help me with this problem?

    Thanks in advance.
    Misschien dat het probleem nu wat duidelijker is.

  6. #6
    FTP fouten en de firewall
    geregistreerd gebruiker
    121 Berichten
    Ingeschreven
    17/10/04

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Meschien dat je dit alreeds hebt gedaan maar post het maar even voor de zekerheid.


    Troubleshooting WS_FTP:
    Blocking Call Cancelled Error
    This error is peculiar to WS_FTP, and generally indicates a problem with a router (sometimes referred to as a "blackhole router") between your computer and and our network. There are 3 possible solutions:

    Use CuteFTP or some other FTP client instead of WS_FTP.

    In your WS_FTP configuration, change the setting for Passive Transfers (If you find that Passive Transfers is enabled, you should disable it and if it is disabled, you should enable it.) and/or

    Increase the Network Timeout setting in WS_FTP to 120 or higher.

    Vooral punt3 kan intressant zijn.

    Nog een


    I've been using WS FTP for a few years. I recently starting getting an error while trying to connect to certain sites. Others I connect to fine. The message I get upon trying to connect is "Receive error: Blocking call cancelled". I saw something about setting MTU to fix this. If this is the solution, and if so how do I do it? Thanks!


  7. #7
    FTP fouten en de firewall
    geregistreerd gebruiker
    1.181 Berichten
    Ingeschreven
    15/12/03

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    maar het is raar dat de gehele service er mee stopt ?

    wat zeggen de log files van de ocean ftp server?

  8. #8
    FTP fouten en de firewall
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Nou, dat is het denk ik niet, aangezien LeechFTP het ook heeft. Check:
    Code:
    < 226 Transfer complete.
    > mkdir hallo
    ! Socket Error: connection reset by peer 
    ~ Disconnected
    En vervolgens is mn FTP service weer gestopt! Het ligt dus echt aan de server!

  9. #9
    FTP fouten en de firewall
    geregistreerd gebruiker
    1.181 Berichten
    Ingeschreven
    15/12/03

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Daarom wil ik ook de log files van je server zien , niet van je ftp client.

  10. #10
    FTP fouten en de firewall
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Ik heb accountlogs, ftplogs en servicelogs (van Windows):

    ACCOUNT:
    Code:
    Wed, 11 Jan 2006 15:55:21 -> IP -> Directory Viewed: Directory=[/D]
    Wed, 11 Jan 2006 15:55:23 -> IP -> Directory Viewed: Directory=[/D/www]
    Wed, 11 Jan 2006 15:55:28 -> IP -> Directory Viewed: Directory=[/D/__temp]
    (Meer staat er niet, aangezien het ik inderdaad in de map /__temp een nieuwe map aan wilde maken).

    FTP-LOG:
    Code:
    Wed, 11 Jan 2006 15:55:21 -> IP -> administrator -> Directory Viewed: Directory=[/D]
    Wed, 11 Jan 2006 15:55:23 -> IP -> administrator -> Directory Viewed: Directory=[/D/www]
    Wed, 11 Jan 2006 15:55:28 -> IP -> administrator -> Directory Viewed: Directory=[/D/__temp]
    Hetzelfde dus!

    SERVICE LOG
    Code:
    The Ocean FTP Server service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 0 milliseconds: Restart the service.
    Die restart heb ik ingesteld.

    Als deze gerestart is krijg ik dit in de service log:
    Code:
    A service process other than the one launched by the Service Control Manager connected when starting the Ocean FTP Server service.  The Service Control Manager launched process 4464 and process 4856 connected instead.
    
      Note that if this service is configured to start under a debugger, this behavior is expected.
    Strange?

  11. #11
    FTP fouten en de firewall
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Origineel geplaatst door _arno_
    Daarom wil ik ook de log files van je server zien , niet van je ftp client.
    Dat was een reactie op SystemZ, m'n bovenbuurman in rack 25

  12. #12
    FTP fouten en de firewall
    geregistreerd gebruiker
    121 Berichten
    Ingeschreven
    17/10/04

    Locatie
    Eindhoven

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Origineel geplaatst door Glenn
    Dat was een reactie op SystemZ, m'n bovenbuurman in rack 25
    Idd

  13. #13
    FTP fouten en de firewall
    geregistreerd gebruiker
    1.181 Berichten
    Ingeschreven
    15/12/03

    Locatie
    Utrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Misschien config probleempje?

    Al reinstall gedaan van de ftp server?


    ben zelf geen guru dus het kan zijn dat ik ook wat blaat, probeer alleen beetje te helpen

  14. #14
    FTP fouten en de firewall
    Zaankanter
    2.217 Berichten
    Ingeschreven
    26/05/04

    Locatie
    Zaanstad

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter
    Origineel geplaatst door _arno_
    Misschien config probleempje?

    Al reinstall gedaan van de ftp server?


    ben zelf geen guru dus het kan zijn dat ik ook wat blaat, probeer alleen beetje te helpen
    Er valt weinig te configgen aan een ftp server wat betreft general settings

    Ik ga nog eens een reinstall doen.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics