Check je error.log eens?
Likes: 0
Check je error.log eens?

'!^www\\.issingle\\.be$', perhaps mis-spelled or defined by a module not included in the server configuration
[Mon Dec 12 23:46:21 2005] [alert] [client 81.82.81.173] /home/issingle/domains/issingle.be/public_html/.htaccess: Invalid command
Hij herkent dit dus niet...
Misschien omdat je het nog steeds fout hebt?
RewriteEngine On
RewriteCond %{SERVER_NAME} !^www\.issingle\.be$
RewriteCond %{SERVER_NAME} !^download\.issingle\.be$
RewriteCond %{SERVER_NAME} !^static\.issingle\.be$
RewriteCond %{SERVER_NAME} ^(.*)\.issingle\.be$
RewriteRule .* http://www.issingle.be/profile.php?user=%1
^^ dat moet het zijn

Beste ja3,
Heb zojuist bovenstaande oplossing geprobeerd (letterlijk via copy/paste), maar deze blijkt ook niet te werken (nog altijd internal server errors).
Viel mij op dat de server ipv een enkele backslash, plots dubbele gebruikt in de foutmelding (!^www\\.issingle\\.be$). Kan dit het probleem zijn?
//EDIT
Foutmelding in de logs
[Tue Dec 13 08:56:29 2005] [error] [client 81.83.92.146] mod_security: get_variable: unresolved variable type 9 (internal error) [hostname "qmldkfj.issingle.be"] [uri "/favicon.ico"]
[Tue Dec 13 08:56:29 2005] [error] [client 81.83.92.146] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.
[Tue Dec 13 08:56:29 2005] [error] [client 81.83.92.146] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.
Laatst gewijzigd door IT-worX; 13/12/05 om 09:07.
Denk dat we dit beter even prive kunnen afhandelen, gaat wat sneller.
Kan je het antwoord hier nog posten? Ik ga ook in de toekomst met zoiets bezig zijn, en dan kan ik het nu alvast een beetje oefenen![]()

direct admin is niet zo blij met .htaccess is mijn ervaring, echter is php een beter oplossing lijkt mij.
Tools die handig zjn voor ISPs vind je natuurlijk bij Tools 4 ISP.
Beetje raar maar:
RewriteEngine On
RewriteCond %{SERVER_NAME} !^www\.issingle\.be$
RewriteCond %{SERVER_NAME} !^download\.issingle\.be$
RewriteCond %{SERVER_NAME} !^static\.issingle\.be$
RewriteCond %{SERVER_NAME} ^(.*)\.issingle\.be$
RewriteRule .* http://www.issingle.be/profile.php?user=%1
Deze code werkte op mijn server wel maar niet bij IT Worx (beide met DA).
Daarvoor heb ik dit maar gemaakt (in index.php) en dat werkt zeker:
<?php
$hostname = $_SERVER['SERVER_NAME'];
$subname = str_replace(".issingle.be","",$hostname);
if($subname != "www" && $subname != "issingle.be") header("Location: http://www.issingle.be/profile.php?user=" . $subname);
?>

Op welke manier kan ik met die php code van jou ervoor zorgen dat static.issingle.be en download.issingle.be nog werken?
Hij gaat deze nu gaan "vertalen" als http://www.issingle.be/profile.php?user=static
Dit moet werken (hele php code):
<?php
$hostname = $_SERVER['SERVER_NAME'];
$subname = str_replace(".issingle.be","",$hostname);
if($subname == "static") {
header("Location: http://www.issingle.be/static/");
}
elseif($subname != "www" && $subname != "issingle.be") {
header("Location: http://www.issingle.be/profile.php?user=" . $subname);
}
?>

yup doet het
Tnx!!!