Likes Likes:  0
Resultaten 1 tot 5 van de 5
Geen
  1. #1
    Beginnen met PureFTPd, dat begint lekker...
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter

    Angry Beginnen met PureFTPd, dat begint lekker...

    Ik ben voor een test begonen met PureFPTd
    Momenteel word er nog gebruik gemaakt van ProFTPd maar deze heeft nog al wat gebrekenen ik heb gehoord het nog wel is gevaarlijke bugs heeft.

    Nu heb ik pure-ftp geinstalleerd, en raat is het werkt niet
    Hij draait wel maar ik krijg hem niet zo ver dat een gebruiker kan inlogt.

    Hij controlleerd volgens mij niet eens

    Heeft iemand hier ervaring met Pure-FTP kan die mij mischien uit legen wat ik fout doet.

    Ik start hem zo:

    [root@server log]# /data/purepftd/sbin/pure-config.pl /etc/pure-ftpd.conf --daemonize
    Running: /data/purepftd/sbin/pure-ftpd --daemonize -A -c50 -B -C8 -D -E -fftp -H -I15 -lpgsql:/etc/pureftpd-pgsql.conf -L2000:8 -m4 -s -U133:022 -u500 -i -k99 -Z

    En in het ftp log krijg ik dit:
    Code:
    [root@server log]# cat /var/log/ftp
    Sep 11 16:50:17 rollerscapes pure-ftpd: (?@?) [ERROR] Unable to start a standalone server: [Invalid argument]
    Sep 11 16:50:41 rollerscapes pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Sep 11 16:50:54 rollerscapes pure-ftpd: (?@127.0.0.1) [WARNING] Authentication failed for user [rollller]
    Sep 11 16:51:00 rollerscapes pure-ftpd: (?@127.0.0.1) [INFO] Logout.
    Sep 11 16:54:32 rollerscapes pure-ftpd: (?@?) [ERROR] Unable to start a standalone server: [Illegal seek]
    Sep 11 16:57:28 rollerscapes pure-ftpd: (?@rollerscapes.net) [INFO] New connection from rollerscapes.net
    Sep 11 16:57:38 rollerscapes pure-ftpd: (?@rollerscapes.net) [WARNING] Authentication failed for user [rollerscapes]
    Sep 11 16:57:45 rollerscapes pure-ftpd: (?@rollerscapes.net) [INFO] Logout.
    En ik kan met iedere naam inloggen, maar ik kom er niet in.
    Zoals boven is te zien moet hij de gebruikers uit een postgresql database halen.

    Als iemand het weet alfast bedankt.
    Park The Hosting Manager - your friend in hosting software

  2. #2
    Beginnen met PureFTPd, dat begint lekker...
    Mentally unstable
    2.586 Berichten
    Ingeschreven
    27/06/03

    Locatie
    Rivierenland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 11058224
    Ondernemingsnummer: nvt

    - heb je wel users aangemaakt?
    - heb je daarna wel mkdb uitgevoerd.

  3. #3
    Beginnen met PureFTPd, dat begint lekker...
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter
    Ik heb een user aangemaakt ja maar wat is mkdb ?? Daar stond niet van bij in de handlijding.

    En postgresql is gewoon goed.
    Park The Hosting Manager - your friend in hosting software

  4. #4
    Beginnen met PureFTPd, dat begint lekker...
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter
    Aangezien hij gebruik maakten van de oude library-files dacht ik, dan pas ik de nieuwe library-files toe.

    En raat is nu zeurd hij dat hij geen postgresql support heeft


    ./configure --prefix=/data/purepftd --with-ftpwho --with-largefile --with-pgsql=/data/postgresql8.0.3 --with-sysquotas --with-puredb --with-throttling --with-uploadscript --with-language=dutch --with-language=english --with-diraliases --with-peruserlimits --with-virtualhosts --with-libraries=/data/postgresql8.0.3/lib


    Terwijl postgresql toch echt is geinstalleerd in /data/postgresql8.0.3
    Park The Hosting Manager - your friend in hosting software

  5. #5
    Beginnen met PureFTPd, dat begint lekker...
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter
    Het probleem is zo goed als opgegelost.

    Pure-FTP is niet gezicht voor een client versie van postgresql8.

    En het echt probleem was: Waaneer leren mensen nu eens hun documentatie te controleren.

    Er werd gebruik gemaakt van hooftleters voor de veld namen maar niet in de query's... Hier kon hij de query niet eens uitvoeren.


    Als ik dit nu al vanaf het begint had geweten had ik nu niet zoon koppijn
    Park The Hosting Manager - your friend in hosting software

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics