Likes Likes:  0
Resultaten 1 tot 5 van de 5
Geen
  1. #1
    PHP chmod -> apache fout?
    RurouniKenshin.nl
    2.512 Berichten
    Ingeschreven
    21/12/03

    Locatie
    Apeldoorn

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Thread Starter

    PHP chmod -> apache fout?

    Ik dacht dat Johan al een topic voor me had gemaakt omdat ik niet op WHT kon komen. Maar kan deze niet vinden, dus stel ik de vraag zelf:

    Iemand belde mij gister op met de vraag of apache op de server wel goed werkte. Het probleem was dat meneer plaatjes wil uploaden en verwijderen in een bepaalde map via php. Hiervoor wil hij géén chmod gebruiken aangezien dit niet risicovrij is. Meneer beweert dat het ook mogelijk is zonder chmodden en dat er in dit geval een fout in apache zit op mijn server. (server van flydesign in dit geval) Maar hoe kan ik dit oplossen? Hoe kan ik zorgen dat meneer wel zijn plaatjes kan uploaden en verwijderen zonder die map rechten te geven en dit wel doormiddel van php mogelijk te maken?

  2. #2
    PHP chmod -> apache fout?
    Mentally unstable
    2.586 Berichten
    Ingeschreven
    27/06/03

    Locatie
    Rivierenland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 11058224
    Ondernemingsnummer: nvt


  3. #3
    PHP chmod -> apache fout?
    geregistreerd gebruiker
    36 Berichten
    Ingeschreven
    25/06/04

    Locatie
    Europa

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: x
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    uhm nou wat zijn dan de precieze risico's als meneer de map voor uploads op 777 zet?
    Dan is het probleem toch opgelost?

  4. #4
    PHP chmod -> apache fout?
    Cloud hoster
    182 Berichten
    Ingeschreven
    30/12/03

    Locatie
    Amstelveen

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 34175113
    Ondernemingsnummer: nvt

    Installeer phpSuExec, dan draaien de php scripts als de user dus kunnen de scripts naar de maps schrijven aangezien het de zelfde eigenaar is.

  5. #5
    PHP chmod -> apache fout?
    geregistreerd gebruiker
    172 Berichten
    Ingeschreven
    17/05/03

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 04073143
    Ondernemingsnummer: nvt

    Origineel geplaatst door MrD
    Installeer phpSuExec, dan draaien de php scripts als de user dus kunnen de scripts naar de maps schrijven aangezien het de zelfde eigenaar is.
    Inderdaad. Je kunt ook suPHP gebruiken, betere "compatibiliteit" vergeleken met phpsuexec.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics