Likes Likes:  0
Resultaten 1 tot 7 van de 7
Geen
  1. #1
    uploaden via cronjob [rh9] (ftp)
    geregistreerd gebruiker
    672 Berichten
    Ingeschreven
    18/09/02

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 37101101
    Ondernemingsnummer: nvt

    Thread Starter

    uploaden via cronjob [rh9] (ftp)

    Ivm het backuppen van een map-inhoud naar andere server de volgende vraag:

    Is dit mogelijk middels een cron bestandje?

    Heb dus shell root toegang op een rh9 systeem waar de gehele inhoud van 1 map (server backup) iedere dag naar een ftp account op een andere server geupload moet worden.

    Nu zat ik zelf te denken aan een cronjob, die dit iedere nacht om 4u kan doen, maar is dit mogelijk/ veilig?

    Normale upload gaat wel:
    # ftp [host.nl]
    # ff inloggen
    ftp> put -r map*
    ftp> exit

    Maar wat moet ik in de cron file zetten zodat login->upload_inhoud->loguit vanzelf gaat?

    wget is geen alternatief gezien ik geen shell rechten heb op backup server (alleen ftp account).

  2. #2
    uploaden via cronjob [rh9] (ftp)
    geregistreerd gebruiker
    30 Berichten
    Ingeschreven
    15/05/04

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Met een simpel ftp scriptje is dat wel te doen:

    #!/bin/bash
    lftp <<EOF
    open host.nl
    user user pass
    pwd
    put -r map*
    bye
    EOF

    dan het scipt toevoegen in cron.

  3. #3
    uploaden via cronjob [rh9] (ftp)
    geregistreerd gebruiker
    672 Berichten
    Ingeschreven
    18/09/02

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 37101101
    Ondernemingsnummer: nvt

    Thread Starter
    Heel erg bedankt m2k.

    Weet je toevallig ook hoe ik de hele map inhoud kan uploaden, dus ook de sub-mappen?

    put -r werkt niet, moet natuurlijk zijn mput * dat verplaatsts alle bestanden in de lcd map, maar niet de bestaande sub-mappen van de local map.

    Heb nu:

    #!/bin/bash
    lftp <<EOF
    open host.nl
    user user pass
    pwd
    lcd /home/backup
    cd /backup
    bin
    prompt
    mput *
    close
    bye
    EOF

    Verder geeft de output de volgende errors:
    Unknown command `prompt'.
    Unknown command `bin'


    Als laatst moet passive-mode worden gebruik bij het connecten, nu werkt het alleen met de firewall op stop.

    Alvast heel erg bedankt
    Laatst gewijzigd door Bob2; 11/06/04 om 00:56.

  4. #4
    uploaden via cronjob [rh9] (ftp)
    geregistreerd gebruiker
    30 Berichten
    Ingeschreven
    15/05/04

    Locatie
    Almere

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Wat je kan proberen is zoiets:

    #!/bin/bash
    FILES=`find /root/ -printf "%p "`
    lftp <<EOF
    open host.nl
    user user pass
    pwd
    cd /backup/
    mput -d $FILES
    bye
    EOF


    Ik weet niet of het werkt maar probeer dit eens voor passive:
    ftp:passive-mode true
    Laatst gewijzigd door M2k; 11/06/04 om 07:41.

  5. #5
    uploaden via cronjob [rh9] (ftp)
    geregistreerd gebruiker
    241 Berichten
    Ingeschreven
    24/06/03

    Locatie
    Amsterdam

    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: BV, 30141839
    Ondernemingsnummer: nvt

    ncftpget en ncftpput zijn hier ook erg geschikt voor.

  6. #6
    uploaden via cronjob [rh9] (ftp)
    geregistreerd gebruiker
    672 Berichten
    Ingeschreven
    18/09/02

    Locatie
    NL

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 37101101
    Ondernemingsnummer: nvt

    Thread Starter
    Bedankt Leaseweb, werkt idd erg makkelijk!
    Alleen heb ik nog een klein probleempje met de firewall op de remote server. Als deze aan staat werkt het uploaden via ncftpput maar gedeeltelijk met errors:

    -------------------------------------
    [root@plesk home]# ncftpput -R -u username -p password remote_host.nl /backup /home/backup/*
    connect failed: Connection refused.
    Falling back to PORT instead of PASV mode.
    Could not read reply from control connection -- timed out.
    ncftpput /home/backup/06-09-04: timed out while waiting for server response.
    ncftpput /home/backup/06-10-04: remote host closed control connection.
    ncftpput /home/backup/mysqlbk.sql: remote host closed control connection.
    [root@plesk home]#
    --------------------------------------

    Als ik de firewall uit zet op de remote host dan werkt het wel perfect:

    -------------------------------
    [root@plesk home]# ncftpput -R -u username -p password remote_host.nl /backup /home/backup/*
    /home/backup/06-09-04/custom/etc.tar.gz: 687.70 kB 8.83 MB/s
    /home/backup/06-09-04/custom/etc.md5: 76.00 B 134.70 kB/s
    /home/backup/06-09-04/custom/usr/local/psa.tar.gz: 28.49 MB 9.28 MB/s
    /home/backup/06-09-04/custom/usr/local/psa.md5: 86.00 B 129.81 kB/s
    /home/backup/06-09-04/custom/home/httpd.tar.gz: 102.30 MB 10.55 MB/s
    -----------------------------------


    Wat is er mis met de rules:

    *filter
    :INPUT ACCEPT [0:0]
    :FORWARD ACCEPT [0:0]
    UTPUT ACCEPT [0:0]
    :RH-Lokkit-0-50-INPUT - [0:0]
    -A INPUT -j RH-Lokkit-0-50-INPUT
    -A FORWARD -j RH-Lokkit-0-50-INPUT
    -A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 443 --syn -j ACCEPT
    -A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 8443 --syn -j ACCEPT
    -A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 80 --syn -j ACCEPT
    -A RH-Lokkit-0-50-INPUT -p udp -m udp --dport 53 -j ACCEPT
    -A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 21 --syn -j ACCEPT
    -A RH-Lokkit-0-50-INPUT -p tcp -m tcp --dport 22 --syn -j ACCEPT
    -A RH-Lokkit-0-50-INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
    -A RH-Lokkit-0-50-INPUT -i lo -j ACCEPT
    -A RH-Lokkit-0-50-INPUT -p tcp -m tcp --syn -j REJECT
    -A RH-Lokkit-0-50-INPUT -p udp -m udp -j REJECT [/B][/QUOTE]

  7. #7
    uploaden via cronjob [rh9] (ftp)
    MijnAlbum BV
    110 Berichten
    Ingeschreven
    28/06/03

    Locatie
    Heerenveen, FRL

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Ja
    KvK nummer: 01105144
    Ondernemingsnummer: Nvt

    Doe es 'lsmod' en kijk of de ip_conntrack_ftp module is geladen. Je laadt die module met 'modprobe ip_conntrack_ftp' mits de juiste kernelopties zijn geselecteerd bij het compilen..

    Overigens zou ik voor dit backupsysteem de tool rsync gebruiken, wat std. op de meeste servers staat.

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics