Hallo,
Mijn systeem is opeens overgegaan op een read-only filesystem waardoor ik dus niets meer kan doen.
Is er misschien een commando om dat uit te zetten en wat kan de oorzaak zijn?
Running on: Debian 3.0 R1
Alvast Bedankt,
Stef
Likes: 0
Hallo,
Mijn systeem is opeens overgegaan op een read-only filesystem waardoor ik dus niets meer kan doen.
Is er misschien een commando om dat uit te zetten en wat kan de oorzaak zijn?
Running on: Debian 3.0 R1
Alvast Bedankt,
Stef
Laatst gewijzigd door ja3; 02/11/03 om 14:54.
ik zou toch eerst nagaan waarom die in read-only mode zit (waarschijnlijk is fsck mislukt, en moet je het handmatig uitvoeren).
Anders kan je even een restart geven, zou het probleem op kunnen lossen.
is ie niet gehackt en alls op chmod 'read-only' gezet?
denk dat je dan toch het zaaitje bent![]()
je kan ook proberen
mount -o remount,rw {mountpoint}
Laatst gewijzigd door LeaseWeb; 03/11/03 om 14:12.
server01:/# mount -o remount,rw /dev/hda3
mount: block device /dev/hda3 is write-protected, mounting read-only
Dit werkt dus ook niet en ik krijg hem niet gereboot dat geeft er ook een error door.
ben bang dat je dan een probleem hebt
root ?![]()
Volgens mij zit er gewoon een kapotte harddisk in ik heb nu alles al geprobeerd.. steets als hij tussen 20 en 28 uur up is gaat het op read only...
lijkt mij dan geen kapotte hdd, maar 1 of andere script/programma dat de boel vastzet, controleer je cron jobs / log eens?
Nov 6 06:34:19 server01 kernel: hda: write_intr: status=0x51 { DriveReady SeekComplete Error }
Nov 6 06:34:19 server01 kernel: hda: write_intr: error=0x04 { DriveStatusError }
Nov 6 06:34:24 server01 kernel: hda: write_intr error1: nr_sectors=1, stat=0x51
Nov 6 06:34:24 server01 kernel: hda: write_intr: status=0x51 { DriveReady SeekComplete Error }
Nov 6 06:34:24 server01 kernel: hda: write_intr: error=0x04 { DriveStatusError }
Nov 6 06:34:29 server01 kernel: hda: write_intr error1: nr_sectors=1, stat=0x51
Nov 6 06:34:29 server01 kernel: hda: write_intr: status=0x51 { DriveReady SeekComplete Error }
Nov 6 06:34:29 server01 kernel: hda: write_intr: error=0x04 { DriveStatusError }
Nov 6 06:34:29 server01 kernel: ide0: reset: success
Nov 6 06:34:33 server01 kernel: hda: write_intr error1: nr_sectors=1, stat=0x51
Nov 6 06:34:33 server01 kernel: hda: write_intr: status=0x51 { DriveReady SeekComplete Error }
Allemaal van zulke errors zitten er in de kernel.log
Dat lijkt inderdaad op een defecte schijf.
soms wil het (tijdelijk) helpen om DMA uit te zetten "hdparm -d 0 /dev/hdX" (waarbij X = schijf (hda voor primary master))
De perfomance gaat omlaag en de serverload omhoog, maar je kan wel weer schrijven.
Ik zou wel de schijf zsm vervangen.
Ja kan ook een fsck met runnen met badblocks of dat misschien een reden is voor de foutmeldingen.