Afgelopen week is op een webserver die wij beheren de sshd daemon gesloten. Waardoor we uiteraard niet meer remote konden inloggen.
Het probleem is inmiddels verholpen, maar ik blijf met vraagtekens zitten hoe dit heeft kunnen plaatsvinden. Ik wil het uiteraard niet nogmaals meemaken.
Op een ochtend kreeg ik een SMS dat enkel de SSH-port onbereikbaar was, dus ik ging kijken wat er loos was. Hier bleek alles gewoon nog te draaien, behalve dat ik niet meer kon connecten. Het filesystem van deze server is gekoppeld aan een 2tal andere servers, waardoor ik gelukkig enige toegang had tot de server.
Ik kwam erachter in een logbestand dat er het volgende was gebeurt, zonder enige andere melding:
May 1 xx:14:45 webserver sshd: sshd -TERM succeeded
May 1 xx:14:45 webserver sshd: /usr/sbin/sshd: error while loading shared libraries: libz.so.1: cannot open shared object file: No such file or directory
May 1 xx:14:45 webserver sshd: failed
Na het achterhalen waarom deze foutmelding werd weergegeven kwam ik erachter dat:
- /etc/ssh/sshd_config nog wel bestond, maar helemaal leeg was
- /usr/lib/libz.so.1 niet meer aanwezig was
Ik heb het probleem kunnen oplossen door de sshd_config te restoren vanuit de backup.
En libz.so.1 opnieuw aan te maken (ergens een kopie van een soortgelijke server + os). Vervolgens door een reboot was het probleem opgelost.
De server draait op centos 4.3 met kernel 2.6.9-34.ELsmp.
Komt iemand de bovenstaande situatie bekend voor, zo ja: weet iemand de mogelijke oorzaak en oplossing om dit soort zaken in de toekomst te voorkomen?
Alvast bedankt!

Likes:

