Likes Likes:  0
Resultaten 1 tot 15 van de 21
Pagina 1 van de 2 1 2 LaatsteLaatste
  1. #1
    MySQL wijgert de gebruiker te verwijderen!
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter

    Angry MySQL wijgert de gebruiker te verwijderen!

    Dit is echt zo'n dag dat het niet leuk is programmeur te zijn , voor de webhosting bied ik MySQL database ondersteuning aan.

    Ik heb zelf het controlepaneel daar voor geschreven, maar nu moet ik een database gebruiker verwijderen.
    Dus doe ik deze query uitvoeren:
    DROP USER 'user_5'@ 'localhost';

    Dat heb ik uit de handleiding gehaald
    Zowel de server als de client zijn: 5.0.24a-standard-log

    Maar dan toch krijg ik (IK ZOU NIET WETEN WAAROM) deze melding:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''localhost'' at line 1

    Staat gewoon in de handleiding wat ik moet doen, maar het werkt gewoon niet?

    Ik had ook al een topic ge opent op PHP-Freazk maar dit heeft nog helaas niet veel opgeleverd.

    Ik ben echt al 3 uur bezig dit aan de praat te krijgen, ik neem over wat er in de handleiding staat ik heb MySQL5 en nog werkt het voor geen meter

    Dus wie kan mij het verlossende antwoord geven.
    Park The Hosting Manager - your friend in hosting software

  2. #2
    MySQL wijgert de gebruiker te verwijderen!
    geregistreerd gebruiker
    465 Berichten
    Ingeschreven
    11/02/04

    Locatie
    Venlo

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: Nee
    KvK nummer: 12037834
    Ondernemingsnummer: nvt

    phpMyAdmin installeren en dan de shit deleten..

  3. #3
    MySQL wijgert de gebruiker te verwijderen!
    Banned
    794 Berichten
    Ingeschreven
    02/03/05

    Locatie
    Mijdrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 30203392
    Ondernemingsnummer: nvt

    [mompelmode]
    Iets met dingen die je niet ziet, maar er wel zijn.
    [/mompelmode]

  4. #4
    MySQL wijgert de gebruiker te verwijderen!
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter
    Ja dat ken ik, maar het is niet voor mij
    Het is voor de klanten die MySQL willen en gebruikers aanmaken en zo.

    Ik zelf werk met PostgreSQL

    Edit:
    Citaat Oorspronkelijk geplaatst door bakkerl Bekijk Berichten
    [mompelmode]
    Iets met dingen die je niet ziet, maar er wel zijn.
    [/mompelmode]
    Bedoel je de handleiding?
    Daar had ik het juist gevonden, en volgens dat zou het goed moeten zijn.
    Maar gezien de hele staat van MySQL is dat ook onzin.
    Park The Hosting Manager - your friend in hosting software

  5. #5
    MySQL wijgert de gebruiker te verwijderen!
    moderator
    7.022 Berichten
    Ingeschreven
    29/07/03

    Locatie
    Nijmegen

    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    175 Berichten zijn liked


    Naam: Mike
    Bedrijf: admin.nu
    URL: www.admin.nu
    Registrar SIDN: Ja
    KvK nummer: 09139651

    Wel vreemd dat jij altijd diegene bent die er niet mee kan werken, soms zegt de gebruiker ook al genoeg hoe een bepaald stukje software uiteindelijk functioneert.
    "Zo zijn ook wij één leverancier. Dé leverancier in gedegen Linux kennis, wanneer jij dat nodig hebt."
    Boek je admin vandaag nog via : www.admin.nu
    Gevestigd in Nederland en Moldavië

    Lees hier de webhostingtalk.nl forum regels en voorwaarden!

  6. #6
    MySQL wijgert de gebruiker te verwijderen!
    Banned
    794 Berichten
    Ingeschreven
    02/03/05

    Locatie
    Mijdrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 30203392
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door Rollerscapes Bekijk Berichten
    Bedoel je de handleiding?
    Daar had ik het juist gevonden, en volgens dat zou het goed moeten zijn.
    Maar gezien de hele staat van MySQL is dat ook onzin.
    Neuh, de handleiding is vrij duidelijk en geeft op de meeste vragen wel een correct antwoord. Gezien de orginele vraag is meer de gebruiker die onzin aan het geven is aan MySQL. Wat ook door MySQL bevestigd wordt gezien je een foutmelding krijgt.

    /me blijft erbij dat die in zijn eerste reply al 'het' antwoord gegeven heb.

  7. #7
    MySQL wijgert de gebruiker te verwijderen!
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter
    Ik maak wel is mijn fouten, geef ik eerlijk toe.
    Maar dit, een syntax fout in regel code die notabene uit de handleiding komt

    Ik was vergeten te melden dat ik nog andere dingen had probeerd:
    Zonder '' dus gewoon.
    DROP USER user_5;

    Zonder succes...
    Park The Hosting Manager - your friend in hosting software

  8. #8
    MySQL wijgert de gebruiker te verwijderen!
    Banned
    794 Berichten
    Ingeschreven
    02/03/05

    Locatie
    Mijdrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 30203392
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door Rollerscapes Bekijk Berichten
    Ik maak wel is mijn fouten, geef ik eerlijk toe.
    Maar dit, een syntax fout in regel code die notabene uit de handleiding komt
    Mag ik dan een verwijzing naar de handleiding. Dan wil ik wel een bevestiging geven of de fout in die handleiding dit of dat het toch aan de gebruiker achter het toetsenbord is geweest.

    Indien die handleiding fout is zal ik je direct het juiste antwoord geven

  9. #9
    MySQL wijgert de gebruiker te verwijderen!
    blabla
    191 Berichten
    Ingeschreven
    30/08/04

    Locatie
    Nederland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Niet toevallig die spatie mee gekopieerd tussen @ en 'localhost' ?

  10. #10
    MySQL wijgert de gebruiker te verwijderen!
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter
    WAT oke hij werkt nu, de handleiding beweerd dat ik '' moet gebruiken bij de gebruikersnaam.

    Maar zonder '' en en wel de hostname doet hij het gewoon.
    Wat ik op doel met mijn (gezeur) is het volgende:

    1. Ze beweren dat je '' moet gebruiken, NIET DUS
    2. Dan krijg je nog zo'n leuke melding dat de syntax niet goed is, ja wat dan? de handleiding zij het toch echt zo...
    3. Als ik hem dan zover krijg hem te verwerken krijg ik een melding, dat kan niet, ja wat kan dan niet? bestaat de gebruiker niert is de tabel niet berijkbaar of zo.

    Bij PostgreSQL heb de beschikking over een normale duidelijke handleiding en als ik iets fout doet dan krijg ik zelfs een suggestie!
    Er zijn dan nog zat mensen die MySQL het besten vinden maar als je hebt gewerkt met PostgreSQL wil nooit meer iets met MySQL te maken hebben.
    Vandaar ook mijn soms wat koord door de bocht uitspraken

    Edit ik citeer:
    Each account is named using the same format as for the GRANT statement; for example, 'jeffrey'@'localhost'. If you specify only the username part of the account name, a hostname part of '%' is used. For additional information about specifying account names, see Section 13.5.1.3, “GRANT Syntax”.
    Ze zeggen gebruik '', nou mooi dat het niet zo is
    Laatst gewijzigd door SebastiaanStok; 30/01/07 om 17:10.
    Park The Hosting Manager - your friend in hosting software

  11. #11
    MySQL wijgert de gebruiker te verwijderen!
    Banned
    794 Berichten
    Ingeschreven
    02/03/05

    Locatie
    Mijdrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 30203392
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door Rollerscapes Bekijk Berichten
    WAT oke hij werkt nu, de handleiding beweerd dat ik '' moet gebruiken bij de gebruikersnaam.

    Maar zonder '' en en wel de hostname doet hij het gewoon.
    Wat ik op doel met mijn (gezeur) is het volgende:

    1. Ze beweren dat je '' moet gebruiken, NIET DUS
    met en zonder '' zal die accepteren. Even aangenomen dat je namen zonder spaties gebruikt, anders ben je verplicht om '' te gebruiken. Het is dus zelfs beter als je wel altijd '' gebruikt om de usernaam en hostnaam.

    2. Dan krijg je nog zo'n leuke melding dat de syntax niet goed is, ja wat dan? de handleiding zij het toch echt zo...
    Nope. De SQL die jij in je openings post geeft zal inderdaad niet werken. Omdat daar nu eenmaal een fout inzit. punt.

    3. Als ik hem dan zover krijg hem te verwerken krijg ik een melding, dat kan niet, ja wat kan dan niet? bestaat de gebruiker niert is de tabel niet berijkbaar of zo.
    Er staat toch duidelijk SYNTAX fout. Dat betekend dat de sql die je opgeeft niet klopt. Dan is er nog niet eens in een database file gekeken wat daar instaat. Jou opdracht wordt simpelweg niet gesnapt omdat die niet correct is.

    Bij PostgreSQL heb de beschikking over een normale duidelijke handleiding en als ik iets fout doet dan krijg ik zelfs een suggestie!
    Er zijn dan nog zat mensen die MySQL het besten vinden maar als je hebt gewerkt met PostgreSQL wil nooit meer iets met MySQL te maken hebben.
    Vandaar ook mijn soms wat koord door de bocht uitspraken
    Ik wil een zelfde soort fout ook wel produceren in postgress. Dan gaat die echt niet een suggestie geven die het probleem gaat verhelpen.

    Dat jij als gebruiker gewoon niet een SQL commando goed kan inkloppen, wil nog niet zeggen dat het product er achter bagger is.

    Ik zie hier alleen een probleem welke duidelijk veroorzaakt is door de gebruiker.
    En je heb nog steeds geen link gaan de bewust documentatie url gegeven.

    Omdat je aan het bijciteren ben geweest.. edit..
    Omdat het antwoord al gegeven is.

    ik zou de SPATIE tussen @ en 'localhost' in de SQL van je openings post eens weghalen. Dan zul je gewoon zien dat het werkt. Je heb het voorbeeld van de helppagina dus gewoon ZELF niet goed overgenomen.
    Maar het is o zo makkelijk om de applicatie de schuld te geven. Dat valt bij mij onder de noemer "bagger in, bagger uit". Er alleen de gebruiker zorgt dat er bagger ingaat.

    -- samenvatting --
    Het probleem zit in de gebruiker!
    Laatst gewijzigd door bakkerl; 30/01/07 om 17:20.

  12. #12
    MySQL wijgert de gebruiker te verwijderen!
    Sebastiaan Stok
    2.468 Berichten
    Ingeschreven
    20/12/04

    Locatie
    Rotterdam

    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    86 Berichten zijn liked


    Naam: Sebastiaan Stok

    Thread Starter
    http://dev.mysql.com/doc/refman/5.0/en/drop-user.html

    Echt als ik de '' gebruik bij de gebruikersnaam zelf doet hij het echt niet hoor

    DROP USER 'user_5'@ 'localhost';
    Werkt niet

    DROP USER user_5@ 'localhost';
    Werkt wel!

    Omdat de gebruikersnaam een SQL statement is, het is immers een gebruiker.
    Die moet ik altijd aanmaken zonder '', maar bijvoorbeeld met `` (Dat zal bij de handleiding wel een type fout zijn geweest of zo)

    Wat ik bedoelde met niet duidelijk foutmelding.
    #1396 - Operation DROP USER failed for 'user_5'@'%'

    Ik wouw al wat meer informatie geven maar ik kreeg hem eindelijk na drie uur werkend, dus was ik dit even vergeten.

    PostgreSQL (en niet postgres) geeft niet altijd een sugestie, maar als ik bijvoorbeeld een functie aanroept die niet bestaat dan geeft hij dat die functie gewoon niet bestaat en niet dat de query fout is of zo.


    En waarom ik iets heb tegen MySQL:
    1. Breekt de SQL standaarts
    2. Heeft tot MySQL5 geen ondersteuning voor Sub-querys
    3. Als ik een CHAR aan maakt en een VARCHAR maakt hij van die CHAR een varchar, waarom ik heb toch gezegt CHAR
    4. Je kan heel makkelijk de hooft gebruiker verwijderen en zo je zelf compleet buiten sluiten
    5. Backupen is een ramp, je moet alles read-only maken en dan dan als hij nog is veel moeten gaan verwerken loopt de hele mysql server vast met het risico van data corruptie wat in deze moderne tijden toch niet meer moet kunnen.

    Etc...
    Meer over hoe goed wel niet is:
    http://www.yapf.net/Articles/ArticleView/803
    http://www.yapf.net/Forum/topicview/...ROUP_BY_ROLLUP

    Maar het probleem is opgelost dus zullen we ophouden met modder gooien
    Park The Hosting Manager - your friend in hosting software

  13. #13
    MySQL wijgert de gebruiker te verwijderen!
    geregistreerd gebruiker
    278 Berichten
    Ingeschreven
    24/03/06

    Locatie
    Westland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: ja
    KvK nummer: 27278354
    Ondernemingsnummer: nvt

    Ik vraag met toch elke keer weer af waarom er altijd gelijk geschreeuwd moet worden dat "MySQL sucks, PostgreSQL pwns!". Als MySQL zo sucked, waarom is het dan de meeste gebruikte dbms op het internet?

    Net zo belachelijk als de hele "windows sux, linux owned" ongein, waarom moet het (bijna) altijd OF het 1, OF het ander zijn? Waarom voelen zoveel mensen de drang om altijd gelijk maar weer te gaan schreeuwen dat iets "sucked"?

    De beste oplossing hangt van de situatie af. Soms is dat MySQL, soms PostgreSQL, soms windows, soms linux, soms BSD. Wij als professionals zouden met z'n allen echt eens moeten stoppen met zo kinderachtig te doen.

    Zeker als blijkt dat 99% van de problemen een gevalletje PEBKAC is, zoals ook dit keer :-)

  14. #14
    MySQL wijgert de gebruiker te verwijderen!
    Banned
    794 Berichten
    Ingeschreven
    02/03/05

    Locatie
    Mijdrecht

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: 30203392
    Ondernemingsnummer: nvt

    En dan nog een keer omdat je echt je eigen stommiteit niet wil zien dat een spatie tussen de @ en 'localhost' er niet hoord. De output van beide commando's

    Code:
    SQL query:
    DROP USER 'user_5'@ 'localhost';
    
    MySQL said: Documentation
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''localhost'' at line 1

    Code:
    DROP USER 'user_5'@'localhost';
    Your SQL query has been executed successfully (Query took 0.0003 sec)
    Let even op de spatie. Het heeft dus weinig met de '' te maken.

    Daarnaast kun je klanten die MySQL gebruiken altijd afwijzen als je MySQL zo bagger vindt.
    Laatst gewijzigd door bakkerl; 30/01/07 om 18:33.

  15. #15
    MySQL wijgert de gebruiker te verwijderen!
    geregistreerd gebruiker
    5.163 Berichten
    Ingeschreven
    04/06/05

    Locatie
    Zeeland

    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    0 Berichten zijn liked


    Registrar SIDN: nee
    KvK nummer: nvt
    Ondernemingsnummer: nvt

    Citaat Oorspronkelijk geplaatst door Rollerscapes Bekijk Berichten
    En waarom ik iets heb tegen MySQL:
    1. Breekt de SQL standaarts
    2. Heeft tot MySQL5 geen ondersteuning voor Sub-querys
    3. Als ik een CHAR aan maakt en een VARCHAR maakt hij van die CHAR een varchar, waarom ik heb toch gezegt CHAR
    4. Je kan heel makkelijk de hooft gebruiker verwijderen en zo je zelf compleet buiten sluiten
    5. Backupen is een ramp, je moet alles read-only maken en dan dan als hij nog is veel moeten gaan verwerken loopt de hele mysql server vast met het risico van data corruptie wat in deze moderne tijden toch niet meer moet kunnen.
    Ieder vogeltje zingt zoals het gebekt is.

    Ik zal verder maar niet op de door jou genoemde punten in gaan. Als je er echt iets op tegen heb gebruik het dan gewoon niet, ook niet voor je klanten.

Pagina 1 van de 2 1 2 LaatsteLaatste

Labels voor dit Bericht

Webhostingtalk.nl

Contact

  • Rokin 113-115
  • 1012 KP, Amsterdam
  • Nederland
  • Contact
© Copyright 2001-2026 Webhostingtalk.nl.
Web Statistics