Zonder iemand aan te kijken ..... vind hem wel leuk, kende deze nog niet :D
Afdrukvoorbeeld
Uhm (voorzichtige vraag), wat is er mis met:Code:delete from mysql.user where user = 'user_5';
flush privileges;
Dan nog is die spatie niet mijn fout :)
Zo stond het ook in de handleiding, nog beter er was geen duidelijk voorbeeld hoe ik het moest doen in combinatie met een hostname, iemand anders had hier ook al over geklaagd, maar is volgens mij nog niets mij gedaan.
En dit is ook de uitvoer die phpmydmin terug geeft.
Als ik geen duidelijkheid hebt over iets moet is mij niets te verwijten.
MySQL niet aanbieden zou wel mooi zijn maar dan loop je toch die groep mensen mis die het wel willen gebruiken, maar daarom bied ik ook een conversie tool aan om van mysql naar pgsql om te zetten.
De reden waarom de meesten mensen voor mysql kiezen is omdat het makkelijk is in het gebruik en tot in tegenstelling van postgresql wel windows ondersteuning heeft, bij postgresql is dat pas bij versie 8 gebeurd.
Ik had (misschien) iets minder mysql moeten afkraken maar als je al een dag bezig bent met iets dat niet lukt kan je zelfs een foutloze software afkraken.
De broncode van het klanten paneel was sowieso een dieven klus om te doen dus dat heeft ook een rol gespeeld.
Dus al met al weer samenloop van omstandig heden en geen duidelijkheid.
Ik zit ook elke dag weer MS aftekraken maar blijf het ook gebruiken, bij mij mysql heb je verschillende alternatieven.
en als je voorkeur licht bij mysql, oke :)
Het probleem is nu opgelost er duidelijk wat er fout is, dus?
Als ik kijk op http://dev.mysql.com/doc/refman/5.1/en/drop-user.html (wat me toch een handleiding lijkt welke van MySQL zelf is, dan zie ik daar een voorbeeld hoe de combi met de hostnaam. Tevens zie ik daarin geen spatie staan.
Tevens zie ik _geen_ user comments staan. Tevens als ik kijk bij de 5.0 en 4.1 link van de zelfde commando's zie ik geen user comments staan.
Ik weet dus niet waar je zit te kijken, want dat heb je nog steeds niet vermeld, maar als ik kijk bij de 'officiele' documentatie zie ik dus een voorbeeld en dat zonder klachten.
Een syntax error is toch vrij duidelijk. De regel die je geeft valt niet te interperteren door de applicatie. Het stuk wat die kan interperteren klaagt die niet over, maar geeft nog wel aan vanaf waar die het niet meer snapt (het eerste woord wat er dan niet begrepen wordt).Citaat:
En dit is ook de uitvoer die phpmydmin terug geeft.
Als ik geen duidelijkheid hebt over iets moet is mij niets te verwijten.
Emoties spelen mee. Maar begin dan niet zelf ook dingen te beweren welke niet waar zijn. Beweren dat de handleiding fout is omdat daar wel '' staan, terwijl dat echt fout zou zijn. Het is niet fout, dat werkt gewoon, alleen niet als je een spatie teveel neerzet.Citaat:
Ik had (misschien) iets minder mysql moeten afkraken maar als je al een dag bezig bent met iets dat niet lukt kan je zelfs een foutloze software afkraken.
De broncode van het klanten paneel was sowieso een dieven klus om te doen dus dat heeft ook een rol gespeeld.
Dus al met al weer samenloop van omstandig heden en geen duidelijkheid.
Ik hou het nog steeds op die spatie in je SQL statement welke je het probleem geeft. '<user>'@'<hostnaam>' moet geheel zonder spaties.Citaat:
Het probleem is nu opgelost er duidelijk wat er fout is, dus?
Deze gaat op slot. Wil je mysql vs psql bespreken, open je maar een nieuw topic.